Über

Über / About
 Startseite Vor
Hilfefile zur / Help file for /
UserLib JHRegistry_394 von / by Jens Haipeter

Library:
V1.01 vom / built 11.06.2007
Hilfe / Help:
V1.01 vom / built 11.06.2007

Die Library ist ausschließlich für: PB 3.94 / Windows-Version /
The library is only for PB3.94, windows version

Windows Vista tauglich

In Anlehnung an die JHRegistry_400 und angeregt durch Probleme mit anderen UserLibrarys unter Windows Vista habe ich mich entschieden, diese Library noch zu veröffentlichen, obwohl PB 394 nicht mehr der aktuelle Stand ist. Es kann sein, daß
in dieser Hilfe Bezug auf PB 400 genommen wird oder aber Funktionen enthalten sind, die ich nicht in die 3.94 Version übernommen habe.
Diese UserLibrary wurde geschrieben für PureBasic Version 3.94. Sie dient der Abfrage, Eintragung und Entfernung von Registryschlüsseln. Alle Funktionen wurden mehrfach getestet. Es wird keinerlei Garantie auf Funktion oder Nichtfunktion übernommen. Die Benutzung erfolgt auf eigene Gefahr, da ich keinen Einfluß auf korrekte Eintragung der Schlüsselworte für die Registry habe. Benutzen Sie die Funktionen der Library mit Bedacht. Eine unsachgemässe Anwendung führt sonst möglicher Weise zu einem Systemcrash, besonders bei unsachgemäßer Verwendung der Löschfunktionen. Außerdem sind einige
weitere Funktionen enthalten, siehe Funktionsliste .

English
This UserLibrary was written for PureBasic version 3.94. for you serves the query, entry, change and distance of registry keys. All functions were tested repeatedly. No guarantee is taken on function or not function. The use carried out at her own risk, since no influence on correct entry for the keyword for the registry I have. Use the library functions deliberately. An improper application leads otherwise possible way to a system crash particularly at improper use of the deleting functions. In addition, some further functions are contained, see function list please.

Alle Textrückgabe erfolgen als ASCII-Zeichenfolge, kein Unicode! /
Please note: All text returns are ASCII, not Unicode!

Verwendung fand ein Codebeispiel aus dem Codearchiv, jedoch wurden erhebliche Teile verändert beziehungsweise angepasst und erweitert. Die Basis ist dieser Code (für die Registryfunktionen): German forum: http://robsite.de/php/pureboard/viewtopic.php?t=1378&highlight=
Author: Manne Date: 16. June 2003 (updated on 26. July 2003)

Weiterhin fand für die Erstellung von Shell Shortlink ein Codebeispiel von Danilo Krahn Verwendung.

Dem Paket beigefügt ist ein Codebeispiel, welches alle Funktionen beinhaltet.
A code example which contains all functions is enclosed with the package.

Chemnitz, 12. Mai 2007

Jens Haipeter, Website: www.jens-haipeter.de


History
 Zurück Startseite Vor
Änderungen, Erweiterungen, Reparaturen an der UserLib

In der Version 1.00

- Public Release

Update V1.01 / 11.06.2007

- weitere Funktionen aus der 4.xx Version übernommen


Allgemeines

Allgemeines / General
allgemeine Vereinbarung / General agreements

Alle Stringrückgaben erfolgen bis auf weiteres als ASCII-Zeichenfolge. Ich bitte dies bei Unicode Programmen zu beachten. Die Library ist Windows Vista tauglich.

English

All string returns are ASCII. Please note it for Unicode programs. This library is god for Windows Vista.

Fehlermeldungen / ERROR-Messages

Alle eventuell auftretenden Fehler werden intern in einen String abgelegt, dessen Inhalt zu Beginn des Funktionsaufrufs geleert wird. Wird die aktuelle Funktion ohne Fehler beendet, so bleibt der String auch leer. Im Falle eines Fehlers wird der String mit einem adequaten Inhalt belegt. Nach dem einmaligen Aufruf der Fehlerfunktion wird der Inhalt geleert. Daher ist es zum einen nur sinnvoll direkt nach dem eigentlichen Funktionsaufruf eine Fehlerabfrage durchzuführen und zum anderen nicht möglich, die Fehlerabfrage mehrfach hintereinander zu machen. Alle Fehlertexte sind englisch.

Wenn man nur wissen möchte, ob ein Fehler aufgetreten ist, reicht es aus die ersten 5 Zeichen der Funktionsrückgabe von JHRegLastError() auszuwerten. Diese enthalten in dem Fall immer das Wort "ERROR".

Ebenfalls englisch sind alle Hinweise die in der Editorsyntaxvorschau angezeigt werden.

English
All faults appearing perhaps are put down internally into a string whose contents are emptied at the beginning of the function call. If the current function is ended without faults, then the string remains also emptily. In the case of a fault the string is covered with error contents. It´s only possible to make one error request directly after the function call. All fault texts are english.
If one only liked to know whether a fault has appeared, it hands out the first 5 signs of the function return of evaluate. This contained in the case always the word "ERROR".
All notes are also these shown on the editor syntax line be english.


Danksagungen

Danksagungen / Credits
Dank gilt an dieser Stelle / thanks for:

Manne aus dem PB Forum, der mit seinem Code die Grundlage geschaffen hat, ebenfalls danke, allerdings unbekannter Weise.

Danilo Krahn dessen Ursprungscode aus dem Forum mir für die Funktion des Shell Links Pate stand.

Miguel Calderon alias El_Choni für seinen Library-Maker Tailbite, ohne ihn wäre es unmöglich UserLib zu erstellen.

Allen ungenannten, die durch ihre Kritik zu Verbesserungen oder Veränderung beigetragen haben oder dies noch tun wollen ;) Es dürfen gern Vorschläge oder Wünsche auf meiner Webseite im Gästebuch oder im Forum hinterlassen werden.

English

By her criticism these have contributed to improvements or change or want to do this still all unnamed. Notes, suggestions being able to and so on be left on my web page in the forum or in the visitor's book. I will assume gratefully or pick up for changes her.


Functions

Funktionen / Functions
Registryfunktionen / Registry functions

Prüffunktion / examining functions

JHRegIsKey
JHRegGetValueType

SubKey Erstellfunktionen / SubKey create functions

JHRegCreateKey

SubKey Löschfunktionen / SubKey delete functions

JHRegDeleteKey

Eintrag Erstellfunktionen / value create/change functions

JHRegSetString
JHRegSetDW
JHRegSetBinary

Eintrag Lesefunktionen / value read functions

JHRegGetValue
JHRegGetString
JHRegGetDWord
JHRegGetBinary und JHRegGetBinarySize

Eintrag Löschfunktionen / value delete functions

JHRegDelValue

Auflistfunktionen / listing functions

JHRegListSubKey
JHRegListSubValue

Pfadfunktionen / path functions

JHRegGetDesktopPath
JHRegGetProgramsPath
JHRegGetStartmenuPath
JHRegGetStartMenuProgramsPath
JHRegGetSystemPath
JHRegGetPersonalPath
JHRegGetSystem32Path
JHRegGetWindowsPath
JHRegGetAplicationPath
JHRegGetAutostartPath
JHRegGetFontPath
JHRegGetFavoritePath
JHRegGetPBPath
JHRegCommonGetStartmenuPath
JHRegCommonGetStartmenuProgramsPath
JHRegGetUserDesktopPath
JHRegSelfsetPath

Daten der gerade laufenden EXE / dates of running exe

JHRegGetExeName
JHRegGetExeFullPath
JHRegGetCompilerExe

Desktop Auflösung feststellen / Show desktop dpi

JHRegGetDesktopDPI

Shortcut erstellen (Shell-Link)

JHRegCreateShortcutFull
JHRegCreateShortcutSimply

sonstige Funktionen / Other functions

JHRegFileExist()
JHRegStartOnlyOneInstance
JHRegGetLenOfText
JHRegSetLenOfText

einen Farbverlauf erstellen

JHRegCreateGradient

Versionsinformation

JHRegVersion
JHRegVersionDate
JHRegGetWindowsPlatform
JHRegGetWindowsVersion

Umwandlungen / Transformations

JHRegHexDez
JHRegBinHex
JHRegHexBin

Fehlermeldungsrückgabe / Error returns

JHRegLastError( )


JHRegGetExeFullpath

Funktion JHRegGetExeFullpath
Syntax

result.s=JHRegGetExeFullPath()

Beschreibung / Description

Gibt bei Abfrage den vollständigen Pfad inclusive des FilePart zur Exe zurück aus der die Abfrage erfolgte, z.B. "C:\Programme\MeinProgramm\Meine.exe".

English

At query gives the full path back to the running aplication, e.g. :"c\programs\myprogram\my.exe".

Rückgabewerte / Returns

- den Pfad wenn erfolgreich,
- the path if successful

Fehlerrückgabe / Error return

keine / no


JHRegGetExeName

Funktion JHRegGetExeName
Syntax

result.s=JHRegGetExeName()

Beschreibung / Description

Gibt bei Abfrage den Nmen der Exe zurück aus der die Abfrage erfolgte, z.B. "Meine.exe".

English

At query gives back the name of running aplication, e.g. :"my.exe".

Rückgabewerte / Returns

- den Namen wenn erfolgreich,
- the name if successful

Fehlerrückgabe / Error return

keine / no


JHRegGetCompilerExe

Funktion JHRegGetCompilerExe
Syntax

result.s=JHRegGetCompilerExe()

Beschreibung / Description

Gibt bei Abfrage den Status des Pfads zurück aus der die Abfrage erfolgte.

English

At query gives back the state of path from the running aplication.

Rückgabewerte / Returns

- #False wenn die exe nicht im Compilerpfad läuft
- #True wenn die exe im Compilerpfad läuft
- #False if not compiler running
- #True if compiler running

Fehlerrückgabe / Error return

keine / no


JHRegFileExist

Funktion JHRegFileExist()
 Zurück Startseite Vor
Syntax

result.l = JHRegFileExist(Path.s, File.s)
Beschreibung / Description

Die Funktion versucht anhand der Angaben festzustellen, ob ein File existiert.

English

This function contol if exist a file with the given name in the given path
Rückgabewerte / Returns

0 wenn das File nicht exisitiert
1 wenn das File existiert
-1 wenn der übergebene Pfadname leer war
-2 wenn der übergebene Filename leer war

English

0 if not exist a file with this name in this directory
1 if exist this file
-1 the given directory name was empty
-2 the given filename was empty


JHRegGetDesktopDPI

Funktion JHRegGetDesktopDPI
Syntax

result.l = JHRegGetDesktopDPI()

Beschreibung / Description

Diese Funktion gibt die eingestellte Auflösung des Desktops zurück. Standardmäßig ist 96 DPI eingestellt (kleine Schriftarten). Um jedoch in der Programmumgebung auch zu gewährleisten, das die Darstellung immer gleich ist, kann diese Funktion dazu benutzt werden, eine Schriftart zu wählen die immer im Verhältnis zu einer Ausgabe basierend auf der Standardeinstellung ein gleiches Aussehen der erstellten Fenster gewähleistet.

English

This function gives the oriented dissolving of the desktop back. Per default is oriented for 96 DPI (small scripts). Which is always the representation at once, this function can be used to this, a similar appearance of the erected windows makes on the standard attitude always basing this one in proportion to a version it possible a script to choose to also guarantee, however, in the program surroundings.

Rückgabewerte / Returns

- >Null wenn erfolgreich
- #False wenn die Ausgabe fehlgeschlagen ist
- greater than zero if successful
- #False at fault

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English
In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegGetLenOfText

Funktion JHRegGetLenOfText
Syntax

result.l = JHRegGetLenOfText(#Gadget)

Beschreibung / Description

Diese Funktion gibt die Länge der maximal möglichen Eingabe in ein Stringgadget zurück. Wurde vorher kein Wert gesetzt, so wird der Defaultwert zurückgegeben.

English

This function give back the maximal length of input into a stringgadget. If you don´t give a length befor, the result is default length.

Rückgabewerte / Returns

- die Länge wenn erfolgreich
- #False bei Fehler
- the length if successful
- #False at fault

Fehlerrückgabe / Error return

keine


JHRegGetWindowsPlatform

Funktion JHRegGetWindowsPlatform()
 Zurück Startseite Vor
Syntax

result.s = JHRegGetWindowsPlatform()

Beschreibung / Description

Diese Funktion gibt den Namen der Windowsplattform zurück, unabhängig davon ob
im Kompatibilitätsmodus gestartet wurde oder nicht (bei XP und Vista)
English

This function give back the name of windows version.

Rückgabewerte / Returns

- den Namen der Plattform wenn erfolgreich
- einen Leerstring wenn die Ausgabe fehlgeschlagen ist
- the name if successful
- a empty string at fault

Fehlerrückgabe / Error return

keine

English

no error message


JHRegGetWindowsVersion

Funktion JHRegGetWindowsVersion()
 Zurück Startseite Vor
Syntax

result.s = JHRegGetWindowsVersion()

Beschreibung / Description

Diese Funktion gibt den Namen des verwendeten Windows zurück, unabhängig davon ob
im Kompatibilitätsmodus gestartet wurde oder nicht (bei XP und Vista)
English

This function give back the name of windows version.

Rückgabewerte / Returns

- den Namen wenn erfolgreich
- einen Leerstring wenn die Ausgabe fehlgeschlagen ist
- the name if successful
- a empty string at fault

result = "Windows 95"
result = "WinNT 3.51"
result = "WinNT 4.0"
result = "Windows 98"
result = "Windows ME"
result = "Windows 2000"
result = "Windows XP"
result = "WindowsServer 2003"
result = "Windows Vista"

Fehlerrückgabe / Error return

keine

English

no error message


JHRegLastError

Funktion JHRegLastError
Syntax

result.s = JHRegLastError()
Beschreibung / Description
Diese Funktion gibt einen String zurück der Rückschlüsse auf eventuelle Fehlerursachen zuläßt, falls von einer aufgerufenen Funktion nicht das erwartete Ergebnis zurückgegeben worden ist. Eine Auswertung ist nur unmittelbar nach dem Aufruf einer Funktion sinnvoll, da bei jedem weiteren Aufruf der Fehler zuerst zurückgesetzt wird. Ebenfalls zurückgesetzt wird der Fehlertext nach dem Aufruf der Fehlerfunktion.

English

This function returns a string with informations of error for the last function call. Use it only directly after function call. After a call of this function the string is also empty.

Rückgabewerte / Returns

- einen (englischen) Fehlertext wenn aktuell ein Fehler ansteht
- einen Leerstring wenn kein aktueller Fehler ansteht

English

- unites fault text a fault lines up if current
- unites empty string if no current fault lines up


JHRegSetLenOfText

Funktion JHRegSetLenOfText
Syntax

result.l = JHRegSetLenOfText(#Gadget, Length.l)

Beschreibung / Description

Diese Funktion setzt die Länge der maximal möglichen Eingabe in ein String oder Editorgadget.

English

This function set the maximal length of input into a string or editor gadget.

Rückgabewerte / Returns

- #True wenn erfolgreich
- #False bei Fehler
- #True if successful
- #False at fault

Fehlerrückgabe / Error return

keine

English

no error message


JHRegStartOnlyOneInstance

Funktion JHRegStartOnlyOneInstance
Syntax

result.s = JHRegStartOnlyOneInstance (InstanceName.s, [flag.l])

Beschreibung / Description

Läßt nach Aufruf nur einen Start des Programms welches mit InstanceName benannt wurde zu. Optional kann mit flag = 1 eine Information ausgegeben werden. Gleichzeitig wird das Fenster mit dem Namen <InstanceName> versucht in den Vordergrund zu holen. Dazu darf diese Fenster nicht minimiert und nicht versteckt sein.

English

If set you can start only one instance of given InstanceName. As option you can set if you want to have a message. During this process will be lock to show the window with the name <InstanceName> in foreground. This window must be visible and not minimized or hide.

Rückgabewerte / Returns

keine / no

Bemerkung:

Für diese Funktion stand teilweise ein Codeausschnitt aus der TailBite als Grundlage zur Verfügung.

Beispiel / Example

#InstanceName="Mein Programm"
; Use this for message
; JHRegStartOnlyOneInstance(#InstanceName,1)
; or this without message
JHRegStartOnlyOneInstance(#InstanceName)
OpenWindow(0,100,100,600,400,#InstanceName)
JHRegSetForegroundWindow(#InstanceName)
Repeat
Select WaitWindowEvent()
Case #PB_Event_CloseWindow
End
EndSelect
ForEver


JHRegVersion

Funktion JHRegVersion
Syntax

result.s = JHRegVersion (flag.b)

Beschreibung / Description

Gibt die Versionsnummer der Library zurück.

English

Returns the number of version from the library.

Rückgabewerte / Returns

- mit flag = 1 wird ein Requester geöffnet der die Daten anzeigt. Außerdem wird
der Rückgabestring mit der Versionsnummer belegt.
- mit flag <> 1 wird nur der Rückgabestring mit der Versionsnummer belegt.
- with flag = #True is open a requester with the version informations. The string will be return
the number of version.
- with flag <> #True give only the string with version number.


JHRegVersionDate

Funktion JHRegVersionDate()
 Zurück Startseite Vor
Syntax

result.s = JHRegVersionDate ()

Beschreibung / Description

Gibt das Datum der Version der Library zurück.

English

Returns the date of version from the library.

Rückgabewerte / Returns

- Das Datum der Version in Form eines deutschen Datumsstring

- the date of version in format of german date-string


JHRegGetAplicationPath
Syntax

result.s=JHRegGetAplicationPath()

Beschreibung / Description

Gibt bei Abfrage den Pfad zu Anwendungsdaten zurück. Und zwar mit am Ende folgendem Backslash, z.B. "C:\Windows\Anwendungsdaten\".

English

At query gives the path back to the aplications folder. And but with a BACKSLASH following on the end. e.g.:"c\windows\anwendungsdaten\".

Rückgabewerte / Returns

- den gesuchten Pfad wenn erfolgreich,
- bei Fehler ein Leerstring
- the sought-after path if successful
- an empty string at fault

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English
In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegGetAutostartPath
Syntax

result.s=JHRegGetAutostartPath()

Beschreibung / Description

Gibt bei Abfrage den Pfad zum Autostartordner im Startmenu zurück. Und zwar mit am Ende folgendem Backslash, z.B. "C:\Windows\Startmenu\Programme\Autostart\".

English

At query gives the path back to the autostart folder in the startmenu. And but with a BACKSLASH following on the end. e.g.:"c\windows\startmenu\progams\autostart\".

Rückgabewerte / Returns

- den gesuchten Pfad wenn erfolgreich,
- bei Fehler ein Leerstring
- the sought-after path if successful
- an empty string at fault

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English
In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegGetCommonStartmenuPath

Funktion JHRegGetCommonStartmenuPath()
 Zurück Startseite Vor
Syntax

result.s=JHRegCommonGetStartmenuPath()

Diese Funktion wird nicht von Windows9x unterstützt.

Beschreibung / Description

Gibt bei Abfrage den Pfad zum AllUsers Startmenüordner zurück. Und zwar mit am Ende folgendem Backslash, z.B. "C:\programdata\microsoft\windows\start menu\".

English

At query gives the path back to the startmenu folder. And but with a BACKSLASH following on the end. e.g.:"c\programdata\microsoft\windows\start menu\".

Rückgabewerte / Returns

- den gesuchten Pfad wenn erfolgreich,
- bei Fehler ein Leerstring
- the sought-after path if successful
- an empty string at fault

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English
In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegGetCommonStartmenuProgramsPath

Funktion JHRegGetCommonStartmenuProgramsPath()
 Zurück Startseite Vor
Syntax

result.s=JHRegGetCommonStartMenuProgramsPath()

Diese Funktion wird nicht von Windows9x unterstützt.

Beschreibung / Description

Gibt bei Abfrage den Pfad zum AllUsers Startmenü, Unterordner Programme zurück. Und zwar mit am Ende folgendem Backslash, z.B. "C:\programdata\microsoft\Windows\Startmenü\Programme\".

English

At query gives the path back to the startmenu programs folder. And but with a BACKSLASH following on the end. e.g.:"c\programdata\microsoft\windows\start menu\programs\".

Rückgabewerte / Returns

- den gesuchten Pfad wenn erfolgreich,
- bei Fehler ein Leerstring
- the sought-after path if successful
- an empty string at fault

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English
In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegGetDesktopPath

Funktion JHRegGetDesktopPath
Syntax

result.s=JHRegGetDesktopPath()

Beschreibung / Description

Gibt bei Abfrage den Pfad zum Desktop zurück. Und zwar mit am Ende folgendem Backslash, z.B. "C:\Windows\Desktop\".

English

At query gives the path back to the desktop. And but with a BACKSLASH following on the end. e.g.:"c\windows\desktop\".

Rückgabewerte / Returns

- den gesuchten Pfad wenn erfolgreich,
- bei Fehler ein Leerstring
- the sought-after path if successful
- an empty string at fault

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English
In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegGetFavoritePath
Syntax

result.s=JHRegGetFavoritePath()

Beschreibung / Description

Gibt bei Abfrage den Pfad zu Favoriten zurück. Und zwar mit am Ende folgendem Backslash, z.B. "C:\Windows\Favoriten\".

English

At query gives the path back to the favorits folder. And but with a BACKSLASH following on the end. e.g.:"c\windows\favoriten\".

Rückgabewerte / Returns

- den gesuchten Pfad wenn erfolgreich,
- bei Fehler ein Leerstring
- the sought-after path if successful
- an empty string at fault

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English
In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegGetFontPath
Syntax

result.s=JHRegGetFontPath()

Beschreibung / Description

Gibt bei Abfrage den Pfad zum Fontordner zurück. Und zwar mit am Ende folgendem Backslash, z.B. "C:\Windows\Fonts\".

English

At query gives the path back to the font folder. And but with a BACKSLASH following on the end. e.g.:"c\windows\fonts\".

Rückgabewerte / Returns

- den gesuchten Pfad wenn erfolgreich,
- bei Fehler ein Leerstring
- the sought-after path if successful
- an empty string at fault

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English
In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegGetPBPath

Funktion JHRegGetPBPath()
 Zurück Startseite Vor
Syntax

result.s=JHRegGetPBPath()

Beschreibung / Description

Gibt bei Abfrage den Pfad zur aktuell aktiven Version von PureBasic zurück. Und zwar mit am Ende folgendem Backslash, z.B. "C:\Programme\PB400\PureBasic\".

English

At query gives the path back to the folder of the active PB version. And but with a BACKSLASH following on the end. e.g.:"c\programme\pb400\purebasic\".

Rückgabewerte / Returns

- den gesuchten Pfad wenn erfolgreich,
- bei Fehler ein Leerstring
- the sought-after path if successful
- an empty string at fault


JHRegGetPersonalPath
Syntax

result.s=JHRegPersonalPath()

Beschreibung / Description

Gibt bei Abfrage den Pfad zu "Eigene Dateien" zurück. Und zwar mit am Ende folgendem Backslash, z.B. "C:\Eigene Dateien"\".

English

At query gives the path back to the personal directory. And but with a BACKSLASH following on the end. e.g.:"c\my files\".

Rückgabewerte / Returns

- den gesuchten Pfad wenn erfolgreich,
- bei Fehler ein Leerstring
- the sought-after path if successful
- an empty string at fault

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English
In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegGetProgramsPath

Funktion JHRegGetProgramPath
Syntax

result.s=JHRegGetProgramsPath()

Beschreibung / Description

Gibt bei Abfrage den Pfad zum Standard Programmordner zurück. Und zwar mit am Ende folgendem Backslash, z.B. "C:\Programme\".

English

At query gives the path back to the standard program folder. And but with a BACKSLASH following on the end. e.g.:"c:\programs\".

Rückgabewerte / Returns

- den gesuchten Pfad wenn erfolgreich,
- bei Fehler ein Leerstring
- the sought-after path if successful
- an empty string at fault

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English
In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegGetStartmenuPath

Funktion JHRegGetStartmenuPath
Syntax

result.s=JHRegGetStartmenuPath()

Beschreibung / Description

Gibt bei Abfrage den Pfad zum Startmenüordner zurück. Und zwar mit am Ende folgendem Backslash, z.B. "C:\Windows\Startmenü\".

English

At query gives the path back to the startmenu folder. And but with a BACKSLASH following on the end. e.g.:"c\windows\startmenu\".

Rückgabewerte / Returns

- den gesuchten Pfad wenn erfolgreich,
- bei Fehler ein Leerstring
- the sought-after path if successful
- an empty string at fault

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English
In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegGetStartMenuProgramsPath

Funktion JHRegGetStartMenuProgramsPath
Syntax

result.s=JHRegGetStartMenuProgramsPath()

Beschreibung / Description

Gibt bei Abfrage den Pfad zum Startmenü, Unterordner Programme zurück. Und zwar mit am Ende folgendem Backslash, z.B. "C:\Windows\Startmenü\Programme\".

English

At query gives the path back to the startmenu programs folder. And but with a BACKSLASH following on the end. e.g.:"c\windows\startmenu\programs\".

Rückgabewerte / Returns

- den gesuchten Pfad wenn erfolgreich,
- bei Fehler ein Leerstring
- the sought-after path if successful
- an empty string at fault

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English
In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegGetSystemPath

Funktion JHRegGetSystemPath
Syntax

result.s=JHRegGetSystemPath()

Beschreibung / Description

Gibt bei Abfrage den Pfad zum Systemordner zurück. Und zwar mit am Ende folgendem Backslash, z.B. "C:\Windows\System\".

English

At query gives the path back to the system folder. And but with a BACKSLASH following on the end. e.g.:"c\windows\system\".

Rückgabewerte / Returns

- den gesuchten Pfad wenn erfolgreich,
- bei Fehler ein Leerstring
- the sought-after path if successful
- an empty string at fault

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English
In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegGetSystem32Path

Funktion JHRegGetSystem32Path
Syntax

result.s=JHRegGetSystem32Path()

Beschreibung / Description

Gibt bei Abfrage den Pfad zum System32 Ordner zurück. Und zwar mit am Ende folgendem Backslash, z.B. "C:\Windows\System32\".

English

At query gives the path back to the system32 folder. And but with a BACKSLASH following on the end. e.g.:"c\windows\system32\".

Rückgabewerte / Returns

- den gesuchten Pfad wenn erfolgreich,
- bei Fehler ein Leerstring
- the sought-after path if successful
- an empty string at fault

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English
In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegGetUserDesktopPath

Funktion JHRegGetUserDesktopPath()
 Zurück Startseite Vor
Syntax

result.s=JHRegGetUserDesktopPath()

Beschreibung / Description

Gibt bei Abfrage den Pfad zum Desktop zurück. Und zwar mit am Ende folgendem Backslash, z.B. "C:\Dokumente und Einstellungen\<Name>\Desktop\". Für Windows Vista wird die Rückgabe in etwa so aussehen: "c:\users\<name>\desktop\"

English

At query gives the path back to the desktop. And but with a BACKSLASH following on the end. e.g.:"c\users\<name>\desktop\".

Rückgabewerte / Returns

- den gesuchten Pfad wenn erfolgreich,
- bei Fehler ein Leerstring
- the sought-after path if successful
- an empty string at fault

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English
In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegGetWindowsPath

Funktion JHRegGetWindowsPath
Syntax

result.s=JHRegGetWindowsPath()

Beschreibung / Description

Gibt bei Abfrage den Pfad zu Windows zurück. Und zwar mit am Ende folgendem Backslash, z.B. "C:\Windows\".

English

At query gives the path back to the windows folder. And but with a BACKSLASH following on the end. e.g.:"c\windows\".

Rückgabewerte / Returns

- den gesuchten Pfad wenn erfolgreich,
- bei Fehler ein Leerstring
- the sought-after path if successful
- an empty string at fault

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English
In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegGetSelfsetPath

Funktion JHRegGetSelfsetPath()
 Zurück Startseite Vor
Syntax

result.s=JHRegGetSelfsetPath(csidl.l)

Beschreibung / Description

Gibt bei Abfrage den Pfad zurück, der mittels der Übergabe für csidl angegeben wurde sofern die Übergabe gültig war. Und zwar mit am Ende folgendem Backslash, z.B. "C:\Windows\" wenn für csidl = 36.

English

At query gives the path back to the folder with given number for csidl if successful. And but with a BACKSLASH following on the end. e.g.:"c\windows\" if you give csidl = 36.

Rückgabewerte / Returns

- den gesuchten Pfad wenn erfolgreich,
- bei Fehler ein Leerstring
- the sought-after path if successful
- an empty string at fault

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English
In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegCreateKey

Funktion JHRegCreateKey
Syntax

result.l = JHRegCreateKey(HKey.l, SKey.s)

Beschreibung / Description

Diese Funktion erstellt einen SubKey in dem spezifizierten #HKEY.

English

This function create a SubKey in the specified #HKEY.

Rückgabewerte / Returns

- #True wenn der Eintrag erstellt wurde
- #False bei Fehler
- #True if successful
- #False at fault

HKey.l kann folgende Werte annehmen
HKey.l the following can assume results

#HKEY_CURRENT_USER
#HKEY_LOCAL_MACHINE
#HKEY_CLASSES_ROOT
#HKEY_CURRENT_CONFIG
#HKEY_USERS
#HKEY_DYN_DATA
#HKEY_PERFORMANCE_DATA

SKey.s ist der Name des Subschlüssels in folgender Form
SKey.s is the name of sub key in this form

(Beispiel/Example)

"JHTestkey\"

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English
In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegDeleteKey

Funktion JHRegDeleteKey
Syntax

result.l = JHRegDeleteKey(MKey.l, SKey.s [, Flag.b])

Beschreibung / Description

Die Funktion löscht einen SubKey aus dem spezifizierten #HKEY. Achtung, standardmäßig wird keine Prüfung vorgenommen, ob der Inhalt leer ist. Sie können dies jedoch mit einem Flag tun.

Seien Sie besonders vorsichtig bei der Anwendung von Funktionen zur Entfernung von Einträgen oder Schlüsseln.

English
The function deletes a SubKey from the specified # HKEY. Respect, default are carried out no examination about whether the contents are empty. You can, however, do this with a flag.
Are you particularly carefully of entries or keys at the application of functions to the distance.

Rückgabewerte / Returns

- #True wenn der Eintrag gelöscht wurde
- #False bei Fehler
- #True if successful
- #False at fault

HKey.l kann folgende Werte annehmen
HKey.l the following can assume results

#HKEY_CURRENT_USER
#HKEY_LOCAL_MACHINE
#HKEY_CLASSES_ROOT
#HKEY_CURRENT_CONFIG
#HKEY_USERS
#HKEY_DYN_DATA
#HKEY_PERFORMANCE_DATA

SKey.s ist der Name des Subschlüssels in folgender Form
SKey.s is the name of sub key in this form

(Beispiel/Example)

"JHTestkey\"

Flag kann folgende Werte annehmen oder entfallen
Flag can assume the following results or be dropped
0 keine Prüfung
1 Subkey wird vor dem Löschen geprüft
ob er noch Schlüssel oder SubKey enthält
0 no examination
1 Subkey is checked before deleting whether he still contains keys
or additional contained SubKey steward

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English
In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegDelValue

Funktion JHRegDelValue
Syntax

result.l = JHRegDelValue(HKey.l, SKey.s, Value.s)

Beschreibung / Description

Diese Funktion löscht den spezifizierten Schlüssel des angegebenen #HKEY und SubKey. Achtung, seien Sie vorsichtig beim Umgang mit Löschfunktionen in der Registry.

English

This function deletes the specified value of the given # HKEY and SubKey. You are careful respect in the registry at the working with deleting functions.

Rückgabewerte / Returns

- #True wenn der Eintrag entfernt wurde
- #False bei Fehler
- #True if successful
- #False at fault

HKey.l kann folgende Werte annehmen
HKey.l the following can assume results

#HKEY_CURRENT_USER
#HKEY_LOCAL_MACHINE
#HKEY_CLASSES_ROOT
#HKEY_CURRENT_CONFIG
#HKEY_USERS
#HKEY_DYN_DATA
#HKEY_PERFORMANCE_DATA

SKey.s ist der Name des Subschlüssels in folgender Form
SKey.s is the name of sub key in this form
(Beispiel/Example)

"JHTestkey\"

Value.s ist der Name des angesprochenen Schlüssels
Value.s is the name of key value

Fehlerrückgabe / Error returns

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English
In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegGetBinary

Funktion JHRegGetBinary
Syntax

result.l = JHRegGetBinary(HKey.l, SKey.s, Value.s)

Beschreibung / Description

Diese Funktion gibt die Adresse mit dem Inhalt des spezifizierten Schlüssels des angegebenen #HKEY und SubKey zurück, wenn es sich um ein Binary handelt.

Um die Länge des Speicherbereichs zu ermitteln, müssen Sie nach dem Aufruf
dieser Funktion JHRegGetBinarySize() aufrufen.

Wenn Sie die Adresse nicht mehr benötigen, so sollten Sie den mit AllocateMemory() freigehaltenen Speicher mit FreeMemory(Adresse) wieder freigeben.

English
This function gives the address back with the contents of the specified key of the given # HKEY and SubKey, if it is a Binary. After this function you need a call for the length of memory with the function JHRegGetBinarySize().
If you don't need the address any more, then you should release the loft kept free with AllocateMemory () with FreeMemory (*Adresse) again.

Rückgabewerte / Returns

- die Adresse des Speicherbereiches, wo der Inhalt abgelegt wurde.
- #False bei Fehler
- where the contents were put down the address of the memory area.
- #False at fault

HKey.l kann folgende Werte annehmen
HKey.l the following can assume results

#HKEY_CURRENT_USER
#HKEY_LOCAL_MACHINE
#HKEY_CLASSES_ROOT
#HKEY_CURRENT_CONFIG
#HKEY_USERS
#HKEY_DYN_DATA
#HKEY_PERFORMANCE_DATA

SKey.s ist der Name des Subschlüssels in folgender Form
SKey.s is the name of sub key in this form

(Beispiel/Example)

"JHTestkey\"

Value.s ist der Name des angesprochenen Schlüssels
Value.s is the name of key value

Beispiel/Example

*MID=JHRegGetBinary(Hkey.l, SKey.s, Value.s)
Dim b(MemorySize(*MID))
If *MID
For I = 0 To MemorySize(*MID)-1
b(I)=PeekB(*MID + I) & $FF ; wegen signierter Variable!
Next
FreeMemory(*MID)
EndIf

In der mit der Speicherbereichsgröße dimensionierten (numerischen) Variable b() liegen byteweise die einzelnen ASCII-Werte. Achtung, AllocateMemory() richtet immer eine Größe von mindestens 12 Byte als Länge ein! Wenn Sie den reservierten Speicher nicht mehr benötigen, so geben Sie ihn wieder frei.

In the variable b() you can find the ASCII-Numbers of your reading key value. Attention, AllocateMemory() made a minimum size of 12 byte for the length of memory. If you are ready and you don´t use the allocated memory, pleas make it free.

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English
In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegGetBinarySize

Funktion JHRegGetBinarySize()
 Zurück Startseite Vor
Syntax

result.l = JHRegGetBinarySize()

Beschreibung / Description

Diese Funktion gibt die Länge des Eintrages zurück, wenn Sie ein Binary ausgelesen haben.

English

This function gives the length of memory after a registry read for binary.
Rückgabewerte / Returns

- die Länge des Speicherbereichs.
- #False bei Fehler
- the length of memory area.
- #False at fault


JHRegGetDWord

Funktion JHRegGetDWord
Syntax

result.l = JHRegGetDWord(MKey.l, SKey.s, Value.s)

Beschreibung / Description

Diese Funktion gibt den Inhalt des spezifizierten Schlüssels des angegebenen #HKEY und SubKey zurück, wenn es sich um ein DWord handelt.

English
This function gives the contents of the specified key of the given # HKEY and SubKey back, if it is a DWord.

Rückgabewerte / Returns

- den numerischen Inhalt wenn erfolgreich
- 0 bei Fehler oder Inhalt 0
- the numeric contents if successful
- Zero at fault or contents is zero

HKey.l kann folgende Werte annehmen
HKey.l the following can assume results

#HKEY_CURRENT_USER
#HKEY_LOCAL_MACHINE
#HKEY_CLASSES_ROOT
#HKEY_CURRENT_CONFIG
#HKEY_USERS
#HKEY_DYN_DATA
#HKEY_PERFORMANCE_DATA

SKey.s ist der Name des Subschlüssels in folgender Form
SKey.s is the name of sub key in this form

(Beispiel/Example)

"JHTestkey\"

Value.s ist der Name des angesprochenen Schlüssels
Value.s is the name of key value

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English
In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegGetString

Funktion JHRegGetString
Syntax

result.s = JHRegGetString(HKey.l, SKey.s, Value.s)

Beschreibung / Description

Diese Funktion gibt den Inhalt des spezifizierten Schlüssels des angegebenen #HKEY und SubKey zurück, wenn es sich um einen String handelt. Alle Rückgaben erfolgen als String. Wird Value ein Leerstring übergeben, so erfolgt die Rückgabe des Eintrages für <Standard>

English

This function gives the contents of the specified key of the given # HKEY and SubKey back, if it is a string. All returns are carried out as a string. If given for value a empty string, you become return the content of <Standard>

Rückgabewerte / Returns

- den Inhalt des Schlüssels wenn erfolgreich
- einen Leerstring im Fehlerfalle
- the contents of the key if successful
- an empty string in the fault case

HKey.l kann folgende Werte annehmen
HKey.l the following can assume results

#HKEY_CURRENT_USER
#HKEY_LOCAL_MACHINE
#HKEY_CLASSES_ROOT
#HKEY_CURRENT_CONFIG
#HKEY_USERS
#HKEY_DYN_DATA
#HKEY_PERFORMANCE_DATA

SKey.s ist der Name des Subschlüssels in folgender Form
SKey.s is the name of sub key in this form

(Beispiel/Example)

"JHTestkey\"

Value.s ist der Name des angesprochenen Schlüssels
Value.s is the name of key value

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English
In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegGetValue

Funktion JHRegGetValue
Syntax

result.s = JHRegGetValue(HKey.l, SKey.s, Value.s)

Beschreibung / Description

Diese Funktion gibt den Inhalt des spezifizierten Schlüssels des angegebenen #HKEY und SubKey zurück, unabhängig von der Art des Selben. Alle Rückgaben erfolgen als String. Wird Value ein Leerstring übergeben, so erfolgt die Rückgabe des Eintrages für <Standard>

English

This function gives the contents of the specified key of the given # HKEY and SubKey back, independently of the way of the same. All returns are carried out as a string. If given for value a empty string, you become return the content of <Standard>

Rückgabewerte / Returns

- Inhalt des Schlüssels wenn erfolgreich.
- bei Binarys als Hex-String jeweils getrennt durch ein Leerzeichen zwischen den Byte.
- bei Fehler einen Leerstring.
- the contents of the key if successful
- separated the byte by a blank at Binarys as a conjure up string respectively between
- an empty string in the fault case

HKey.l kann folgende Werte annehmen
HKey.l the following can assume results

#HKEY_CURRENT_USER
#HKEY_LOCAL_MACHINE
#HKEY_CLASSES_ROOT
#HKEY_CURRENT_CONFIG
#HKEY_USERS
#HKEY_DYN_DATA
#HKEY_PERFORMANCE_DATA

SKey.s ist der Name des Subschlüssels in folgender Form
SKey.s is the name of sub key in this form

(Beispiel/Example)

"JHTestkey\"

Value.s ist der Name des angesprochenen Schlüssels
Value.s is the name of key value

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English
In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegGetValueType

Funktion JHRegGetValueType
Syntax

result.s = JHRegGetValueType(HKey.l, SKey.s, Value.s)

Beschreibung / Description

Diese Funktion gibt den Typ des spezifizierten Wertes im angegebenen #HKEY und SubKey zurück. Alle Rückgaben erfolgen als String.

English

This function gives the type of the specified keyword of the given # HKEY and SubKey back. All returns are carried out as a string.

Rückgabewerte / Returns

- den Type des Value in Form eines String
- bei Fehler einen Leerstring.
- the type of value as a string if successful
- an empty string in the fault case

HKey.l kann folgende Werte annehmen
HKey.l the following can assume results

#HKEY_CURRENT_USER
#HKEY_LOCAL_MACHINE
#HKEY_CLASSES_ROOT
#HKEY_CURRENT_CONFIG
#HKEY_USERS
#HKEY_DYN_DATA
#HKEY_PERFORMANCE_DATA

SKey.s ist der Name des Subschlüssels in folgender Form
SKey.s is the name of sub key in this form

(Beispiel/Example)

"JHTestkey\"

Value.s ist der Name des angesprochenen Schlüssels
Value.s is the name of key value

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English
In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegIsKey

Funktion JHRegIsKey
Syntax

result.l = JHRegIsKey(HKey.l, SKey.s)

Beschreibung / Description

Diese Funktion prüft ob ein angegebener SubKey im spezifizierten #HKEY vorhanden ist.

English

This function checks whether a given SubKey is available in the specified # HKEY.

Rückgabewerte / Returns

- #True wenn der Eintrag gefunden wurde
- #False bei Fehler
- #True if found entry successful
- #False at fault

HKey.l kann folgende Werte annehmen
HKey.l the following can assume results

#HKEY_CURRENT_USER
#HKEY_LOCAL_MACHINE
#HKEY_CLASSES_ROOT
#HKEY_CURRENT_CONFIG
#HKEY_USERS
#HKEY_DYN_DATA
#HKEY_PERFORMANCE_DATA

SKey.s ist der Name des Subschlüssels in folgender Form
SKey.s is the name of sub key in this form

(Beispiel/Example)

"JHTestkey\"

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English
In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegListSubKey

Funktion JHRegListSubKey
Syntax

result.s = JHRegListSubKey(HKey.l, SKey.s, Index.l)

Beschreibung / Description

Diese Funktion gibt den Namen des Subkey innerhalb des angesprochenen Subkey zurück, welcher mit der Indexierung angesprochen wird. Der Index des Subkeys ergibt sich aus der Reihenfolge der Eintragung in die Registry. Eine sortierbare Liste aller Eintragungen innerhalb eines Key können Sie mit der Funktion JHRegListContents erstellen.

English

Which one is asked with the indexation gives the names of the Subkey this function back. The index of the Subkeys arises from the order of the entry into the registry. You can key for entries for a sortable list for everyone make with the function JHRegListValue () within one.

Rückgaben / Returns

- der Name des mit dem Index angesprochenen Schlüssels bei Erfolg
- bei Fehler ein Leerstring
- the name of the key at success mentioned with the index
- an empty string at fault

HKey.l kann folgende Werte annehmen
HKey.l the following can assume results

#HKEY_CURRENT_USER
#HKEY_LOCAL_MACHINE
#HKEY_CLASSES_ROOT
#HKEY_CURRENT_CONFIG
#HKEY_USERS
#HKEY_DYN_DATA
#HKEY_PERFORMANCE_DATA

SKey.s ist der Name des Subschlüssels in folgender Form
SKey.s is the name of sub key in this form

(Beispiel/Example)

"JHTestkey\"
Index.l ist die Nummer des Eintrages bezogen auf die Erstellzeit
Index.l is obtained the number of the entry till the making time

Gültiger Bereich von 0 bis 2147483647, wobei bei fehlerhaften Index eine Meldung erfolgt.
Valid area of 0 to 2147483647, in which a report is carried out at faulty index.

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English
In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegListSubValue

Funktion JHRegListSubValue
Syntax

result.s = JHRegListSubValue(HKey.l, SKey.s, Index.l)

Beschreibung / Description

Diese Funktion gibt den Namen des Value zurück, welcher mit der Indexierung angesprochen wird. Der Index des Value ergibt sich aus der Reihenfolge der Eintragung in die Registry. Eine sortierbare Liste aller Eintragungen innerhalb eines Key können Sie mit der Funktion JHRegListContents erstellen.

English

Which one is asked with the indexation gives the names of the value this function back. The index of the values arises from the order of the entry into the registry. You can key for entries for a sortable list for everyone make with the function JHRegListValue () within one.

Rückgaben / Returns

- der Name des mit dem Index angesprochenen Value bei Erfolg
- bei Fehler ein Leerstring
- the name of the value at success mentioned with the index
- an empty string at fault

HKey.l kann folgende Werte annehmen
HKey.l the following can assume results

#HKEY_CURRENT_USER
#HKEY_LOCAL_MACHINE
#HKEY_CLASSES_ROOT
#HKEY_CURRENT_CONFIG
#HKEY_USERS
#HKEY_DYN_DATA
#HKEY_PERFORMANCE_DATA

SKey.s ist der Name des Subschlüssels in folgender Form
SKey.s is the name of sub key in this form

(Beispiel/Example)

"JHTestkey\"
Index.l ist die Nummer des Eintrages bezogen auf die Erstellzeit
Index.l is obtained the number of the entry till the making time

Gültiger Bereich von 0 bis 2147483647, wobei bei fehlerhaften Index eine Meldung erfolgt.
Valid area of 0 to 2147483647, in which a report is carried out at faulty index.

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English
In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegSetBinary

Funktion JHRegSetBinary
Syntax

result.l = JHRegSetBinary(HKey.l, SKey.s, Value.s, Wert.s, [Flag.b]l)

Beschreibung / Description

Diese Funktion schreibt oder ändert einen binären Wert im spezifizierten Schlüssel des angegebenen #HKEY und SubKey. Flag ist optional und kann entfallen.

ohne optionales Flag oder Flag = 0

Reservieren Sie einen Speicherbereich und tragen Sie die Daten mit PokeB() dort ein. Geben Sie dann die Adresse davon an oder übergeben Sie eine anderweitig bereits vergebene MemoryID an die Procedure. Die Übergabe an die Procedure muß mit Str(MemoryID) erfolgen, da ich keine zusätzliche Variable verwenden wollte. Die Übergabe erfolgt mit dem Parameter Wert.s

mit Flag = 1

Tragen Sie in die Variable <Value.s> einen Hexadezimalstring wie unten angegeben ein, den Rest erledigt die Funktion

English

This function writes or changes a binary value of keys the given # HKEY and SubKey specified in this. Flag is optional and can be dropped.

without flag or flag = 0

Reserve a memory area and type the data in with PokeB() there. Then give the address of this or submit a MemoryID already allocated elsewhere to the procedure. The handing over to the procedure must be carried out with Str(MemoryID) since I didn't want to use any additional variable. The handing over is carried out with the parameter Wert.s

with flag = 1

You write one down, on the variable <Value.s> for hexadecimal string like indicated below for one takes care of the remains the function.

Rückgabewerte ohne optionales Flag oder Flag = 0 oder Flag = 1

- #True wenn der Eintrag erfolgt ist
- #False bei Fehler
- #True if write / change successful
- #False at fault

HKey.l kann folgende Werte annehmen
HKey.l the following can assume results

#HKEY_CURRENT_USER
#HKEY_LOCAL_MACHINE
#HKEY_CLASSES_ROOT
#HKEY_CURRENT_CONFIG
#HKEY_USERS
#HKEY_DYN_DATA
#HKEY_PERFORMANCE_DATA

SKey.s ist der Name des Subschlüssels in folgender Form
SKey.s is the name of sub key in this form

(Beispiel/Example)

"JSTestkey\"

Value.s ist der Name des angesprochenen Schlüssels
Value.s is the name of key value

Wert.s ist der einzutragende Inhalt,
Wert.s is the contents to be typed in

Byteweise getrennt durch je ein Leerzeichen wenn Flag = #True. Es erfolgt eine Prüfung auf gültige Zeichefolge.

Flag = # True byte way separated by each one blank if. An examination is carried out on valid string.

Beispiel mit / Example with Flag = #True

Wert.s = "AA 01 1F FF" oder / or Wert.s = "a1 10 f1 da"
Debug JHRegSetBinary(#HKey, SKey, Value, Wert.s, #True)

Die mit Str(*MID) übergebene gültige Adresse eines zuvor mit AllocateMemory() reservierten Speicherbereiches wenn Flag = #False oder nicht angegeben.
The valid address of a memory area reserved before with AllocateMemory() submitted with Str(*MID) flag = # False or not indicated if.

Beispiel mit / Example with Flag = #False / oder nicht angegeben / or dropped
Length.l = 32
Restore BinaryTest ; Data
*MID = AllocateMemory(Length)
For a=0 To 31
Read b
PokeB(*MID+a,b)
Next a
If *MID
Debug JHRegSetBinary(#HKey, SKey, Value, Str(*MID), #False)
EndIf

; Binary Test
DataSection
BinaryTest:
Data.l 77, 65, 68, 69, 0, 73, 78, 0
Data.l 83, 65, 88, 79, 78, 89, 0, 0
Data.l 67, 72, 69, 77, 78, 73, 84, 90
Data.l 0, 0, 0, 0, 0, 0, 0, 0
EndDataSection

Flag.b kann folgende Werte annehmen oder weggelassen werden
Flag can assume the following results or be dropped

#True
#False

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English
In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegSetDW

Funktion JHRegSetDW
Syntax

result.l = JHRegSetDW(HKey.l, SKey.s, Value.s, Wert.l)

Beschreibung / Description

Diese Funktion schreibt oder ändert ein DWord im spezifizierten Schlüssel des angegebenen #HKEY und SubKey.

English

This function writes or changes a DWord in the specified key of the given # HKEY and SubKey.

Rückgabewerte / Returns

- #True wenn der Eintrag erfolgt ist
- #False bei Fehler
- #True if write / change successful
- #False at fault

HKey.l kann folgende Werte annehmen
HKey.l the following can assume results

#HKEY_CURRENT_USER
#HKEY_LOCAL_MACHINE
#HKEY_CLASSES_ROOT
#HKEY_CURRENT_CONFIG
#HKEY_USERS
#HKEY_DYN_DATA
#HKEY_PERFORMANCE_DATA

SKey.s ist der Name des Subschlüssels in folgender Form
SKey.s is the name of sub key in this form
(Beispiel/Example)

"JHTestkey\"

Value.s ist der Name des angesprochenen Schlüssels
Value.s is the name of key value

Wert.l ist der einzutragende Inhalt
Wert.s is the contents to be typed in

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English
In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegSetString

Funktion JHRegSetString
Syntax

result.l = JHRegSetString(HKey.l, SKey.s, Value.s, Wert.s)

Beschreibung / Description

Diese Funktion schreibt oder ändert einen String im spezifizierten Schlüssel des angegebenen #HKEY und SubKey. Wird Value ein Leerstring übergeben, so erfolgt der Eintrag für das Value <Standard>

English

This function writes or changes a string in the specified key of the given # HKEY and SubKey. If value a empty string, so you write the value of <Standard>.

Rückgabewerte / Returns

- #True wenn der Eintrag erfolgt ist
- #False bei Fehler
- #True if write / change successful
- #False at fault

HKey.l kann folgende Werte annehmen
HKey.l the following can assume results

#HKEY_CURRENT_USER
#HKEY_LOCAL_MACHINE
#HKEY_CLASSES_ROOT
#HKEY_CURRENT_CONFIG
#HKEY_USERS
#HKEY_DYN_DATA
#HKEY_PERFORMANCE_DATA

SKey.s ist der Name des Subschlüssels in folgender Form
SKey.s is the name of sub key in this form

(Beispiel/Example)

"JSTestkey\"

Value.s ist der Name des angesprochenen Schlüssels
Value.s is the name of key value

Wert.s ist der einzutragende Inhalt
Wert.s is the contents to be typed in

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English
In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegCreateGradient
Syntax

result.l=JHRegCreateGradient(color1.l, color2.l, number.l, direction.l, window.l, Image.l)

Beschreibung / Description

Erstellt einen Farbverlauf im durch die PB Nummer angegebenen Fenster. Image ist eine PB-Nummer eines Bildes. Die Richtung des Verlaufs wird mit direction angegeben, wobei die Angabe #Null immer einen waagrechten Verlauf erzeugt und alle anderen einen horizontalen. Farbe1 und Farbe2 geben die Start und die Endfarbe an. Deren Werte können Sie mit der Funktion RGB(r,g,b) ermitteln und übergeben. Sie können die Funktion auch bei laufendem Programm aufrufen. Es wird kein CallBack verwendet. Im Beispiel ist dies dargestellt.

English

Create a gradient in the specified window. Number set the lines, window is the PB-Number of specified window and Image is a PB-Image number. Direction set if it´s horizontal or vertical. If direction #Null it´s allready vertical, else horizontal.

Color1 is the startcolor and color2 is the endcolor. You can find this with the function RGB().

Rückgabewerte / Returns

- #True wenn erfolgreich,
- #False bei Fehler
- #True if successful
- #False at fault

Beispiel / Example

#Window = 0
#Image = 0
#BGadget = 0
#TGadget = 1

OpenWindow(#Window, 0, 0,200,150,"Testfenster Farbverlauf",#PB_Window_Invisible|#PB_Window_SystemMenu|#PB_Window_ScreenCentered)
JHRegCreateGradient(RGB( 0, 0, 0),RGB(255, 0, 0),255, 0, #Window, #Image)
CreateGadgetList(WindowID(#Window))
ButtonGadget(#BGadget, 10, 10,780, 24,"Beenden")
HideWindow(#Window,0)
a=0
Repeat
Select WindowEvent()
Case #PB_Event_CloseWindow
Quit = 1
Case #PB_Event_Gadget
Select EventGadget()
Case #BGadget
CloseWindow(#Window)
Quit=1
EndSelect
Default
Delay(1)
a+1
EndSelect
; Farbe ändern, Richtung ändern
If a=200
JHRegCreateGradient(RGB( 0, 0, 0),RGB( 0,255, 0),255, 0, #Window, #Image)
ElseIf a=400
JHRegCreateGradient(RGB( 0, 0, 0),RGB( 0, 0,255),255, 0, #Window, #Image)
ElseIf a=600
JHRegCreateGradient(RGB(255, 0, 0),RGB( 0, 0,255),255, 0, #Window, #Image)
ElseIf a=800
JHRegCreateGradient(RGB( 0, 0,255),RGB( 0,255, 0),255, 1, #Window, #Image)
a=0
EndIf
Until Quit = 1

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English
In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegCreateShortcutFull

Funktion JHRegCreateShortcutFull
Syntax

result.l = JHRegCreateShortcutFull (Zieldatei.s, Link.s, Parameter.s, ToolTip.s, WorkDir.s, WinSize.l, Hotkey.l, Icon.s, IconIdx.l)

Beschreibung / Description

Erstellt einen (Shell-) Link zur angegebenen Datei mit den angegebenen Spezifikationen.
Diese Funktion basiert auf einem Code von Danilo Krahn aus dem PB-Forum. Alle Angaben können selbst gemacht werden.

Wenn Sie nur eine mindest Anzahl von Parametern übergeben möchten oder benötigen können Sie auch die Funktion / If you need not all options you can use the function JHRegCreateShortcutSimply .

English

Create a *.lnk-file to the specified file with the given orders. This function is based by a code from Danilo Krahn. All specification must be write by yourself.

Link.s gibt den Name des zu erstellenden Shell Link an. Der Suffix *.lnk kann bei der Angabe entfallen. Ein falscher Suffix wird entsprechend korrigiert.

Link.s give the name for shortcutfile. The suffix *.lnk must not write into the string. A false suffix will be correctly.

WinSize.l kann folgende Werte annehmen / terms for WinSize:
SW_SHOWNORMAL = Grundeinstellung, normales Fenster
SW_SHOWMAXIMIZED = maximiertes Fenster
SW_SHOWMINIMIZED = minimiertes Fenster

Hotkey.l kann folgende Werte annehmen oder eine Kombination daraus sein:
0 = kein Hotkey
HOTKEYF_ALT = ALT key
HOTKEYF_CONTROL = CTRL key
HOTKEYF_EXT = Extended key
HOTKEYF_SHIFT = SHIFT key

IconIdx bezeichnet den Index des Icon wenn sich mehrere Icon im angegebenen Ziel befinden, z.B. wenn Sie die Systemicon benutzen. Soll das Icon der aufzurufenden Programmdatei benutzt werden, so geben Sie bitte "Null" als Index an.

Beispiel: dies wird den Schaltkreis als Icon anzeigen (WinME)
Icon.s = %SystemRoot%\system32\SHELL32.dll"
IconIdx = 12

Beispiel auf meinem eigenen System / sample from my system:

Zieldatei.s = "D:\Programme\PB400\PureBasic\purebasic.exe"; Zieldatei/-programm
Link.s = "e:\PB.lnk"; Link Ort und Name
PGMPara.s = "testen_wir_mal"; Programmparameter
ToolTip.s = "TestLink zu PB"; Tooltip
WorkDir.s = "D:\Programme\PB400\PureBasic\"; Arbeitsverzeichnis der Zieldatei
WinSize.l = #SW_SHOWMAXIMIZED; Fenstergröße beim Öffnen
Hotkey.l = 0; Hotkeys zum Programmaufruf
Icon.s = "D:\Programme\PB400\PureBasic\purebasic.exe" ; Iconfile
IconIdx.l = 0; Icon Index

Rückgabewerte / Returns

- #True wenn der Shelllink erstellt werden konnte
- #False bei Fehler
- #True if successful create
- #False at fault

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English
In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegCreateShortcutSimply

Funktion JHRegCreateShortcutSimply
Syntax

result.l = JHRegCreateShortcutSimply (Zieldatei.s, Link.s, Parameter.s, ToolTip.s, Icon.s)

Beschreibung / Description

Erstellt einen (Shell-) Link zur angegebenen Datei mit den angegebenen Spezifikationen.
Diese Funktion basiert auf einem Code von Danilo Krahn aus dem PB-Forum. Es werden nur die unbedingt notwendigen Daten übergeben. Alle anderen werden intern gesetzt.

Wenn Sie alle Optionen benötigen, nutzen Sie bitte die Funktion / If you need all options use the function JHRegCreateShortcutFull .

English

Create a *.lnk-file to the specified file with the given orders. This function is based by a code from Danilo Krahn. The important specification must be write by yourself. All other will be setting by the function.

Link.s gibt den Name des zu erstellenden Shell Link an. Der Suffix *.lnk kann bei der Angabe entfallen. Ein falscher Suffix wird entsprechend korrigiert.

Link.s give the name for shortcutfile. The suffix *.lnk must not write into the string. A false suffix will be correctly.

WinSize.l kann folgende Werte annehmen / terms for WinSize:
SW_SHOWNORMAL = Grundeinstellung, normales Fenster
SW_SHOWMAXIMIZED = maximiertes Fenster
SW_SHOWMINIMIZED = minimiertes Fenster

fest gesetzte Parameter die nicht übergeben werden müssen / fix setting parameters

Hotkey = 0 = kein Hotkey
IconIdx = 0 = erstes vorhandenes Icon in der Datei Icon.s
WinSize = #SW_ShowNormal
WorkDir = Programm Verzeichnis

Beispiel auf meinem eigenen System / sample from my system:

Zieldatei.s = "D:\Programme\PB400\PureBasic\purebasic.exe"; Zieldatei/-programm
Link.s = "e:\PB.lnk"; Link Ort und Name
PGMPara.s = "testen_wir_mal"; Programmparameter
ToolTip.s = "TestLink zu PB"; Tooltip
Icon.s = "D:\Programme\PB400\PureBasic\purebasic.exe" ; Iconfile

Rückgabewerte / Returns

- #True wenn der Shelllink erstellt werden konnte
- #False bei Fehler
- #True if successful create
- #False at fault

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English
In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegBinHex

Funktion JHRegBinHex
Syntax

result.s = JHRegBinHex(Bin.s)

Beschreibung / Description

Diese Funktion wandelt einen maxial 64 Zeichen langen String mit einer binären Zeichenfolge in eine Hexadezimalzahl. Die Rückgabe ist ein String. Führende Nullen werden mit angezeigt.

English

This function changes a maxial 64 signs long string with a binary string into a hexadecimal number. The return is a string. High-order zeros are shown.

Rückgabewerte / Returns

- der hexadezimale Wert der Übergabe als String
- ein Leerstring bei Fehler
- the hexadecimal value of the handing over as a string
- an empty string at fault

Bin.s ist ein String,

der nur 0 und 1 enthalten darf und zwischen 1 und 64 Zeichen lang sein kann. Leerzeichen sind ebenfalls erlaubt und werden ausgefiltert. Diese können dazu benutzt werden, um die einzelnen Nibble oder Byte von einander zu trennen, wobei es letztlich auf die Zahl ohne Leerzeichen ankommt.

English
Bin.s is a string
containedly may only 0 and 1 and can be between 1 and 64 signs long. Blanks also are permitted and are from filtered. These can be used to separate the single nibble or byte of each other in which it depends on the number without blanks in the end to this.

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English
In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegHexBin

Funktion JHRegHexBin
Syntax

result.s = JHRegHexBin(Hex.s)

Beschreibung / Description

Diese Funktion wandelt einen maxial 16 Zeichen langen String mit einer hexadezimalen Zeichenfolge in eine Binärzahl. Die Rückgabe ist ein 64Bit Binärstring. Führende Nullen werden mit angezeigt.

English

This function changes a maxial 16 signs long string with a hexadecimal string into a binary number. The return is a string with a 64 bit binary. High-order zeros are shown.

Rückgabewerte / Returns

- der binäre Wert der Übergabe als String
- ein Leerstring bei Fehler
- the binary value of the handing over as a string
- an empty string at fault

Hex.s ist ein String,

der die Hexziffern 0 bis F enthalten darf und zwischen 1 und 16 Zeichen lang sein kann. Kleinschreibung ist erlaubt ebenso Leerzeichen zwischen den Ziffern. Letztere werden ausgefiltert.

English
Hex.s is a string
contain the hexadecimal numbers 0 to F this one may and can be between 1 and 16 signs long. Use of small initial letters is permits just blank between the numbers. The latter are from filtered.

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English
In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegHexDez

Funktion JHRegHexDez
 Zurück Startseite
Syntax

result.l = JHRegHexDez(Hex.s)

Beschreibung / Description

Diese Funktion wandelt einen maxial 4 Zeichen langen String mit einer hexadezimalen Zeichenfolge in eine Dezimalzahl (16 Bit). Der Rückgabewert ist vom Typ Long. Für eine 32 Bit Hexzahl verwenden Sie bitte JHRegHex32Dez() .

English

This function changes a maxial 4 signs long string with a hexadecimal string into a decimal number (16 bits). The return value is of the type long. Please, use JHRegHex32Dez () for a 32 bits hexadecimal number.

Rückgabewerte / Returns

- den dezimalen Wert der Zeichenfolge wenn erfolgreich
- 0 bei Fehler oder Übergabe = 0
- the decimal value of the handing over
- Zero at fault or handing over = 0

Hex.s ist ein String,

der nur die Hexadezimalziffern 0 - F enthalten darf und zwischen 1 und 4 Zeichen lang sein kann. Kleinschreibung wird geprüft und ist für die Hexzahlenwerte erlaubt. Leerzeichen sind als Trennzeichen erlaubt und werden gefiltert.

English
Hex.s is a string
this one only the hexadecimal number 0 - F and can be between 1 and 4 signs long. Use of small initial letters is checked and is permitted for the hexadecimal numbers. Blanks are permitted as a hyphen and are filtered.

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English
In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


Syntax

result.l = JHRegHexDez(Hex.s)

Beschreibung / Description

Diese Funktion wandelt einen maxial 4 Zeichen langen String mit einer hexadezimalen Zeichenfolge in eine Dezimalzahl (16 Bit). Der Rückgabewert ist vom Typ Long. Für eine 32 Bit Hexzahl verwenden Sie bitte JHRegHex32Dez().

English

This function changes a maxial 4 signs long string with a hexadecimal string into a decimal number (16 bits). The return value is of the type long. Please, use JHRegHex32Dez () for a 32 bits hexadecimal number.

Rückgabewerte / Returns

- den dezimalen Wert der Zeichenfolge wenn erfolgreich
- 0 bei Fehler oder Übergabe = 0

- the decimal value of the handing over
- Zero at fault or handing over = 0

Hex.s ist ein String,

der nur die Hexadezimalziffern 0 - F enthalten darf und zwischen 1 und 4 Zeichen lang sein kann. Kleinschreibung wird geprüft und ist für die Hexzahlenwerte erlaubt. Leerzeichen sind als Trennzeichen erlaubt und werden gefiltert.

English

Hex.s is a string

this one only the hexadecimal number 0 - F and can be between 1 and 4 signs long. Use of small initial letters is checked and is permitted for the hexadecimal numbers. Blanks are permitted as a hyphen and are filtered.

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English

In the case of a fault a string which can be questioned on by means of the function  JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.