Über

Über / About
 Startseite Vor
Hilfefile zur / Help file for /
UserLib JHPrinter_420 von / by Jens Haipeter

Library:
V1.10 vom / built 15.06.2008
Hilfe / Help:
V1.10 vom / built 15.06.2008

Die Library ist ausschließlich für: PB 4.20 / Windows-Version /
The library is only for PB4.20, windows version
Diese UserLibrary wurde geschrieben für PureBasic Version 4.20. Sie dient verschiedenen Druckerfunktionen. Alle Funktionen wurden mehrfach getestet. Es wird keinerlei Garantie auf Funktion oder Nichtfunktion übernommen. Die Benutzung erfolgt auf eigene Gefahr.

English
This UserLibrary was written for PureBasic version 4.20. This library is good for some printer functions. All functions were tested repeatedly. No guarantee is taken on function or not function. The use carried out at her own risk.

Dem Paket beigefügt ist ein Codebeispiel, welches alle Funktionen beinhaltet.
A code example which contains all functions is enclosed with the package.

Chemnitz, im Mai 2008

Jens Haipeter, Website: www.jens-haipeter.de


History
 Zurück Startseite Vor
Änderungen, Erweiterungen, Reparaturen an der UserLib

In der Version 1.00 neu:

- Veröffentlichungsversion

Update Version 1.01 vom 11.02.2007

- hinzugefügt Anwendungsbeispiel

Update Version 1.02 vom 15.02.2007

- hinzugefügt Funktionen zur Textformatierung
- geändert Anwendungsbeispiel

Update Version 1.03 vom 16.02.2007

- geänderte Funktionen
- ergänzte Hilfe

Update Version 1.04 vom 17.02.2007

- neue Funktionen zum zeichnen von Linien und Tabellen

Update Version 1.05 vom 22.02.2007

- neue Funktionen
- Druckvorschau mit speichern des Image im Demoprogramm

Update Version 1.06 vom 12.07.2007

repariert

- Einige Funktionen benutzen fälschlicher Weise Funktionen
aus der JHRegistry_400 Library

hinzugefügt

- 2 ergänzende Funktionen

Update Version 1.07 vom 02.01.2008

repariert
- Anpassung an PB 4.20_Beta1

Update Version 1.10 vom 15.06.2008

repariert
- Anpassung an PB 4.20 Final


Allgemeines

Allgemeines / General
allgemeine Vereinbarung / General agreements

Sofern zukünftig Stringrückgaben erforderlich sein sollten werden diese bis auf weiteres als ASCII-Zeichenfolge ausgegeben. Ich bitte dies bei Unicode Programmen zu beachten.

Als erstes vor allen andern Funktionen ist immer die JHPrtSelectPrinter() Funktion aufzurufen.

English

If i need stringreturns all string returns are ASCII. Please note it for Unicode programs. The first function for using is JHPrtSelectPrinter()

Fehlermeldungen / ERROR-Messages

keine Fehlermeldungen vorgesehen.

Alle Hinweise die in der Editorsyntaxvorschau angezeigt werden sind englisch.

English
No error messages in this library.
All notes are also these shown on the editor syntax line be english.


Danksagungen

Danksagungen / Credits
Dank gilt an dieser Stelle / thanks for:

Miguel Calderon alias El_Choni für seinen Library-Maker Tailbite, ohne ihn wäre es unmöglich UserLib zu erstellen.

ABBKlaus aus dem PB Forum der einige Anpassungen an Tailbite vorgenommen hat.

Gnozal der sich auch Tailbite angenommen hat.

Allen ungenannten, die durch ihre Kritik zu Verbesserungen oder Veränderung beigetragen haben oder dies noch tun wollen ;) Es dürfen gern Vorschläge oder Wünsche auf meiner Webseite im Gästebuch oder im Forum hinterlassen werden.

English

By her criticism these have contributed to improvements or change or want to do this still all unnamed. Notes, suggestions being able to and so on be left on my web page in the forum or in the visitor's book. I will assume gratefully or pick up for changes her.


Functions

Funktionen / Functions
Funktionen / functions

Um die Funktionen der Library nutzen zu können, muß als erstes immer die JHPrtSelectPrinter() aufgerufen werden. (Gilt nur für die Druckerfunktionen)

JHPrtSelectPrinter
JHPrtDefaultPrinter()

Version und Versionsdatum der Library

JHPrtVersion
JHPrtVersionDate

Blatt- und Druckbereichsgröße (Pixel)

JHPrtPageSizePX
JHPrtPageSizePY
JHPrtPrintSizePX
JHPrtPrintSizePY

Rand- und Startpositionen (Pixel)

JHPrtStartPointPX
JHPrtStartPointPY
JHPrtRightRandPX
JHPrtDownRandPY

Ausgabeauflösungen

JHPrtDPMX
JHPrtDPMY
JHPrtDPI

Blatt- und Druckbereisgröße (mm)

JHPrtPaperSizeMX
JHPrtPaperSizeMY
JHPrtPrintSizeMX
JHPrtPrintSizeMY

Blattausrichtung und DIN-Format

JHPrtDirection
JHPrtDINFormat

Textformatierungen für Ausdruck

JHPrtCountWords
JHPrtBlockText
JHPrtCenterText
JHPrtFormatedLine
JHPrtFormatText

Textformatierungen für Bildschirmausgabe

JHPrtGetDesktopDPI
JHPrtSetGadgetFont
JHPrtGadgetBlockText

Linien und Boxen

JHPrtBackGround
JHPrtLine
JHPrtMarkMidleX
JHPrtMarkMidleY
JHPrtMultiLineX
JHPrtMultiLineY
JHPrtPointLine
JHPrtSemicolonLine

Textausgabegrößen

JHPrtFontHeight
JHPrtTextLength

Sonstiges

JHPrtFileExist
JHPrtGetCompilerExe


JHPrtDefaultPrinter

Funktion JHPrtDefaultPrinter
Syntax

result.l = JHPrtDefaultPrinter()

Beschreibung / Description

Diese Funktion gibt die PB-ID des Standarddruckers zurück, wenn dieser vorhanden ist. Sie müssen die Funktion vor der Benutzung aller anderen Druckerfunktionen aufrufen oder Sie benutzen die alternativ JHPrtSelectPrinter() .

English

This function gives back the PB-ID of default printer. You must call befor all other printerfunctions, else you use JHPrtSelectPrinter() .

Rückgabewerte / Returns

Die PB-Ident des ausgewählten Druckers oder 0 bei Fehler.

The PB ID of your selected printer if successfull or #False if error.


JHPrtDinFormat

Funktion JHPrtDinFormat()
 Zurück Startseite Vor
Syntax

result.s = JHPrtDINFormat()

Beschreibung / Description

Gibt für einige implementierte Blattformate die DIN-Größe zurück. Derzeit hinterlegt sind die Formate A3, A4, A5 und A6.

English

Return the DIN format of paper for some integrated size. In this moment you can use the find A3, A4, A5 and A6.

Rückgabewerte / Returns

Einen String der den Namen des Formates enthält oder wenn nicht unterstützt einen Leerstring.

A string with the name of format or a empty string if false.


JHPrtDirection

Funktion JHPrtDirection()
 Zurück Startseite Vor
Syntax

result.s = JHPrtDirection()

Beschreibung / Description

Gibt die die Blattausrichtung des aktuell eingestellten Druckers als ASCII-String zurück.

English

Return the direction of paper from used printer as ascii-string.

Rückgabewerte / Returns

Der Rückgabestring enthält das Wort "LANDSCAPE" für Querformat oder "PORTRETE" für Hochformat. Kann die Ausrichtung nicht ermittelt werden, so wird ein Leerstring zurückgegeben.

The string content LANDSCAPE or PORTRETE. If false you become a empty string.


JHPrtDownRandPY
Syntax

result.l = JHPrtDownRandPY ()

Beschreibung / Description

Gibt die die Breite des unteren Randes in Pixel zurück. Dies ist eine Druckereinstellung.

English

Return the down space in pixel as long.

Rückgabewerte / Returns

Die Breite des unteren Randes in Pixel des gerade benutzten Druckers oder 0 bei Fehler.

The width of down space in pixel from the used printer or #False if error.


JHPrtDPI

Funktion JHPrtDPI()
 Zurück Startseite Vor
Syntax

result.l = JHPrtDPI ()

Beschreibung / Description

Gibt die Auflösung in Pixel pro Inch zurück. Diese Funktion arbeitet nur richtig, wenn beide Auflösungen des Drucker gleich sind. Es gibt Geräte, da ist die Y-Auflösung verschieden von der in X-Richtung, dann können Sie diese Funktion nicht verwenden.

English

Return the dpi for used printer as long. This function is only correct if you have a printer with the theme dpi for x and y.

Rückgabewerte / Returns

Die Auflösung in DPI gerundet oder 0 bei Fehler.

The roundet dpi or #False if error.


JHPrtDPMX

Funktion JHPrtDPMX()
 Zurück Startseite Vor
Syntax

result.l = JHPrtDPMX ()

Beschreibung / Description

Gibt die Auflösung in Pixel pro Inch für die horizontale Richtung als gerundeten Wert zurück.

English

Return the rounded dpi for x-direction as long.

Rückgabewerte / Returns

Die Auflösung in DPI gerundet oder 0 bei Fehler.

The roundet dpi or #False if error.


JHPrtDPMY

Funktion JHPrtDPMY()
 Zurück Startseite Vor
Syntax

result.l = JHPrtDPMY ()

Beschreibung / Description

Gibt die Auflösung in Pixel pro Inch für die vertikale Richtung als gerundeten Wert zurück.

English

Return the rounded dpi for y-direction as long.

Rückgabewerte / Returns

Die Auflösung in DPI gerundet oder 0 bei Fehler.

The roundet dpi or #False if error.


JHPrtPageSizePX

Funktion JHPrtPageSizePX()
 Zurück Startseite Vor
Syntax

result.l = JHPrtPageSizePX()

Beschreibung / Description

Gibt die Breite des Blattes in Pixel zurück als Long.

English

Return the width of paper in pixel as long.

Rückgabewerte / Returns

- die Blattbreite in Pixel oder 0 bei fehlschlagen der Funktion

- the paper width in pixel or #False if error


JHPrtPageSizePY

Funktion JHPrtPageSizePY()
 Zurück Startseite Vor
Syntax

result.l = JHPrtPageSizePY ()

Beschreibung / Description

Gibt die Höhe des Blattes in Pixel zurück als Long.

English

Return the paper height in pixel as long.

Rückgabewerte / Returns

- die Blatthöhe in Pixel oder 0 bei fehlschlagen der Funktion

- the paper height in pixel or #False if error


JHPrtPaperSizeMX

Funktion JHPrtPaperSizeMX()
 Zurück Startseite Vor
Syntax

result.l = JHPrtPaperSizeMX()

Beschreibung / Description

Gibt die Breite des Blattes in mm zurück als Long.

English

Return the width of paper in mm as long.

Rückgabewerte / Returns

- die Blattbreite in mm oder 0 bei fehlschlagen der Funktion

- the paper width in mm or #False if error


JHPrtPaperSizeMY

Funktion JHPrtPaperSizeMY()
 Zurück Startseite Vor
Syntax

result.l = JHPrtPaperSizeMY ()

Beschreibung / Description

Gibt die Höhe des Blattes in mm zurück als Long.

English

Return the paper height in mm as long.

Rückgabewerte / Returns

- die Blatthöhe in mm oder 0 bei fehlschlagen der Funktion

- the paper height in mm or #False if error


JHPrtPrintSizeMX

Funktion JHPrtPrintSizeMX()
 Zurück Startseite Vor
Syntax

result.l = JHPrtPrintSizeMX ()

Beschreibung / Description

Gibt die Breite des Druckbereiches ohne die eingestellten Ränder in mm zurück.

English

Return the width of printing space in mm as long.

Rückgabewerte / Returns

Die Breite des Druckbereiches oder 0 bei Fehler.

The width for printing space or #False if error.


JHPrtPrintSizeMY

Funktion JHPrtPrintSizeMY()
 Zurück Startseite Vor
Syntax

result.l = JHPrtPrintSizeMY ()

Beschreibung / Description

Gibt die Höhe des Druckbereiches ohne die eingestellten Ränder in mm zurück.

English

Return the height of printing space in mm as long.

Rückgabewerte / Returns

Die Höhe des Druckbereiches oder 0 bei Fehler.

The height for printing space or #False if error.


JHPrtPrintSizePX

Funktion JHPrtPrintSizePX()
 Zurück Startseite Vor
Syntax

result.l = JHPrtPrintSizePX ()

Beschreibung / Description

Gibt die Breite des Druckbereiches ohne die eingestellten Ränder in Pixel zurück.

English

Return the width of printing space in pixel as long.

Rückgabewerte / Returns

Die Breite des Druckbereiches oder 0 bei Fehler.

The width for printing space or #False if error.


JHPrtPrintSizePY

Funktion JHPrtPrintSizePY()
 Zurück Startseite Vor
Syntax

result.l = JHPrtPrintSizePY ()

Beschreibung / Description

Gibt die Höhe des Druckbereiches ohne die eingestellten Ränder in Pixel zurück.

English

Return the height of printing space in pixel as long.

Rückgabewerte / Returns

Die Höhe des Druckbereiches oder 0 bei Fehler.

The height for printing space or #False if error.


JHPrtRightRandPX

Funktion JHPrtRightRandPX()
 Zurück Startseite Vor
Syntax

result.l = JHPrtRightRandPX ()

Beschreibung / Description

Gibt die die Breite des rechten Randes in Pixel zurück. Dies ist eine Druckereinstellung.

English

Return the right space in pixel as long.

Rückgabewerte / Returns

Die Breite des rechten Randes in Pixel des gerade benutzten Druckers oder 0 bei Fehler.

The width of right space in pixel from the used printer or #False if error.


JHPrtSelectPrinter

Funktion JHPrtSelectPrinter()
 Zurück Startseite Vor
Syntax

result.l = JHPrtSelectPrinter ()

Beschreibung / Description

Öffnet den PrinterRequester zur Auswahl eines Druckers. Nehmen Sie dort auch die entsprechenden Einstellungen wie Druckauflösung, Blattausrichtung und so weiter vor.

Wird der Requester abgebrochen, so können Sie die Funktionen der Library nicht benutzen.
Die Rückgabe der Funktion ist der PB-Ident des ausgewählten Printer-Device. Diese Auswahl bleibt so lange gültig, bis Sie einen anderen Drucker auswählen. Änderungen am ausgewählten Drucker müssen Sie mit dieser Funktion vornehmen, da verschiedene Sachen innerhalb der Library abgelegt werden.

Sie müssen diese Funktion auch vor allen anderen der Library benutzen. Oder Sie benutzen die Funktion JHPrtDefaultPrinter() um den Standarddrucker auszuwählen wenn vorhanden.

English

You must use this function first, else you can use JHPrtDefaultPrinter() for standard printer device if exist. Step one is opening the PB printer requester. If you stop this, you dont have a valid ID for printer and its impossible to use the other functions of this library. If you want to change you used printer, you must call this function only. Some information will be stored inside the library.

Rückgabewerte / Returns

Die PB-Ident des ausgewählten Druckers oder 0 bei Fehler.

The PB ID of your selected printer if successfull or #False if error.


JHPrtStartPointPX

Funktion JHPrtStartPointPX()
 Zurück Startseite Vor
Syntax

result.l = JHPrtStartPointPX ()

Beschreibung / Description

Gibt die Startposition abzüglich des durch die Druckereinstellungen festgelegten Rande in Pixel für die horizontale als Long zurück.

English

Return the startposition for printing without rand in the horizontal direction as long.

Rückgabewerte / Returns

Die Position in Pixel von links an der der Ausdruck beginnt oder 0 bei Fehler.

The position in pixel for start printing or #False if error.


JHPrtStartPointPY

Funktion JHPrtStartPointPY()
 Zurück Startseite Vor
Syntax

result.l = JHPrtStartPointPY ()

Beschreibung / Description

Gibt die obere Startposition für den Ausdruck zurück ohne den für den Drucker eingestellten Rand.

English

Return the startposition from left for printing in pixel as long.

Rückgabewerte / Returns

Die Position in Pixel von oben an der der Ausdruck beginnt oder 0 bei Fehler.

The position in pixel for start printing or #False if error.


TextFormat

Kapitel TextFormat
Hier sind alle Funktionen die mit Textformatierung zu tun haben beschrieben. Sie finden diese nicht im Testfile der Library sondern nur im Anwendungsbeispiel.

Here you find all function for text format. You find this functions only in the using_file for this library, not in the test file.


JHPrtBlockTxt

Funktion JHPrtBlockTxt (für Druckfunktionen)
 Zurück Startseite Vor
Syntax

result.s = JHPrtBlockTxt(Text.s, Width.l)

Beschreibung / Description

Diese Funktion kann erst verwendet werden, wenn Sie die PB-2-D-Drawing Funktion StartDrawing(OutputID()) aufgerufen haben. Legen Sie dann den Font fest der für die Druckfunktionen verwendet werden soll, formatieren Sie den Text falls es sich um einen Fließtext handelt mit JHPrtFormatText() und JHPrtFormatedLine() . Führen Sie dann diese Funktion aus. Oder geben Sie einen Text als einzelne Zeile an, von dem Sie wissen das er in die zunkünftige Abmessung passt.

Diese Funktion gibt den angegebenen Text mit der angegebenen Breite des angegebenen Fonts als Blocksatz zurück.

Für die Funktionsweise sehen Sie bitte im Anwendungsbeispiel jh_printer_using_sample.pb nach.

Die Funktion basiert auf der Einfügung von Leerzeichen zwischen die Worte, es ist also (noch) nicht möglich ein einzelnes Wort in eine Blocklänge zu bringen.

English

This function must be called after the PB-2D-Drawing function StartDrawing(OutputID()). Give than the printing font for using. The next is the format of text with the functions JHPrtFormatText() and JHPrtFormatedLine() . You can also use a single line text for this if you know the size is ok.

This function gives back the given string with the given parameters as block.

This function is based of CHR(20) sign between the words. It´s impossible now to use one word in a line for this.

Please see for using the sample file jh_printer_using_sample.pb

Rückgabewerte / Returns

- den gewandelten String wenn erfolgreich
- den Quellstring bei Fehlschlag
- the new string if successful
- source string if false


JHPrtCenterText

Funktion JHPrtCenterText (für Druckfunktionen)
 Zurück Startseite Vor
Syntax

result.s = JHPrtCenterTxt(Text.s, Width.l)

Beschreibung / Description

Diese Funktion kann erst verwendet werden, wenn Sie die PB-2-D-Drawing Funktion StartDrawing(OutputID()) aufgerufen haben. Legen Sie dann den Font fest der für die Druckfunktionen verwendet werden soll. Geben Sie einen Text als einzelne Zeile an, von dem Sie wissen das er in die zunkünftige Abmessung passt.

Diese Funktion gibt den angegebenen Text mit der angegebenen Breite des angegebenen Fonts als zentrierten Satz zurück.

Für die Funktionsweise sehen Sie bitte im Anwendungsbeispiel jh_printer_using_sample.pb nach.

Die Funktion basiert auf der Einfügung von Leerzeichen zwischen die Worte, es ist also (noch) nicht möglich ein einzelnes Wort in eine Blocklänge zu bringen.

English

This function must be called after the PB-2D-Drawing function StartDrawing(OutputID()). Give than the printing font for using. Than use a single line text for this.

This function gives back the given string with the given parameters as centered text.

This function is based of CHR(20) sign between the words. It´s impossible now to use one word in a line for this.

Please see for using the sample file jh_printer_using_sample.pb

Rückgabewerte / Returns

- den gewandelten String wenn erfolgreich
- den Quellstring bei Fehlschlag
- the new string if successful
- source string if false


JHPrtCountWords

Funktion JHPrtCountWords
Syntax

result.l = JHPrtCountWord(Text.s)

Beschreibung / Description

Diese Funktion gibt die Anzahl der Worte eines übergebenen Strings zurück. Die Funktion arbeitet nur korrekt, wenn zwischen jedem Wort ein Leerzeichen eingefügt ist, ansonsten gibt es eine falsche Rückgabe.

English

This function gives back the number of words of a given string. This functions works only correctly if you write one space between the words.

Rückgabewerte / Returns

- größer als Null wenn erfolgreich
- #False wenn das Zählen fehlgeschlagen ist
- greater than zero if successful
- #False at fault


JHPrtFontHeight

Funktion JHPrtFontHeight
Syntax

result.l = JHPrtFontHeight(#Font)

Beschreibung / Description

Diese Funktion gibt die Höhe des verwendeten Font zurück. Es erfolgt eine Prüfung ob die übergebene FontID gültig ist und der Font initialisiert ist. Die Funktion kann auch für die Ermittlung der Höhe eines Font für eine Gadget- oder Fensterausgabe benutzt werden.

English

This function gives back the height of specified font. You can use it also for gadget or window print.

Rückgabewerte / Returns

- größer als Null wenn erfolgreich
- #False wenn fehlgeschlagen
- greater than zero if successful
- #False at fault


JHPrtFormatText

Funktion JHPrtFormatText (für Druckfunktionen)
 Zurück Startseite Vor
Syntax

result.l = JHPrtFormatText(Text.s, Width.l)

Beschreibung / Description

Diese Funktion kann erst verwendet werden, wenn Sie die PB-2-D-Drawing Funktion StartDrawing(OutputID()) aufgerufen haben. Legen Sie dann den Font fest der für die Druckfunktionen verwendet werden soll.

Diese Funktion gibt die Anzahl der Zeilen eines übergebenen Strings zurück damit er mit der Spezifikation "Breite" in das angestrebte Format passt. Nachfolgend müssen Sie die Funktion JHPrtFormatedLine() aufrufen, der Sie die ermittelte Zeilenzahl als Parameter übergeben.

English

This function must be called after the PB-2D-Drawing function StartDrawing(OutputID()). Give than the printing font for using. The next is the call of function JHPrtFormatedLine() to read the single line strings.

This function gives back the line number of given string with the given parameter width.

Rückgabewerte / Returns

- die Anzahl der Zeilen des gewandelten Strings wenn erfolgreich
- the number of lines from string if successful

Beispiel (gekürzt und nicht funktionsfähig) /
Example (cut and not usable)

Für die vollständige funktionsweise sehen Sie bitte im Anwendungsbeispiel jh_printer_using_sample.pb nach.

Please see for using the sample file jh_printer_using_sample.pb

; muß vor JHPrtFormatText() und JHPrtBlockTxt() aufgerufen werden
DrawingFont(FontID(#Font_0))

; den Fließtext an die Breite anpassen und in Zeilen aufteilen
lines.l=JHPrtFormatText(tx, TxWX)
ClearList(Text())
For a= 1 To lines
AddElement(Text())
; die erstellten Zeile auslesen, Anfangswert ist 1. Ein Wert kleiner als
; 1 oder größer als die Zeilenzahl ergibt einen Leerstring als Rückgabe
; vorher muß die Funktion JHPrtFormatText() aufgerufen werden, wird
; dies nicht getan, so wird entweder nur ein Leerstring zurückgegeben
; oder aber der zuletzt formatierte Inhalt
Text()=JHPrtFormatedLine(a)
Next a


JHPrtFormatedLine

Funktion JHPrtFormatedLine (für Druckerfunktionen)
 Zurück Startseite Vor
Syntax

result.s = JHPrtFormatedLines(Number.l)

Beschreibung / Description

Diese Funktion kann erst verwendet werden, wenn Sie die PB-2-D-Drawing Funktion StartDrawing(OutputID()) aufgerufen haben. Legen Sie dann den Font fest der für die Druckfunktionen verwendet werden soll.

Außerdem müssen Sie mit der Funktion JHPrtFormatText() den Inhalt erstellen.

Diese Funktion gibt den Inhalt des Strings zurück, der mit dem Index angesprochen wird. Die Länge des Strings orientiert sich an der vorhergehenden Formatierung mit der Funktion JHPrtFormatText() .

English

This function must be called after the PB-2D-Drawing function StartDrawing(OutputID()). Give than the printing font for using. The next is the call of function JHPrtFormatedLine() to read the single line strings.

This function gives back the string from given index.

Rückgabewerte / Returns

- den String wenn erfolgreich
- the string if successful

Beispiel (gekürzt und nicht funktionsfähig) /
Example (cut and not usable)

Für die vollständige funktionsweise sehen Sie bitte im Anwendungsbeispiel jh_printer_using_sample.pb nach.

Please see for using the sample file jh_printer_using_sample.pb

; muß vor JHPrtFormatText() und JHPrtBlockTxt() aufgerufen werden
DrawingFont(FontID(#Font_0))

; den Fließtext an die Breite anpassen und in Zeilen aufteilen
lines.l=JHPrtFormatText(tx, TxWX)
ClearList(Text())
For a= 1 To lines
AddElement(Text())
; die erstellten Zeile auslesen, Anfangswert ist 1. Ein Wert kleiner als
; 1 oder größer als die Zeilenzahl ergibt einen Leerstring als Rückgabe
; vorher muß die Funktion JHPrtFormatText() aufgerufen werden, wird
; dies nicht getan, so wird entweder nur ein Leerstring zurückgegeben
; oder aber der zuletzt formatierte Inhalt
Text()=JHPrtFormatedLine(a)
Next a


JHPrtGadgetBlockText

Funktion JHPrtGadgetBlockText (für Gadget oder Bildschirm)
 Zurück Startseite Vor
Syntax

result.s = JHPrtGadgetBlockText(Text.s, Width.l, #FontNo, FontName.s, FontSize.l, FontStyle.l)

Beschreibung / Description

Diese Funktion gibt den angegebenen Text mit der angegebenen Breite des angegebenen Fonts als Blocksatz zurück. Für die Breite geben Sie die des zu verwendeten Gadget an. Die Konstante #FontNo bezeichnet den Identifer des zu verwendenten Font, FontName.s gibt den Namen des Font an, FontSize die Höhe und FontStyle eine der PB FontStyle Konstanten. Wenn Sie für FontStyle #False übergeben wird mit dem Standardstyle gearbeitet. Sie sollten vor immer die Funktion JHPrtSetGadgetFont() aufrufen. Die Ermittlung der Ausgabebreite erfolgt innerhalb der Procedure basierend auf der aktuellen Einstellung ihres Ausgabegerätes.

Für die Funktionsweise sehen Sie bitte im Anwendungsbeispiel jh_printer_using_sample.pb nach.

Die Funktion basiert auf der Einfügung von Leerzeichen zwischen die Worte, es ist also (noch) nicht möglich ein einzelnes Wort in eine Blocklänge zu bringen.

English

This function gives back the given string with the given parameters as block. Width.l is the width of gadget for using. #FontNo is the ID of used font, FontName the name of this, FontSize the specified size of font and FontStyle the PB constant for style or #False for standard. Please use first JHPrtSetGadgetFont() .

This function is based of CHR(20) sign between the words. It´s impossible now to use one word in a line for this (in the moment).

Please see for using the sample file jh_printer_using_sample.pb

Rückgabewerte / Returns

- den gewandelten String wenn erfolgreich
- den Quellstring bei Fehlschlag
- the new string if successful
- source string if false

Beispiel / Example

tx1.s="Eine Fließtextausgabe in ein Textgadget"
; Der Text
TxtWid.l=510; Die Breite des späteren Gadget vermindert um 4 Pixel
tx.s="Im folgenden werden Sie aufgefordert, den Drucker auszuwählen. "
tx +"Ein Abbruch führt zur Beendigung des Programms. Verschiedene "
tx +"Einstellungen sind abhängig vom verwendeten Drucker und dessen "
tx +"Einstellungen. Auf diese nimmt das Programm Bezug. Ändern Sie "
tx +"die Einstellungen für den Drucker separat, diese können von "
tx +"hier nicht beeinflußt werden. "
; den gesamten Fließtext anpassen in Blocksatz
; setzt den Font für das Gadget, sollte man machen ;)
FontHe.l=JHPrtSetGadgetFont("ARIAL",10,0,#PB_Font_Bold)
tx2.s=JHPrtGadgetBlockText(tx, TxtWid, 1, "ARIAL", FontHe, #PB_Font_Bold)
tx+Chr(13)+Chr(13)
tx+"Und nun das Ganze im Blocksatz wiederholen."
tx+Chr(13)+Chr(13)
tx+tx2
tx=tx1+Chr(13)+Chr(13)+tx

; Informationsfenster öffnen
win.l=OpenWindow(#PB_Any, 0, 0,520,290,"Testprogramm JHPrinter_400 UserLibrary",#PB_Window_SystemMenu|#PB_Window_ScreenCentered)
If win
If CreateGadgetList(WindowID(win))
TextGadget (#PB_Any, 5, 0,514,280,tx)
EndIf
Repeat
Select WaitWindowEvent()
Case #PB_Event_CloseWindow
Quit=#True
EndSelect
Until Quit
EndIf


JHPrtGetDesktopDPI

Funktion JHPrtGetDesktopDPI
Syntax

result.l = JHPrtGetDesktopDPI()

Beschreibung / Description

Diese Funktion gibt die eingestellte Auflösung des Desktops zurück. Standardmäßig ist 96 DPI eingestellt (kleine Schriftarten). Um jedoch in der Programmumgebung auch zu gewährleisten, das die Darstellung immer gleich ist, kann diese Funktion dazu benutzt werden, eine Schriftart zu wählen die immer im Verhältnis zu einer Ausgabe basierend auf der Standardeinstellung ein gleiches Aussehen der erstellten Fenster gewähleistet.

Es handelt sich hierbei um die gleiche Funktion wie in der JHRegistry_Libray, mit dem Unterschied, das hier noch die Höhe des berechneten Font zurückgegeben wird.

English

This function gives the oriented dissolving of the desktop back. Per default is oriented for 96 DPI (small scripts). Which is always the representation at once, this function can be used to this, a similar appearance of the erected windows makes on the standard attitude always basing this one in proportion to a version it possible a script to choose to also guarantee, however, in the program surroundings.

Rückgabewerte / Returns

- größer als Null wenn erfolgreich
- #False wenn die Ausgabe fehlgeschlagen ist
- greater than zero if successful
- #False at fault


JHPrtSetGadgetFont

Funktion JHPrtSetGadgetFont (für Gadget oder Bildschirm)
 Zurück Startseite Vor
Syntax

result.l = JHPrtSetGadgetFont(Fontname.s, Fontsize.l, FontID, FontStyle)

Beschreibung / Description

Diese Funktion stellt den Gadgetfont ein auf eine frei wählbare Schriftart und Größe, die sich auf eine Desktopauflösung von 96 DPI bezieht. Es wird somit immer ein gleiches Aussehen der Inhalte gewährleistet, unabhängig von den Systemeinstellungen für die Darstellung der Schriftarten. Beachten Sie jedoch, daß nicht alle Schriftarten in allen möglichen Größen auf jedem System vorhanden sind. Meist richtig liegen Sie mit Arial.

Es handelt sich hierbei um die ähnliche Funktion wie in der JHRegistry_400 Library. Unterschiede sind die erweiterte Übergabe und die Rückgabewerte.

English

This function adjusts the gadgetfont to a script freely eligible for office and size which refers to a desktop dissolving of 96 DPI. A similar appearance of the contents is always guaranteed independently of the system attitudes for the representation of the scripts therefore. Make sure, however, that all scripts aren't available in all possible sizes on every system. You usually lie correctly with Arial.

Rückgabewerte / Returns

- die Größe des Font wenn erfolgreich
- #False bei Fehler
- size of font if successful
- #False at fault

FontID sollte eine Konstante sein, die man mit Enumeration festlegt.
FontID should be a constant which one fixes with Enumeration.

FontStyle sind die PB Konstanten für den Style
FontStyle are the PB constants for style


JHPrtTextLength

Funktion JHPrtTextLength
Syntax

result.l = JHPrtTextLength(Text.s, #Font)

Beschreibung / Description

Diese Funktion gibt die Länge des übergebenen Textes bei Benutzung des angegebenen Font zurück. Es erfolgt eine Prüfung ob die übergebene FontID gültig ist und der Font initialisiert ist. Die Funktion kann auch für die Ermittlung der Höhe eines Font für eine Gadget- oder Fensterausgabe benutzt werden.

English

This function gives back the length of given text by using specified font. You can use it also for gadget or window print.

Rückgabewerte / Returns

- größer als Null wenn erfolgreich
- #False wenn fehlgeschlagen
- greater than zero if successful
- #False at fault


JHPrtVersion

Funktion JHPrtVersion()
 Zurück Startseite Vor
Syntax

result.s = JHPrtVersion (flag.b)

Beschreibung / Description

Gibt die Versionsnummer der Library als ASCII-String zurück.

English

Returns the number of version from the library as ascii-string.

Rückgabewerte / Returns

- mit flag = 1 wird ein Requester geöffnet der die Daten anzeigt. Außerdem wird
der Rückgabestring mit der Versionsnummer belegt.
- mit flag <> 1 wird nur der Rückgabestring mit der Versionsnummer belegt.
- with flag = #True is open a requester with the version informations. The string will be return
the number of version.
- with flag <> #True give only the string with version number.


JHPrtVersionDate

Funktion JHPrtVersionDate()
 Zurück Startseite Vor
Syntax

result.s = JHPrtVersionDate()

Beschreibung / Description

Gibt das Versionsdatum der Library als ASCII-String zurück.

English

Returns the date of version from the library as ascii-string.

Rückgabewerte / Returns

- Das Versionsdatum der Library

- the date of version from the library


JHPrtGetCompilerExe

Funktion JHPrtGetCompilerExe()
 Zurück Startseite Vor
Syntax

result.s=JHPrtGetCompilerExe()

Beschreibung / Description

Gibt bei Abfrage den Status des Pfads zurück aus der die Abfrage erfolgte. Wurde die exe aus dem Compiler gestartet, so wird #True zurückgegeben, ansonsten #False

English

At query gives back the state of path from the running aplication. Is your program start from compiler than it´s #True, else #False

Rückgabewerte / Returns

- #False wenn die exe nicht im Compilerpfad läuft
- #True wenn die exe im Compilerpfad läuft
- #False if not compiler running
- #True if compiler running


JHPrtFileExist

Funktion JHPrtFileExist()
 Zurück Startseite Vor
Syntax
result.l = JHRegFileExist(Path.s, File.s)

Beschreibung / Description

Die Funktion versucht anhand der Angaben festzustellen, ob ein File existiert.

English

This function contol if exist a file with the given name in the given path

Rückgabewerte / Returns

0 wenn das File nicht exisitiert
1 wenn das File existiert
-1 wenn der übergebene Pfadname leer war
-2 wenn der übergebene Filename leer war

English

0 if not exist a file with this name in this directory
1 if exist this file
-1 the given directory name was empty
-2 the given filename was empty


JHPrtBackGround

Funktion JHPrtBackGround
Syntax

result.l = JHPrtBackGround(XPos.l, YPos.l, Width.l, Height.l, FrameWidth.l, FrameColor.l, BackColor.l)

Beschreibung / Description

Diese Funktion kann erst verwendet werden, wenn Sie die PB-2-D-Drawing Funktion StartDrawing(OutputID()) aufgerufen haben.

Diese Funktion erzeugt ein eingefärbtes Rechteck wahlweise mit oder ohne Rahmen. Hintergrund- und Rahmenfarbe können getrennt voneinander eingestellt werden. Ist die Rahmenbreite < 1 so wird nur der Hintergrund in der angegebenen Dimension dargestellt.

Für die Funktionsweise sehen Sie bitte im Anwendungsbeispiel jh_printer_using_sample.pb nach.

English

This function must be called after the PB-2D-Drawing function StartDrawing(OutputID()).

This function make a rectangle with or without frame. You can set the colors for background and frame separately. If you use a value for the width of frame smaller than 1, so only the background is shown in the stated dimension.
Please see for using the sample file jh_printer_using_sample.pb

Rückgabewerte / Returns

- #True wenn erfolgreich
- #True if successful


JHPrtLine

Funktion JHPrtLine
Syntax

result.l = JHPrtLine(XPos.l, YPos.l, Len.l, Dir.l, Width.l, Color.l)

Beschreibung / Description

Diese Funktion kann erst verwendet werden, wenn Sie die PB-2-D-Drawing Funktion StartDrawing(OutputID()) aufgerufen haben.

Diese Funktion zeichnet eine Linie in horizontaler oder vertikaler Richtung in Abhängikeit von der Variablen Dir.l. Ist Dir = 0 so wird horizontal gezeichnet. Die Länge und die Breite müssen jeweils mindestens 1 sein, sonst werden sie innerhalb auf diesen Wert gesetzt. Negative Werte sind nicht zulässing und werden auf 0 oder 1 gesetzt.

Die Breite (Width) kann maximal 40 Pixel sein, ansonsten wird auf diesen Wert gesetzt.

Für die Funktionsweise sehen Sie bitte im Anwendungsbeispiel jh_printer_using_sample.pb nach.

English

This function must be called after the PB-2D-Drawing function StartDrawing(OutputID()).

This function draw a line in horizontal or vertical direction. The direction is horizontal if the parameter Dir = 0. For length and width you must give 1 or more. Don´t use negative numbers, this will be correct to 0 or 1 inside the function.

The width maxium is 40 pixel, if you use more I will set 40.

Please see for using the sample file jh_printer_using_sample.pb

Rückgabewerte / Returns

- #True wenn erfolgreich
- #True if successful


JHPrtMarkMiddleX

Funktion JHPrtMarkMiddleX
Syntax

result.l = JHPrtMarkMiddleX(Length.l, Color.l)

Beschreibung / Description

Diese Funktion kann erst verwendet werden, wenn Sie die PB-2-D-Drawing Funktion StartDrawing(OutputID()) aufgerufen haben.

Diese Funktion zeichnet eine Linie in vertikaler Richtung in die Mitte in der waagrechten Seite. Die Linienbreite beträgt 1 Pixel, die Länge kann angegeben werden.

Die Länge kann maximal der einfache Wert von DPI sein, minimal 10 Pixel. DPI wird aus den aktuellen Einstellungen für das Ausgabegerät ermittelt.

Die Funktion bezieht sich immer auf den tatsächlichen Drucker, bezieht also physikalische Ränder in die Berechnung ein. Für eine Imageausgabe blenden Sie die Markierung einfach aus.

Für die Funktionsweise sehen Sie bitte im Anwendungsbeispiel jh_printer_using_sample.pb nach.

English

This function must be called after the PB-2D-Drawing function StartDrawing(OutputID()).

This function draw a line in vertical direction in the middle of horizontal side with the width of one pixel. For length you can give maximal 1*DPI, the smallest length is 10 Pixel. The value of DPI is determined from current attitudes of printer device.

Please see for using the sample file jh_printer_using_sample.pb

Rückgabewerte / Returns

- #True wenn erfolgreich
- #True if successful


JHPrtMarkMiddleY

Funktion JHPrtMarkMiddleY
Syntax

result.l = JHPrtMarkMiddleY(Length.l, Color.l)

Beschreibung / Description

Diese Funktion kann erst verwendet werden, wenn Sie die PB-2-D-Drawing Funktion StartDrawing(OutputID()) aufgerufen haben.

Diese Funktion zeichnet eine Linie in horizontaler Richtung in die Mitte in der senkrechten Seite. Die Linienbreite beträgt 1 Pixel, die Länge kann angegeben werden.

Die Länge kann maximal der einfache Wert von DPI sein, minimal 10 Pixel. DPI wird aus den aktuellen Einstellungen für das Ausgabegerät ermittelt.

Die Funktion bezieht sich immer auf den tatsächlichen Drucker, bezieht also physikalische Ränder in die Berechnung ein. Für eine Imageausgabe blenden Sie die Markierung einfach aus.

Für die Funktionsweise sehen Sie bitte im Anwendungsbeispiel jh_printer_using_sample.pb nach.

English

This function must be called after the PB-2D-Drawing function StartDrawing(OutputID()).

This function draw a line in horizontal direction in the middle of vertical side with the width of one pixel. For length you can give maximal 1*DPI, the smallest length is 10 Pixel. The value of DPI is determined from current attitudes of printer device.

Please see for using the sample file jh_printer_using_sample.pb

Rückgabewerte / Returns

- #True wenn erfolgreich
- #True if successful


JHPrtMultiLineX

Funktion JHPrtMultiLineX
Syntax

result.l = JHPrtMultiLineX(XPos.l, YPos.l, Length.l, Width.l, Number.l, Distance.l, Color.l)

Beschreibung / Description

Diese Funktion kann erst verwendet werden, wenn Sie die PB-2-D-Drawing Funktion StartDrawing(OutputID()) aufgerufen haben.

Diese Funktion zeichnet eine Anzahl von Linie in horizontaler Richtung von links nach rechts. Bestimmen Sie Anzahl und Abstand. Die Länge, Breite, Anzahl und Distanz müssen jeweils mindestens 1 sein, sonst werden sie innerhalb auf diesen Wert gesetzt. Negative Werte sind nicht zulässing und werden auf 0 oder 1 gesetzt.

Die Breite (Width) kann maximal 40 Pixel sein, ansonsten wird auf diesen Wert gesetzt.

Für die Funktionsweise sehen Sie bitte im Anwendungsbeispiel jh_printer_using_sample.pb nach.

English

This function must be called after the PB-2D-Drawing function StartDrawing(OutputID()).

This function draw a number of lines in horizontal direction from the left to the right. Please select your number and distance. All Parameters must be 1 or greater, for startposition and color you can also use 0. Don´t use negative numbers, this will be correct to 0 or 1 inside the function.

The width maxium is 40 pixel, if you use more I will set 40.
Please see for using the sample file jh_printer_using_sample.pb

Rückgabewerte / Returns

- #True wenn erfolgreich
- #True if successful


JHPrtMultiLineY

Funktion JHPrtMultiLineY
Syntax

result.l = JHPrtMultiLineY(XPos.l, YPos.l, Length.l, Width.l, Number.l, Distance.l, Color.l)

Beschreibung / Description

Diese Funktion kann erst verwendet werden, wenn Sie die PB-2-D-Drawing Funktion StartDrawing(OutputID()) aufgerufen haben.

Diese Funktion zeichnet eine Anzahl von Linie in vertikaler Richtung von oben nach unten. Bestimmen Sie Anzahl und Abstand. Die Länge, Breite, Anzahl und Distanz müssen jeweils mindestens 1 sein, sonst werden sie innerhalb auf diesen Wert gesetzt. Negative Werte sind nicht zulässing und werden auf 0 oder 1 gesetzt.

Die Breite (Width) kann maximal 40 Pixel sein, ansonsten wird auf diesen Wert gesetzt.

Für die Funktionsweise sehen Sie bitte im Anwendungsbeispiel jh_printer_using_sample.pb nach.

English

This function must be called after the PB-2D-Drawing function StartDrawing(OutputID()).

This function draw a number of lines in vertical direction from the top to the bottom. Please select your number and distance. All Parameters must be 1 or greater, for startposition and color you can also use 0. Don´t use negative numbers, this will be correct to 0 or 1 inside the function.

The width maxium is 40 pixel, if you use more I will set 40.
Please see for using the sample file jh_printer_using_sample.pb

Rückgabewerte / Returns

- #True wenn erfolgreich
- #True if successful


JHPrtPointLine

Funktion JHPrtPointLine
Syntax

result.l = JHPrtPointLine(XPos.l, YPos.l, Length.l, Width.l, Dir.l, Distance.l, PointLength.l, Color.l)

Beschreibung / Description

Diese Funktion kann erst verwendet werden, wenn Sie die PB-2-D-Drawing Funktion StartDrawing(OutputID()) aufgerufen haben.

Diese Funktion zeichnet eine gepunktete oder gestrichelte Linie in horizontaler oder vertikaler Richtung in Abhängikeit von der Variablen Dir.l. Ist Dir = 0 so wird horizontal gezeichnet. Die Länge, Breite, Distance und PointLength müssen jeweils mindestens 1 sein, sonst werden sie innerhalb auf diesen Wert gesetzt. Negative Werte sind nicht zulässing und werden auf 0 oder 1 gesetzt.

Die Breite (Width) kann maximal 40 Pixel sein, ansonsten wird auf diesen Wert gesetzt.

Für die Funktionsweise sehen Sie bitte im Anwendungsbeispiel jh_printer_using_sample.pb nach.

English

This function must be called after the PB-2D-Drawing function StartDrawing(OutputID()).

This function draw a point line in horizontal or vertical direction. The direction is horizontal if the parameter Dir = 0. For length, width, distance and pointlength you must give 1 or more. Don´t use negative numbers, this will be correct to 0 or 1 inside the function.

The width maxium is 40 pixel, if you use more I will set 40.

Please see for using the sample file jh_printer_using_sample.pb

Rückgabewerte / Returns

- #True wenn erfolgreich
- #True if successful


JHPrtSemicolonLine

Funktion JHPrtSemicolonLine
 Zurück Startseite
Syntax

result.l = JHPrtSemicolonLine(XPos.l, YPos.l, Length.l, Width.l, Dir.l, Distance.l, LineLength.l, PointLength.l, Color.l)

Beschreibung / Description

Diese Funktion kann erst verwendet werden, wenn Sie die PB-2-D-Drawing Funktion StartDrawing(OutputID()) aufgerufen haben.

Diese Funktion zeichnet eine Strich-Punkt Linie in horizontaler oder vertikaler Richtung in Abhängikeit von der Variablen Dir.l. Ist Dir = 0 so wird horizontal gezeichnet. Die Länge, Breite, Distance, LineLength und PointLength müssen jeweils mindestens 1 sein, sonst werden sie innerhalb auf diesen Wert gesetzt. Negative Werte sind nicht zulässing und werden auf 0 oder 1 gesetzt.

Die Breite (Width) kann maximal 40 Pixel sein, ansonsten wird auf diesen Wert gesetzt.

Für die Funktionsweise sehen Sie bitte im Anwendungsbeispiel jh_printer_using_sample.pb nach.

English

This function must be called after the PB-2D-Drawing function StartDrawing(OutputID()).

This function draw a semicolon line in horizontal or vertical direction. The direction is horizontal if the parameter Dir = 0. For length, width, distance, linelength and pointlength you must give 1 or more. Don´t use negative numbers, this will be correct to 0 or 1 inside the function.

The width maxium is 40 pixel, if you use more I will set 40.

Please see for using the sample file jh_printer_using_sample.pb

Rückgabewerte / Returns

- #True wenn erfolgreich
- #True if successful


Syntax

result.l = JHPrtSemicolonLine(XPos.l, YPos.l, Length.l, Width.l, Dir.l, Distance.l, LineLength.l, PointLength.l, Color.l)

Beschreibung / Description

Diese Funktion kann erst verwendet werden, wenn Sie die PB-2-D-Drawing Funktion StartDrawing(OutputID()) aufgerufen haben.

Diese Funktion zeichnet eine Strich-Punkt Linie in horizontaler oder vertikaler Richtung in Abhängikeit von der Variablen Dir.l. Ist Dir = 0 so wird horizontal gezeichnet. Die Länge, Breite, Distance, LineLength und PointLength müssen jeweils mindestens 1 sein, sonst werden sie innerhalb auf diesen Wert gesetzt. Negative Werte sind nicht zulässing und werden auf 0 oder 1 gesetzt.

Die Breite (Width) kann maximal 40 Pixel sein, ansonsten wird auf diesen Wert gesetzt.

Für die Funktionsweise sehen Sie bitte im Anwendungsbeispiel jh_printer_using_sample.pb nach.

English

This function must be called after the PB-2D-Drawing function StartDrawing(OutputID()).

This function draw a semicolon line in horizontal or vertical direction. The direction is horizontal if the parameter Dir = 0. For length, width, distance, linelength and pointlength you must give 1 or more. Don´t use negative numbers, this will be correct to 0 or 1 inside the function.

The width maxium is 40 pixel, if you use more I will set 40.

Please see for using the sample file jh_printer_using_sample.pb

Rückgabewerte / Returns

- #True wenn erfolgreich

- #True if successful