uber

Über / About
 Startseite Vor
Hilfefile zur / Help file for /
UserLib JHRegistry_450 von / by Jens Haipeter

Library:
V2.57 vom / built 01.08.2011
Hilfe / Help:
V2.57 vom / built 01.08.2011

Die Library ist ausschließlich für: PB 4.5x / Windows-X86-Version /
The library is only for PB4.5x, windows X86 version

Win98, ME, XP, Server2003, Vista, Windows7

Library is tested for PB 4.50 / 4.51

Die Library ist als MultiLib erstellt, d.h. es können die Modi Unicode, Threadsafe und die Kombination aus beiden verwendet werden.

This library is create as multi. You can use unicode, threadsafe and unicode+threadsafe.

Diese UserLibrary wurde geschrieben für PureBasic Version 4.5x. Sie dient der Abfrage, Eintragung und Entfernung von Registryschlüsseln. Alle Funktionen wurden mehrfach getestet. Es wird keinerlei Garantie auf Funktion oder Nichtfunktion übernommen. Die Benutzung erfolgt auf eigene Gefahr, da ich keinen Einfluß auf korrekte Eintragung der Schlüsselworte für die Registry habe. Benutzen Sie die Funktionen der Library mit Bedacht. Eine unsachgemässe Anwendung führt sonst möglicher Weise zu einem Systemcrash, besonders bei unsachgemäßer Verwendung der Löschfunktionen. Außerdem sind einige weitere Funktionen enthalten, siehe Funktionsliste .

English

This UserLibrary was written for PureBasic version 4.5x. for you serves the query, entry, change and distance of registry keys. All functions were tested repeatedly. No guarantee is taken on function or not function. The use carried out at her own risk, since no influence on correct entry for the keyword for the registry I have. Use the library functions deliberately. An improper application leads otherwise possible way to a system crash particularly at improper use of the deleting functions. In addition, some further functions are contained, see function list please.

Verwendung fand ein Codebeispiel aus dem Codearchiv, jedoch wurden erhebliche Teile verändert beziehungsweise angepasst und erweitert. Die Basis ist dieser Code (für die Registryfunktionen): German forum: http://robsite.de/php/pureboard/viewtopic.php?t=1378&highlight=
Author: Manne Date: 16. June 2003 (updated on 26. July 2003)

Weiterhin fand für die Erstellung von Shell Shortlink ein Codebeispiel von Danilo Krahn Verwendung.

Dem Paket beigefügt sind verschiedene Codebeispiele, welche soweit überschaubar alle Funktionen beinhalteten.

A code example which contains all functions is enclosed with the package.

Chemnitz, im Februar 2011

Jens Haipeter, Website: www.jens-haipeter.de


History
 Zurück Startseite Vor
Änderungen, Erweiterungen, Reparaturen an der UserLib

In der Version 1.02 neu:

- verschiedene Pfadabfragen
- Auflösung des Desktops abfragen

Version 1.03 repariert:

- lesen von Binarys arbeitet jetzt korrekt
- Längenbeschränkung für String und Binary aufgehoben

Version 1.04 erweitert:

- Funktionsumfang von JHRegGetBinary, siehe Funktionsbeschreibung

Version 1.05 repariert:

- schreiben von Binary in einen Schlüssel

Version 1.05 geändert:

- eine neue Funktion für das Anzeigen des Hexdump
- Die Fensteranzeige aus der Procedure JHRegGetBinary() entfernt

Version 1.06 hinzugefügt:

- Binary eintragen aus Speicherbereich
- freie Fontwahl für JHRegSetGadgetFont()

Version 1.06 geändert:

- numerische Rückgaben sind im Fehlerfalle generell negative Zahlen
- verschiedene Proceduren benötigen kein Flag mehr
- wo sinnvoll, Rückgaben in Zahlen geändert anstelle von String
- Rückgaben DWord und Binary sind jetzt numerisch
- bei JHRegGetBinary keine Auswahl mehr als Stringrückgabe, benutzen Sie wenn ein String benötigt werden sollte die allgemeine Funktion JHRegGetValue
- bei den beiden Fenster Funktionen muß noch eine FontID übergeben werden

Version 1.07 geändert:

- alle Fehlerrückgaben können optional zugeschaltet werden, sonst bei Fehler 0 bzw. Leerstring
- die angegebenen Flag sind für alle Funktionen optional, können also weggelassen werden

Version 2.01 repariert:

- Umrechnung eines binären Wertes in eine Dezimalzahl wird als Quad zurück gegeben (32 Bit unsigned)

Version 2.01 hinzugefügt:

- 32 Bit Hexadezimal/Dezimalumrechnung
- 64 Bit Hexadezimal/Binärumrechnung
- 64 Bit Binär/Hexadezimalumrechnung

Version 2.02 - 11.08.2006

geändert:
- alle Fehlerrückgaben werden nicht mehr der Funktionsrückgabe zugeordnet sondern können
mit einer neu eingeführten Funktion nachträglich bei Erfordernis abgefragt werden.
- bei den meisten Funktionen ist das Flag entfallen.
- englische Hilfe so gut es geht.

Version 2.03 - 24.09.2006

hinzugefügt:
- Personal Path (Eigene Dateien)
- Shell Link erstellen
- Abfrage der Libraryversion
- Überarbeitung der Hilfe

Version 2.04 - 30.09.2006

hinzugefügt:
- ShellLink Erstellung geändert und eine vereinfachte Version hinzugefügt

Version 2.05 - Testversion 15.10.2006

Version 2.06 - 15.10.2006

hinzugefügt:
- Auflistung der in einem Subkey befindlichen Subkey (JHRegListSubKey)
- lesen und schreiben von REG_EXPANDED_SZ
- Funktion JHRegGetValueType neu
- Erweiterung der Funktion JHRegListContents auf die Anzeige von SubKey in
der Tabelle und dort entsprechende Anzeigeoptionen eingefügt
- Anzeige des Value Type in der eben genannten Funktion

geändert:
- die Abfrage auf einen leeren Subkey beim Löschen erstreckt sich jetzt auch
auf eventuell dort vorhandene weitere Subkey
- Umbenennung JHRegListValue in JHRegListContens

Version 2.07 - 20.10.2006

repariert:
- die Rückgabe des Wertes für <Standard> erfolgte nicht

Version 2.08 - 23.10.2006

hinzugefügt:
- verschiedene Pfadfunktionen
- erstellen eines Farbverlaufs

Version 2.09 - 30.10.2006

hinzugefügt:
- Pfad zur aktuell aktiven PB-Version
- erstellen eines Setupfensters mit verschiedenen Optionen
- erstellen einer DataSection aus einem File
- Vorabanzeige der optischen Wirkung von Gradientenfarben
- eine Funktion zur Prüfung ob ein File vorhanden ist oder nicht
- Rückgabe des Library Versionsdatums

Version 2.10 - 11.11.2006

hinzugefügt:
- Introduce-Window mit verschiedenen Optionen
geändert:
- Setup-Window Optionen

Version 2.11 - 14.11.2006

geändert:
- Funtionen Setup-Window ruft nicht mehr optional das Introduce auf
- bei Introduce kann jetzt auch ein eigenes Hintergrundbild gewählt werden
- das Introduce-Fenster ist nicht mehr im Vollbildmodus, sondern 800*600 Pixel

Version 2.12 - 21.11.2006

repariert:
- Fehler im Intro-Window

Version 2.13
Version 2.14

Version 2.15 - 17.02.2007

hinzugefügt
- 3 Funktionen für den Pfad der aktuellen Exe

geändert
- Rückgabe der Funktion JHRegSetGadgetFont()

Version 2.16 - 11.03.2007

hinzugefügt
- 2 Funktionen für die Windowsversion

Version 2.17 - 26.04.2007

geändert
- Funktion JHRegShowPalette()

Version 2.18 - 03.05.2007

geändert
- Anpassung auf Windows Vista

Version 2.19 - 06.05.2007

hinzugefügt
- 2 Pfadfunktionen

Version 2.20 - 07.05.2007

hinzugefügt
- 2 Pfadfunktionen

Version 2.21 - nicht öffentliche Version

Version 2.22 - 31.05.2007

hinzugefügt
- 2 Stringfunktionen
- Systemsprache feststellen
- Freischaltcodefenster

Version 2.23 - 07.06.2007

hinzugefügt
- Compilerversion
- Compilerneustart
- Fenster in den Vordergrund holen
- nur eine Instanz ermöglichen

repariert
- PBPfad abfragen

Version 2.24 - 12.07.2007

geändert
- Abfragefunktion ob die exe im Compiler läuft (Vistakompatibilität)

Version 2.25 - 06.12.2007

repariert:
- Anpassungen an PB 4.10

geändert:
- Setupfunktion zeigt jetzt auch den Namen des Programms an

Version 2.26 - 24.12.2007

geändert:
- Setupfunktion Codeeingabefenster kann aus der Zwischenablage bedient werden

Version 2.27 - 26.12.2007

hinzugefügt:
- Pfadfunktionen

Version 2.28 - 02.01.2008

repariert:
- Anpassung an PB4.20_Beta1

Version 2.29 - 25.05.2008

repariert:
- Anpassung an PB4.20 Final

Version 2.30 - 13.06.2008

repariert:
- Bugfix für PB4.20 Final

geändert:
- vorerst sind zwei Funktionen außer Kraft gesetzt: JHRegListContents und JHRegShowPalette

Version 2.40 - 24.03.2009

repariert:
- Bugfix für PB4.30 Final

Version 2.41 - 29.04.2009

repariert:
- JHRegStartOnlyOneInstance

Version 2.42 - 05.05.2009

hinzugefügt:
- JHRegIntroduce kann jetzt alternativ ohne Sprite ausgeführt werden

Version 2.43 - 13.05.2009

hinzugefügt:
- JHRegCreateGradientImage zur Gradientenerstellung

Version 2.44 - 15.08.2009

repariert:
- Fix für PB4.40 B1

Version 2.45 - 12.12.2009

repariert:
- Fix für PB4.40

Version 2.46 - 21.01.2010

hinzugefügt:
- Änderungen am Setup und Introwindow

Version 2.47 - 08.02.2010

geprüft:
- PB4.41 tauglich

Version 2.48 - 23.08.2010

geprüft:
- PB4.50 tauglich

Version 2.49 - 11.12.2010

geprüft:
- PB4.51 tauglich

hinzugefügt:
- Abfrage Dateityp registrieren im Setup-Fenster der Funktion CreateSetupWindow

Version 2.50 - 12.12.2010

repariert:
- Bugfix

Version 2.51 - 29.12.2010

geändert:
- JHRegStartOnlyOneInstance

hinzugefügt:

- Testcode für Instanzen

Version 2.52 - 15.01.2011
unveröffentlichte Version
geändert:
Anpassungen für Unicode

Version 2.53 - 04.02.2011

hinzugefügt:

- Unicode-Version

Version 2.54 - 06.02.2011

es wurde entfernt:
- separate Library für Unicode
- JHRegGetPBVersion()

es wurde geändert:
- JHRegGetPBVersion() in JHRegGetPBVersionsNumber()

es wurde repariert:
- JHRegGetPBVersionsNumber()
- JHRegShowPalette()
- JHRegListContents()

hinzugefügt:
- JHRegGetPBVersionFull()
- JHRegGetLoWord
- JHRegGetHiWord
- Multi-Version, d.h. es ist möglich sowohl Unicode als auch Threadsafe und
die Kombination von beidem zu benutzen

Version 2.55 - 08.06.2011

es wurde repariert:
- JHRegSetString wurde bei UniCode falsch beschrieben

Version 2.56 - 10.06.2011

hinzugefügt:

- Lesen/Schreiben REG_MULTI_SZ

geändert:

- Multi_SZ auch den Funktionen JHRegGetValue und JHRegListContents hinzugefügt
- JHRegGetWindowsVersion erweitert
- Ansicht Eingabefenster der Funktion JHRegCreateCodeWindow geändert

Version 2.57 - 01.08.2011

hinzugefügt:

- JHRegGetSystemTime() auslesen der Systemzeit, Local-Zeit und der Differenz


Allgemeines

Allgemeines / General
allgemeine Vereinbarung / General agreements

Alle Stringrückgaben erfolgen bis auf weiteres als ASCII-Zeichenfolge. Ich bitte dies bei Unicode Programmen zu beachten. Die Library ist Windows Vista tauglich (ab V 2.18).

Ab V2.53 ist eine Unicode-Version im Paket enthalten. Die Installation erfolgt nur auf Systemen, die mindestens Windows2000 als Betriebssystem verwenden.

Ab V2.54 ist die Library sowohl für Unicode als auch Threadsafe tauglich. Die Installationseinschränkung entfällt.

English

All string returns are ASCII. Please note it for Unicode programs. This library is god for Windows Vista (V2.18 or later).

First from V2.53 contains a unicode-version in package. The unicode-libraryfile will be installed only for systems with Windows2000 or greater.

V2.54 library is possible to use under threadsafe-mode.

Fehlermeldungen / ERROR-Messages

Alle eventuell auftretenden Fehler werden intern in einen String abgelegt, dessen Inhalt zu Beginn des Funktionsaufrufs geleert wird. Wird die aktuelle Funktion ohne Fehler beendet, so bleibt der String auch leer. Im Falle eines Fehlers wird der String mit einem adequaten Inhalt belegt. Nach dem einmaligen Aufruf der Fehlerfunktion wird der Inhalt geleert. Daher ist es zum einen nur sinnvoll direkt nach dem eigentlichen Funktionsaufruf eine Fehlerabfrage durchzuführen und zum anderen nicht möglich, die Fehlerabfrage mehrfach hintereinander zu machen. Alle Fehlertexte sind englisch.

Wenn man nur wissen möchte, ob ein Fehler aufgetreten ist, reicht es aus die ersten 5 Zeichen der Funktionsrückgabe von JHRegLastError() auszuwerten. Diese enthalten in dem Fall immer das Wort "ERROR".

Ebenfalls englisch sind alle Hinweise die in der Editorsyntaxvorschau angezeigt werden.

English

All faults appearing perhaps are put down internally into a string whose contents are emptied at the beginning of the function call. If the current function is ended without faults, then the string remains also emptily. In the case of a fault the string is covered with error contents. It´s only possible to make one error request directly after the function call. All fault texts are english.

If one only liked to know whether a fault has appeared, it hands out the first 5 signs of the function return of evaluate. This contained in the case always the word "ERROR".

All notes are also these shown on the editor syntax line be english.


Danksagungen

Danksagungen / Credits
Dank gilt an dieser Stelle / thanks for:

Falko Lünsmann, Beta-Tester, Helfer und Freund (Danke!)

Thomas Schulz (TS-Soft), der erste Kritiker und der, der mit Nachdruck die Funktion JHRegGetBinary und SetBinary verbessern geholfen hat. Nicht durch Code im weiteren Sinne, sondern durch angebrachte Kritik. (Danke!) Außerdem für sein beharrliches Nachhaken wegen der Fehlerrückgaben ;)

Manne aus dem PB Forum, der mit seinem Code für einige Funktionen die Grundlage geschaffen hat, ebenfalls danke, allerdings unbekannter Weise.

Danilo Krahn dessen Ursprungscode aus dem Forum mir für die Funktion des Shell Links Pate stand.

Miguel Calderon alias El_Choni für seinen Library-Maker Tailbite, ohne ihn wäre es unmöglich UserLib direkt aus PureBasic Quellcode zu erstellen.

Klaus Dresen alias ABBKlaus für die Überarbeitung und weitere Anpassung des Librarymakers TailBite und die Nutzbarmachung unter PB 4.xx.

Allen ungenannten, die durch ihre Kritik zu Verbesserungen oder Veränderung beigetragen haben oder dies noch tun wollen ;) Es dürfen gern Vorschläge oder Wünsche auf meiner Webseite im Gästebuch oder im Forum hinterlassen werden.

English

By her criticism these have contributed to improvements or change or want to do this still all unnamed. Notes, suggestions being able to and so on be left on my web page in the forum or in the visitor's book. I will assume gratefully or pick up for changes her.


Functions

Funktionen / Functions
Registryfunktionen / Registry functions

Prüffunktion / examining functions

JHRegIsKey
JHRegGetValueType

SubKey Erstellfunktionen / SubKey create functions

JHRegCreateKey

SubKey Löschfunktionen / SubKey delete functions

JHRegDeleteKey

Eintrag Erstellfunktionen / value create/change functions

JHRegSetString
JHRegSetStringExp
JHRegSetDW
JHRegSetMultiSZ
JHRegSetBinary

Eintrag Lesefunktionen / value read functions

JHRegGetValue
JHRegGetString
JHRegGetStringExp
JHRegGetMultiSZ
JHRegGetDWord
JHRegGetBinary
JHRegGetBinaryDump

Eintrag Löschfunktionen / value delete functions

JHRegDelValue

Auflistfunktionen / listing functions

JHRegListSubKey
JHRegListSubValue
JHRegListContents

Pfadfunktionen / path functions

JHRegGetDesktopPath
JHRegGetProgramsPath
JHRegGetStartmenuPath
JHRegGetStartMenuProgramsPath
JHRegGetSystemPath
JHRegGetPersonalPath
JHRegGetSystem32Path
JHRegGetWindowsPath
JHRegGetAplicationPath
JHRegGetAutostartPath
JHRegGetFontPath
JHRegGetFavoritePath
JHRegGetPBPath
JHRegCommonGetStartmenuPath
JHRegCommonGetStartmenuProgramsPath
JHRegGetUserDesktopPath
JHRegGetDeskPathAllUsers
JHRegSelfsetPath
JHRegGetAllUserDocumentsPath

Daten der gerade laufenden EXE / dates of running exe

JHRegGetExeName
JHRegGetExeFullPath
JHRegGetCompilerExe

Desktop Auflösung feststellen / Show desktop dpi

JHRegGetDesktopDPI

Die Gadgetfunktionen / Gadgetfunctions

JHRegSetGadgetFont
JHRegGetLenOfText
JHRegSetLenOfText

Shortcut erstellen (Shell-Link)

JHRegCreateShortcutFull
JHRegCreateShortcutSimply

sonstige Funktionen / Other functions

JHRegFileExist
JHRegGetLangID
JHRegGetPBVersionsNumber
JHRegGetPBVersionFull
JHRegRestartPBCompiler
JHRegGetAssociatProg
JHRegStartOnlyOneInstance
JHRegSetForegroundWindow
JHRegGetSystemTime

einen Farbverlauf erstellen

JHRegCreateGradient
JHRegShowPalette
JHRegCreateGradientImage

Ein Setupfenster erstellen

JHRegCreateCodeWindow
JHRegCreateSetupWindow
JHRegIntroduce

Versionsinformation

JHRegVersion
JHRegVersionDate
JHRegGetWindowsPlatform
JHRegGetWindowsVersion

Umwandlungen / Transformations

JHRegBinDez
JHRegHexDez
JHRegHex32Dez
JHRegBinHex
JHRegHexBin
JHRegGetLoWord
JHRegGetHiWord
JHRegCreateDataSection

Fehlermeldungsrückgabe / Error returns

JHRegLastError( )


ActiveExe

Funktionen rund um das laufende Programm
Einige Funktionen um das gerade laufende Programm:

- JHRegGetExeFullpath
- JHRegGetExeName
- JHRegGetCompilerExe

Some functions around the running program.


JHRegGetExeFullpath

Funktion JHRegGetExeFullpath
Syntax

result.s=JHRegGetExeFullPath()

Beschreibung / Description

Gibt bei Abfrage den vollständigen Pfad inclusive des FilePart zur Exe zurück aus der die Abfrage erfolgte, z.B. "C:\Programme\MeinProgramm\Meine.exe".

English

At query gives the full path back to the running aplication, e.g. :"c\programs\myprogram\my.exe".

Rückgabewerte / Returns

- den Pfad wenn erfolgreich,

- the path if successful

Fehlerrückgabe / Error return

keine / no


JHRegGetExeName

Funktion JHRegGetExeName
Syntax

result.s=JHRegGetExeName()

Beschreibung / Description

Gibt bei Abfrage den Nmen der Exe zurück aus der die Abfrage erfolgte, z.B. "Meine.exe".

English

At query gives back the name of running aplication, e.g. :"my.exe".

Rückgabewerte / Returns

- den Namen wenn erfolgreich,

- the name if successful

Fehlerrückgabe / Error return

keine / no


JHRegGetCompilerExe

Funktion JHRegGetCompilerExe
Syntax

result.s=JHRegGetCompilerExe()

Beschreibung / Description

Gibt bei Abfrage den Status des Pfads zurück aus der die Abfrage erfolgte.

English

At query gives back the state of path from the running aplication.

Rückgabewerte / Returns

- #False wenn die exe nicht im Compilerpfad läuft
- #True wenn die exe im Compilerpfad läuft

- #False if not compiler running
- #True if compiler running

Fehlerrückgabe / Error return

keine / no


Other

Verschiedene Funktionen
Einige Funktionen, für die es sich nicht als erforderlich erweist, ein eigenes Kapitel zu erstellen.

Some functions without a separate chapter.

JHRegCreateDataSection
JHRegFileExist
JHRegGetAssociatProg
JHRegGetDesktopDPI
JHRegGetLenOfText
JHRegGetLangID
JHRegGetWindowsPlatform
JHRegGetWindowsVersion
JHRegLastError()
JHRegGetPBVersion
JHRegGetPBVersionsNumber
JHRegGetPBVersionFull
JHRegRestartPBCompiler
JHRegSetForegroundWindow
JHRegSetGadgetFont
JHRegSetLenOfText
JHRegStartOnlyOneInstance
JHRegVersion
JHRegVersionDate
JHRegGetSystemTime


JHRegCreateDataSection

Funktion JHRegCreateDataSection
Syntax

result.l = JHRegCreateDataSection( datei.s )

Beschreibung / Description

Mit dieser Funktion können Sie eine Datei einlesen. Die Daten werden in die Zwischenablage gespeichert. Achtung, die Zwischenablage wird zuvor geleert!. Die Daten liegen sofern erfolgreich geladen in folgender Form in der Zwischenablage:

DataSection
Data.b [64 Byte]
...
Data.b [n Byte]
EndDataSection

Ist der Vorgang erfolgreich verlaufen, so wird von der Funktion #True zurückgegeben.
Die Daten können Sie direkt in den Programmcode einfügen und mittels der einschlägigen Funktionen weiterverarbeiten.

English

This function read the content of a file into a DataSection. This data you find in clipboard. Attension: clipboard cleared befor! If succesfull, you find this:

DataSection
Data.b [64 Byte]
...
Data.b [n Byte]
EndDataSection

You can use this directly in your code.
Rückgabewerte / Returns

- #True wenn erfolgreich
- #False bei Fehler

- #True if successful
- #False at fault


JHRegFileExist

Funktion JHRegFileExist
Syntax

result.l = JHRegFileExist(Path.s, File.s)

Beschreibung / Description

Die Funktion versucht anhand der Angaben festzustellen, ob ein File existiert.

English

This function contol if exist a file with the given name in the given path
Rückgabewerte / Returns

0 wenn das File nicht exisitiert
1 wenn das File existiert
-1 wenn der übergebene Pfadname leer war
-2 wenn der übergebene Filename leer war

English

0 if not exist a file with this name in this directory
1 if exist this file
-1 the given directory name was empty
-2 the given filename was empty


JHRegGetAssociatProg

Funktion JHRegGetAssociatProg
Syntax

result.s = JHRegGetAssociatProg(Extension.s)

Beschreibung / Description

Gibt den Pfad eines mit der angegebenen Extension verknüpften Programms zurück, wenn dieser im #HKEY_CLASSES_ROOT eingetragen ist.

English

Returns the the path to a associate program for given extension if find in #HKEY_CLASSES_ROOT.

Rückgabewerte / Returns

- den Pfad wenn gefunden
- einen Leerstring bei Fehler.

- the path if successful
- a empty string at fault


JHRegGetDesktopDPI

Funktion JHRegGetDesktopDPI
Syntax

result.l = JHRegGetDesktopDPI()

Beschreibung / Description

Diese Funktion gibt die eingestellte Auflösung des Desktops zurück. Standardmäßig ist 96 DPI eingestellt (kleine Schriftarten). Um jedoch in der Programmumgebung auch zu gewährleisten, das die Darstellung immer gleich ist, kann diese Funktion dazu benutzt werden, eine Schriftart zu wählen die immer im Verhältnis zu einer Ausgabe basierend auf der Standardeinstellung ein gleiches Aussehen der erstellten Fenster gewähleistet.

English

This function gives the oriented dissolving of the desktop back. Per default is oriented for 96 DPI (small scripts). Which is always the representation at once, this function can be used to this, a similar appearance of the erected windows makes on the standard attitude always basing this one in proportion to a version it possible a script to choose to also guarantee, however, in the program surroundings.

Rückgabewerte / Returns

- >Null wenn erfolgreich
- #False wenn die Ausgabe fehlgeschlagen ist

- greater than zero if successful
- #False at fault

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English

In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegGetLenOfText

Funktion JHRegGetLenOfText
Syntax

result.l = JHRegGetLenOfText(#Gadget)

Beschreibung / Description

Diese Funktion gibt die Länge der maximal möglichen Eingabe in ein Stringgadget zurück. Wurde vorher kein Wert gesetzt, so wird der Defaultwert zurückgegeben

English

This function give back the maximal length of input into a stringgadget. If you don´t give a length befor, the result is default length.

Rückgabewerte / Returns

- die Länge wenn erfolgreich
- #False bei Fehler

- the length if successful
- #False at fault

Fehlerrückgabe / Error return

keine

English

no error message


JHRegGetLangID

Funktion JHRegGetLangID
Syntax

result.l = JHRegGetLangID([typ.l])

Beschreibung / Description

Diese Funktion gibt die ID der System- oder Usersprache zurück. Wurde für die <typ> kein Wert gesetzt oder ist <typ> = 0, so wird die gewählte Sprache des aktiven Users zurückgegeben. Für <typ> = 1 die allgemeine Systemsprache.

English

This function give back the ID of user- or system language. If <typ> empty or 0, return the user language. If <typ> = 1 return the system language.

Rückgabewerte / Returns

- den Code der Spache (z.B. 7 für Deutsch, 9 für Englisch)

- the code of language (e.g. 7 for German, 9 for English)

Fehlerrückgabe / Error return

keine

English

no error message


JHRegGetWindowsPlatform

Funktion JHRegGetWindowsPlatform
Syntax

result.s = JHRegGetWindowsPlatform()

Beschreibung / Description

Diese Funktion gibt den Namen der Windowsplattform zurück, unabhängig davon ob
im Kompatibilitätsmodus gestartet wurde oder nicht (bei XP und Vista)

English

This function give back the name of windows version.

Rückgabewerte / Returns

- den Namen der Plattform wenn erfolgreich
- einen Leerstring wenn die Ausgabe fehlgeschlagen ist

- the name if successful
- a empty string at fault

Fehlerrückgabe / Error return

keine

English

no error message


JHRegGetWindowsVersion

Funktion JHRegGetWindowsVersion
Syntax

result.s = JHRegGetWindowsVersion()

Beschreibung / Description

Diese Funktion gibt den Namen des verwendeten Windows zurück, unabhängig davon ob
im Kompatibilitätsmodus gestartet wurde oder nicht (bei XP und Vista)

English

This function give back the name of windows version.

Rückgabewerte / Returns

- den Namen wenn erfolgreich
- einen Leerstring wenn die Ausgabe fehlgeschlagen ist

- the name if successful
- a empty string at fault

result = "Windows 95"
result = "WinNT 3.51"
result = "WinNT 4.0"
result = "Windows 98"
result = "Windows ME"
result = "Windows 2000"
result = "Windows XP"
result = "WindowsServer 2003"
result = "Windows XP x64"
result = "Windows Home Server"
result = "Windows Server 2003 R2"
result = "Windows Vista"
result = "Windows Server 2008"
result = "Windows7"
result = "Windows Server 2008 R2"

Fehlerrückgabe / Error return

keine

English

no error message


JHRegLastError

Funktion JHRegLastError
Syntax

result.s = JHRegLastError()

Beschreibung / Description

Diese Funktion gibt einen String zurück der Rückschlüsse auf eventuelle Fehlerursachen zuläßt, falls von einer aufgerufenen Funktion nicht das erwartete Ergebnis zurückgegeben worden ist. Eine Auswertung ist nur unmittelbar nach dem Aufruf einer Funktion sinnvoll, da bei jedem weiteren Aufruf der Fehler zuerst zurückgesetzt wird. Ebenfalls zurückgesetzt wird der Fehlertext nach dem Aufruf der Fehlerfunktion.

English

This function returns a string with informations of error for the last function call. Use it only directly after function call. After a call of this function the string is also empty.

Rückgabewerte / Returns

- einen (englischen) Fehlertext wenn aktuell ein Fehler ansteht
- einen Leerstring wenn kein aktueller Fehler ansteht

English

- unites fault text a fault lines up if current
- unites empty string if no current fault lines up


JHRegGetPBVersion

Funktion JHRegGetPBVersion
Diese Funktion wurde durch JHRegGetPBVersionsNumber() ersetzt. (V2.54)

This function will be replace trough JHRegGetPBVersionsNumber()


JHRegGetPBVersionsNumber

Funktion JHRegGetPBVersionsNumber
Syntax

result.s=JHRegGetPBVersionsNumber()

Beschreibung / Description

Gibt bei Abfrage die aktuell aktive Version von PureBasic zurück. z.B. "4.00".

English

At query gives the version back of the active PB version. e.g.:"4.00".

Rückgabewerte / Returns

- die Version,
- bei Fehler ein Leerstring

- the version if successful
- an empty string at fault

Bemerkung:

Diese Funktion entstand bei der Suche nach dem Grund, warum der Compiler bei der TailBite unter XP und PB4.10 nicht neu gestartet wird wenn die Library erzeugt wurde. Die Funktion basiert auf Code aus der TailBite selbst.


JHRegGetPBVersionFull

Funktion JHRegGetPBVersionFull
Syntax

result.s=JHRegGetPBVersionFull()

Beschreibung / Description

Gibt bei Abfrage die aktuell aktive Version von PureBasic mit vollem Namen zurück.

English

At query gives the version back of the active PB version as full length string.

Rückgabewerte / Returns

- die Version,
- bei Fehler ein Leerstring

- the version if successful
- an empty string at fault

Bemerkung:

Diese Funktion entstand bei der Suche nach dem Grund, warum der Compiler bei der TailBite unter XP und PB4.10 nicht neu gestartet wird wenn die Library erzeugt wurde. Die Funktion basiert auf Code aus der TailBite selbst.


JHRegRestartPBCompiler

Funktion JHRegRestartPBCompiler
Syntax

JHRegRestartPBCompiler ()

Beschreibung / Description

Startet den Compiler der aktiven Version neu wenn erfolgreich. (Nur bis V4.02 sicher in der Rückgabe.)

English

Restart the compiler of active version if successful.

Rückgabewerte / Returns

keine / no

Bemerkung:
Die Funktion basiert auf Code aus der TailBite. Sie entstand auf der Suche nach dem Fehler, daß der Compiler mit PB4.10 nach fertigstellen der Lib nicht von TailBite neu gestartet wird.


JHRegSetForegroundWindow

Funktion JHRegSetForegroundWindow
Syntax

result.s = JHRegSetForegroundWindow (InstanceName.s, [flag.l])

Beschreibung / Description

Versucht das Fenster mit dem angegebenen Namen zu finden und in den Vordergrund zu setzen. Dazu darf das Fenster weder minimiert noch versteckt sein.

Die Rückgaben sind immer Strings, da ein mischen nicht zulässig ist.

Werte für flag.l
kein - Rückgabe Windowshandle
0 - Rückgabe Windowshandle
1 - Rückgabe ProzessID
2 - gefundene Klasse des Prozesses
3 - Name des Prozesses (z.B. der gesuchte Fenstername)

English

Set the window with given name in foreground if possible. This window must be visible and not hide or minimized.

Rückgabewerte / Returns

Das Windows Handle des gefundenen Fensters wenn erfolgreich.

The Windows handle if successful.


JHRegSetGadgetFont

Funktion JHRegSetGadgetFont
Syntax

result.l = JHRegSetGadgetFont(Fontname.s, Fontgröße.l, FontID)

Beschreibung / Description

Diese Funktion stellt den Gadgetfont ein auf eine frei wählbare Schriftart und Größe, die sich auf eine Desktopauflösung von 96 DPI bezieht. Es wird somit immer ein gleiches Aussehen der Inhalte gewährleistet, unabhängig von den Systemeinstellungen für die Darstellung der Schriftarten. Beachten Sie jedoch, daß nicht alle Schriftarten in allen möglichen Größen auf jedem System vorhanden sind. Meist richtig liegen Sie mit Arial.

English

This function adjusts the gadgetfont to a script freely eligible for office and size which refers to a desktop dissolving of 96 DPI. A similar appearance of the contents is always guaranteed independently of the system attitudes for the representation of the scripts therefore. Make sure, however, that all scripts aren't available in all possible sizes on every system. You usually lie correctly with Arial.

Rückgabewerte / Returns

- Die Größe des gesetzten Font wenn erfolgreich
- #False bei Fehler

- Size of set font if successful
- #False at fault

FontID sollte eine Konstante sein, die man mit Enumeration festlegt.
FontID should be a constant which one fixes with Enumeration.

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English

In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.

Hinweis / Note

Sollten Sie die gleiche Funktion benötigen, jedoch auch den Style zusätzlich setzen wollen, so können Sie die UserLib JHPrinter_400 benutzen. Aus Kompatibilitätsgründen habe ich darauf verzichtet, hier eine Änderung vorzunehmen.

If you want to set the fontstyle, please use the library JHPrinter_400. I don´t like to change this here for compatibility. Thank you.


JHRegSetLenOfText

Funktion JHRegSetLenOfText
Syntax

result.l = JHRegSetLenOfText(#Gadget, Length.l)

Beschreibung / Description

Diese Funktion setzt die Länge der maximal möglichen Eingabe in ein String oder Editorgadget.

English

This function set the maximal length of input into a string or editor gadget.

Rückgabewerte / Returns

- #True wenn erfolgreich
- #False bei Fehler

- #True if successful
- #False at fault

Fehlerrückgabe / Error return

keine

English

no error message


JHRegStartOnlyOneInstance

Funktion JHRegStartOnlyOneInstance
Syntax

result.s = JHRegStartOnlyOneInstance (InstanceName.s, [flag.l])

Beschreibung / Description

Läßt nach Aufruf nur einen Start des Programms welches mit InstanceName benannt wurde zu. Optional kann mit flag = 1 eine Information ausgegeben werden. Gleichzeitig wird das Fenster mit dem Namen <InstanceName> versucht in den Vordergrund zu holen. Dazu darf diese Fenster nicht minimiert und nicht versteckt sein. Ohne Angabe des flag wird für den Fall, das eine Instanz gefunden wurde, die neu gestartete direkt innerhalb der Procedure beendet.

English

If set you can start only one instance of given InstanceName. As option you can set if you want to have a message. During this process will be lock to show the window with the name <InstanceName> in foreground. This window must be visible and not minimized or hide. If you not give the flag, the new process will be stopped inside the procedure if found one instance more.

Rückgabewerte / Returns

#False wenn keine Instanz gefunden werden konnte / not found instance
#True wenn eine Instanz gefunden wurde / found instance

Bemerkung:

Für diese Funktion stand teilweise ein Codeausschnitt aus der TailBite als Grundlage zur Verfügung.

Beispiel / Example
#InstanceName="Mein Programm"
; Use this for message inside of procedure
; If JHRegStartOnlyOneInstance(#InstanceName,1)
; End
; EndIf
; or this without message
If JHRegStartOnlyOneInstance(#InstanceName,0)
MessageRequester("Achtung","Es läuft bereits eine Instanz dieses Programms")
End
EndIf

OpenWindow(0,100,100,600,400,#InstanceName)

JHRegSetForegroundWindow(#InstanceName)
Repeat
Select WaitWindowEvent()
Case #PB_Event_CloseWindow
End
EndSelect
ForEver


JHRegVersion

Funktion JHRegVersion
Syntax

result.s = JHRegVersion (flag.b)

Beschreibung / Description

Gibt die Versionsnummer der Library zurück.

English

Returns the number of version from the library.

Rückgabewerte / Returns

- mit flag = 1 wird ein Requester geöffnet der die Daten anzeigt. Außerdem wird
der Rückgabestring mit der Versionsnummer belegt.
- mit flag <> 1 wird nur der Rückgabestring mit der Versionsnummer belegt.

- with flag = #True is open a requester with the version informations. The string will be return
the number of version.
- with flag <> #True give only the string with version number.


JHRegVersionDate

Funktion JHRegVersionDate
Syntax

result.s = JHRegVersionDate ()

Beschreibung / Description

Gibt das Datum der Version der Library zurück.

English

Returns the date of version from the library.

Rückgabewerte / Returns

- Das Datum der Version in Form eines deutschen Datumsstring

- the date of version in format of german date-string


JHRegGetSystemTime

Funktion JHRegGetSystemTime
Syntax

result.i = JHRegGetSystemTime(mode.i)

Beschreibung / Description

Gibt je nach Übergabeparameter die folgenden Daten zurück, vorausgesetzt das System ist korrekt eingestellt:

mode=0 Die Systemzeit (UTC)
mode=1 Die lokale Zeit [der Wert ist gleich der PB-Funktion Date()]
mode=2 die Zeitdifferenz zwischen lokaler und Systemzeit, z.B. bei MEZ +3600

Alle Rückgabewerte in Sekunden. Um die Ausgabe zu formatieren, kann der PB-Befehl FormateDate(maske.s, result.i) benutzt werden

English

Returns depending upon delivery parameter the following data, presupposed the system is correctly adjusted:

mode=0 the systemtime (UTC)
mode=1 the local time [the theme as PB-function Date()]
mode=2 the difference between system and local time, e.g. MEZ +3600

All returns in seconds. To formate you can use PB-function FormatDate(maske.s, result.i)

Rückgabewerte / Returns

- die serielle Datumszahl in Sekunden

- the serial date in seconds


Path

Funktionen rund um die Windowspfade
Einige Funktionen rund um die Ermittlung von Windows-Pfaden:

Some functions around windows paths:

JHRegGetDesktopPath
JHRegGetProgramsPath
JHRegGetStartmenuPath
JHRegGetStartMenuProgramsPath
JHRegGetSystemPath
JHRegGetPersonalPath
JHRegGetSystem32Path
JHRegGetWindowsPath
JHRegGetAplicationPath
JHRegGetAutostartPath
JHRegGetFontPath
JHRegGetFavoritePath
JHRegGetPBPath
JHRegCommonGetStartmenuPath
JHRegCommonGetStartmenuProgramsPath
JHRegGetUserDesktopPath
JHRegGetDeskPathAllUsers
JHRegSelfsetPath
JHRegGetAllUserDocumentsPath


JHRegGetAplicationPath

Funktion JHRegGetAplicationPath
Syntax

result.s=JHRegGetAplicationPath()

Beschreibung / Description

Gibt bei Abfrage den Pfad zu Anwendungsdaten zurück. Und zwar mit am Ende folgendem Backslash, z.B. "C:\Windows\Anwendungsdaten\".

English

At query gives the path back to the aplications folder. And but with a BACKSLASH following on the end. e.g.:"c\windows\anwendungsdaten\".

Rückgabewerte / Returns

- den gesuchten Pfad wenn erfolgreich,
- bei Fehler ein Leerstring

- the sought-after path if successful
- an empty string at fault

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English

In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegGetAutostartPath

Funktion JHRegGetAutostartPath
Syntax

result.s=JHRegGetAutostartPath()

Beschreibung / Description

Gibt bei Abfrage den Pfad zum Autostartordner im Startmenu zurück. Und zwar mit am Ende folgendem Backslash, z.B. "C:\Windows\Startmenu\Programme\Autostart\".

English

At query gives the path back to the autostart folder in the startmenu. And but with a BACKSLASH following on the end. e.g.:"c\windows\startmenu\progams\autostart\".

Rückgabewerte / Returns

- den gesuchten Pfad wenn erfolgreich,
- bei Fehler ein Leerstring

- the sought-after path if successful
- an empty string at fault

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English

In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegGetCommonStartmenuPath

Funktion JHRegGetCommonStartmenuPath()
 Zurück Startseite Vor
Syntax

result.s=JHRegCommonGetStartmenuPath()

Diese Funktion wird nicht von Windows9x unterstützt.

Beschreibung / Description

Gibt bei Abfrage den Pfad zum AllUsers Startmenüordner zurück. Und zwar mit am Ende folgendem Backslash, z.B. "C:\programdata\microsoft\windows\start menu\".

English

At query gives the path back to the startmenu folder. And but with a BACKSLASH following on the end. e.g.:"c\programdata\microsoft\windows\start menu\".

Rückgabewerte / Returns

- den gesuchten Pfad wenn erfolgreich,
- bei Fehler ein Leerstring

- the sought-after path if successful
- an empty string at fault

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English

In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegGetCommonStartmenuProgramsPath

Funktion JHRegGetCommonStartmenuProgramsPath()
 Zurück Startseite Vor
Syntax

result.s=JHRegGetCommonStartMenuProgramsPath()

Diese Funktion wird nicht von Windows9x unterstützt.

Beschreibung / Description

Gibt bei Abfrage den Pfad zum AllUsers Startmenü, Unterordner Programme zurück. Und zwar mit am Ende folgendem Backslash, z.B. "C:\programdata\microsoft\Windows\Startmenü\Programme\".

English

At query gives the path back to the startmenu programs folder. And but with a BACKSLASH following on the end. e.g.:"c\programdata\microsoft\windows\start menu\programs\".

Rückgabewerte / Returns

- den gesuchten Pfad wenn erfolgreich,
- bei Fehler ein Leerstring

- the sought-after path if successful
- an empty string at fault

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English

In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegGetDesktopPath

Funktion JHRegGetDesktopPath
Syntax

result.s=JHRegGetDesktopPath()

Beschreibung / Description

Gibt bei Abfrage den Pfad zum Desktop des aktiven Users zurück. Und zwar mit am Ende folgendem Backslash, z.B. "C:\Windows\Desktop\".

English

At query gives the path back to the desktop of active user. And but with a BACKSLASH following on the end. e.g.:"c\windows\desktop\".

Rückgabewerte / Returns

- den gesuchten Pfad wenn erfolgreich,
- bei Fehler ein Leerstring

- the sought-after path if successful
- an empty string at fault

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English

In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegGetDeskPathAllUsers

Funktion JHRegGetDeskPathAllUsers
Syntax

result.s=JHRegGetDesktopPath()

Beschreibung / Description

Gibt bei Abfrage den Pfad zum Desktop zurück. Und zwar mit am Ende folgendem Backslash, z.B. "C:\Windows\Desktop\".

English

At query gives the path back to the desktop. And but with a BACKSLASH following on the end. e.g.:"c\windows\desktop\".

Rückgabewerte / Returns

- den gesuchten Pfad wenn erfolgreich,
- bei Fehler ein Leerstring

- the sought-after path if successful
- an empty string at fault

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English

In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegGetFavoritePath

Funktion JHRegGetFavoritePath
Syntax

result.s=JHRegGetFavoritePath()

Beschreibung / Description

Gibt bei Abfrage den Pfad zu Favoriten zurück. Und zwar mit am Ende folgendem Backslash, z.B. "C:\Windows\Favoriten\".

English

At query gives the path back to the favorits folder. And but with a BACKSLASH following on the end. e.g.:"c\windows\favoriten\".

Rückgabewerte / Returns

- den gesuchten Pfad wenn erfolgreich,
- bei Fehler ein Leerstring

- the sought-after path if successful
- an empty string at fault

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English

In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegGetFontPath

Funktion JHRegGetFontPath
Syntax

result.s=JHRegGetFontPath()

Beschreibung / Description

Gibt bei Abfrage den Pfad zum Fontordner zurück. Und zwar mit am Ende folgendem Backslash, z.B. "C:\Windows\Fonts\".

English

At query gives the path back to the font folder. And but with a BACKSLASH following on the end. e.g.:"c\windows\fonts\".

Rückgabewerte / Returns

- den gesuchten Pfad wenn erfolgreich,
- bei Fehler ein Leerstring

- the sought-after path if successful
- an empty string at fault

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English

In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegGetPBPath

Funktion JHRegGetPBPath
Syntax

result.s=JHRegGetPBPath()

Beschreibung / Description

Gibt bei Abfrage den Pfad zur aktuell aktiven Version von PureBasic zurück. Und zwar mit am Ende folgendem Backslash, z.B. "C:\Programme\PB400\PureBasic\".

English

At query gives the path back to the folder of the active PB version. And but with a BACKSLASH following on the end. e.g.:"c\programme\pb400\purebasic\".

Rückgabewerte / Returns

- den gesuchten Pfad wenn erfolgreich,
- bei Fehler ein Leerstring

- the sought-after path if successful
- an empty string at fault


JHRegGetPersonalPath

Funktion JHRegGetPersonalPath
Syntax

result.s=JHRegGetPersonalPath()

Beschreibung / Description

Gibt bei Abfrage den Pfad zu "Eigene Dateien" zurück. Und zwar mit am Ende folgendem Backslash, z.B. "C:\Eigene Dateien"\".

English

At query gives the path back to the personal directory. And but with a BACKSLASH following on the end. e.g.:"c\my files\".

Rückgabewerte / Returns

- den gesuchten Pfad wenn erfolgreich,
- bei Fehler ein Leerstring

- the sought-after path if successful
- an empty string at fault

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English

In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegGetProgramsPath

Funktion JHRegGetProgramPath
Syntax

result.s=JHRegGetProgramsPath()

Beschreibung / Description

Gibt bei Abfrage den Pfad zum Standard Programmordner zurück. Und zwar mit am Ende folgendem Backslash, z.B. "C:\Programme\".

English

At query gives the path back to the standard program folder. And but with a BACKSLASH following on the end. e.g.:"c:\programs\".

Rückgabewerte / Returns

- den gesuchten Pfad wenn erfolgreich,
- bei Fehler ein Leerstring

- the sought-after path if successful
- an empty string at fault

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English

In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegGetStartmenuPath

Funktion JHRegGetStartmenuPath
Syntax

result.s=JHRegGetStartmenuPath()

Beschreibung / Description

Gibt bei Abfrage den Pfad zum Startmenüordner zurück. Und zwar mit am Ende folgendem Backslash, z.B. "C:\Windows\Startmenü\".

English

At query gives the path back to the startmenu folder. And but with a BACKSLASH following on the end. e.g.:"c\windows\startmenu\".

Rückgabewerte / Returns

- den gesuchten Pfad wenn erfolgreich,
- bei Fehler ein Leerstring

- the sought-after path if successful
- an empty string at fault

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English

In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegGetStartMenuProgramsPath

Funktion JHRegGetStartMenuProgramsPath
Syntax

result.s=JHRegGetStartMenuProgramsPath()

Beschreibung / Description

Gibt bei Abfrage den Pfad zum Startmenü, Unterordner Programme zurück. Und zwar mit am Ende folgendem Backslash, z.B. "C:\Windows\Startmenü\Programme\".

English

At query gives the path back to the startmenu programs folder. And but with a BACKSLASH following on the end. e.g.:"c\windows\startmenu\programs\".

Rückgabewerte / Returns

- den gesuchten Pfad wenn erfolgreich,
- bei Fehler ein Leerstring

- the sought-after path if successful
- an empty string at fault

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English

In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegGetSystemPath

Funktion JHRegGetSystemPath
Syntax

result.s=JHRegGetSystemPath()

Beschreibung / Description

Gibt bei Abfrage den Pfad zum Systemordner zurück. Und zwar mit am Ende folgendem Backslash, z.B. "C:\Windows\System\".

English

At query gives the path back to the system folder. And but with a BACKSLASH following on the end. e.g.:"c\windows\system\".

Rückgabewerte / Returns

- den gesuchten Pfad wenn erfolgreich,
- bei Fehler ein Leerstring

- the sought-after path if successful
- an empty string at fault

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English

In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegGetSystem32Path

Funktion JHRegGetSystem32Path
Syntax

result.s=JHRegGetSystem32Path()

Beschreibung / Description

Gibt bei Abfrage den Pfad zum System32 Ordner zurück. Und zwar mit am Ende folgendem Backslash, z.B. "C:\Windows\System32\".

English

At query gives the path back to the system32 folder. And but with a BACKSLASH following on the end. e.g.:"c\windows\system32\".

Rückgabewerte / Returns

- den gesuchten Pfad wenn erfolgreich,
- bei Fehler ein Leerstring

- the sought-after path if successful
- an empty string at fault

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English

In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegGetUserDesktopPath

Funktion JHRegGetUserDesktopPath()
 Zurück Startseite Vor
Syntax

result.s=JHRegGetUserDesktopPath()

Beschreibung / Description

Gibt bei Abfrage den Pfad zum Desktop zurück. Und zwar mit am Ende folgendem Backslash, z.B. "C:\Dokumente und Einstellungen\<Name>\Desktop\". Für Windows Vista wird die Rückgabe in etwa so aussehen: "c:\users\<name>\desktop\"

English

At query gives the path back to the desktop. And but with a BACKSLASH following on the end. e.g.:"c\users\<name>\desktop\".

Rückgabewerte / Returns

- den gesuchten Pfad wenn erfolgreich,
- bei Fehler ein Leerstring

- the sought-after path if successful
- an empty string at fault

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English

In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegGetWindowsPath

Funktion JHRegGetWindowsPath
Syntax

result.s=JHRegGetWindowsPath()

Beschreibung / Description

Gibt bei Abfrage den Pfad zu Windows zurück. Und zwar mit am Ende folgendem Backslash, z.B. "C:\Windows\".

English

At query gives the path back to the windows folder. And but with a BACKSLASH following on the end. e.g.:"c\windows\".

Rückgabewerte / Returns

- den gesuchten Pfad wenn erfolgreich,
- bei Fehler ein Leerstring

- the sought-after path if successful
- an empty string at fault

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English

In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegGetSelfsetPath

Funktion JHRegGetSelfsetPath()
 Zurück Startseite Vor
Syntax

result.s=JHRegGetSelfsetPath(csidl.l)

Beschreibung / Description

Gibt bei Abfrage den Pfad zurück, der mittels der Übergabe für csidl angegeben wurde sofern die Übergabe gültig war. Und zwar mit am Ende folgendem Backslash, z.B. "C:\Windows\" wenn für csidl = 36.

English

At query gives the path back to the folder with given number for csidl if successful. And but with a BACKSLASH following on the end. e.g.:"c\windows\" if you give csidl = 36.

Rückgabewerte / Returns

- den gesuchten Pfad wenn erfolgreich,
- bei Fehler ein Leerstring

- the sought-after path if successful
- an empty string at fault

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English

In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegGetAllUserDocumentsPath

Funktion JHRegGetAllUserDocumentsPath
Syntax

result.s=JHRegGetAllUserDocumentsPath()

Beschreibung / Description

Gibt bei Abfrage den Pfad zu "All User\Dokumente" zurück. Und zwar mit am Ende folgendem Backslash, z.B. "C:\Windows\All User\Dokumente\".

English

At query gives the path back to the personal directory. And but with a BACKSLASH following on the end. e.g.:"c\windows\all user\documents".

Rückgabewerte / Returns

- den gesuchten Pfad wenn erfolgreich,
- bei Fehler ein Leerstring

- the sought-after path if successful
- an empty string at fault

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English

In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


Registry

Registry-Funktionen
Funktionen rund um das Lesen, Schreiben und Entfernen von Eintragungen in der Registry.

A lot of functions around read, write and delete of registry entrys.

JHRegIsKey
JHRegGetValueType
JHRegCreateKey
JHRegDeleteKey
JHRegSetString
JHRegSetStringExp
JHRegSetDW
JHRegSetMultiSZ
JHRegSetBinary
JHRegGetValue
JHRegGetString
JHRegGetStringExp
JHRegGetMultiSZ
JHRegGetDWord
JHRegGetBinary
JHRegGetBinaryDump
JHRegDelValue
JHRegListSubKey
JHRegListSubValue
JHRegListContents


JHRegIsKey

Funktion JHRegIsKey
Syntax

result.l = JHRegIsKey(HKey.l, SKey.s)

Beschreibung / Description

Diese Funktion prüft ob ein angegebener SubKey im spezifizierten #HKEY vorhanden ist.

English

This function checks whether a given SubKey is available in the specified # HKEY.

Rückgabewerte / Returns

- #True wenn der Eintrag gefunden wurde
- #False bei Fehler

- #True if found entry successful
- #False at fault

HKey.l kann folgende Werte annehmen
HKey.l the following can assume results

#HKEY_CURRENT_USER
#HKEY_LOCAL_MACHINE
#HKEY_CLASSES_ROOT
#HKEY_CURRENT_CONFIG
#HKEY_USERS
#HKEY_DYN_DATA
#HKEY_PERFORMANCE_DATA

SKey.s ist der Name des Subschlüssels in folgender Form
SKey.s is the name of sub key in this form

(Beispiel/Example)

"JHTestkey\"

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English

In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegCreateKey

Funktion JHRegCreateKey
Syntax

result.l = JHRegCreateKey(HKey.l, SKey.s)

Beschreibung / Description

Diese Funktion erstellt einen SubKey in dem spezifizierten #HKEY.

English

This function create a SubKey in the specified #HKEY.

Rückgabewerte / Returns

- #True wenn der Eintrag erstellt wurde
- #False bei Fehler

- #True if successful
- #False at fault

HKey.l kann folgende Werte annehmen
HKey.l the following can assume results

#HKEY_CURRENT_USER
#HKEY_LOCAL_MACHINE
#HKEY_CLASSES_ROOT
#HKEY_CURRENT_CONFIG
#HKEY_USERS
#HKEY_DYN_DATA
#HKEY_PERFORMANCE_DATA

SKey.s ist der Name des Subschlüssels in folgender Form
SKey.s is the name of sub key in this form

(Beispiel/Example)

"JHTestkey\"

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English

In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegDeleteKey

Funktion JHRegDeleteKey
Syntax

result.l = JHRegDeleteKey(MKey.l, SKey.s [, Flag.b])

Beschreibung / Description

Die Funktion löscht einen SubKey aus dem spezifizierten #HKEY. Achtung, standardmäßig wird keine Prüfung vorgenommen, ob der Inhalt leer ist. Sie können dies jedoch mit einem Flag tun.

Seien Sie besonders vorsichtig bei der Anwendung von Funktionen zur Entfernung von Einträgen oder Schlüsseln.

English

The function deletes a SubKey from the specified # HKEY. Respect, default are carried out no examination about whether the contents are empty. You can, however, do this with a flag.

Are you particularly carefully of entries or keys at the application of functions to the distance.

Rückgabewerte / Returns

- #True wenn der Eintrag gelöscht wurde
- #False bei Fehler

- #True if successful
- #False at fault

HKey.l kann folgende Werte annehmen
HKey.l the following can assume results

#HKEY_CURRENT_USER
#HKEY_LOCAL_MACHINE
#HKEY_CLASSES_ROOT
#HKEY_CURRENT_CONFIG
#HKEY_USERS
#HKEY_DYN_DATA
#HKEY_PERFORMANCE_DATA

SKey.s ist der Name des Subschlüssels in folgender Form
SKey.s is the name of sub key in this form

(Beispiel/Example)

"JHTestkey\"

Flag kann folgende Werte annehmen oder entfallen
Flag can assume the following results or be dropped
0 keine Prüfung
1 Subkey wird vor dem Löschen geprüft
ob er noch Schlüssel oder SubKey enthält

0 no examination
1 Subkey is checked before deleting whether he still contains keys
or additional contained SubKey steward

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English

In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegDelValue

Funktion JHRegDelValue
Syntax

result.l = JHRegDelValue(HKey.l, SKey.s, Value.s)

Beschreibung / Description

Diese Funktion löscht den spezifizierten Schlüssel des angegebenen #HKEY und SubKey. Achtung, seien Sie vorsichtig beim Umgang mit Löschfunktionen in der Registry.

English

This function deletes the specified value of the given # HKEY and SubKey. You are careful respect in the registry at the working with deleting functions.

Rückgabewerte / Returns

- #True wenn der Eintrag entfernt wurde
- #False bei Fehler

- #True if successful
- #False at fault

HKey.l kann folgende Werte annehmen
HKey.l the following can assume results

#HKEY_CURRENT_USER
#HKEY_LOCAL_MACHINE
#HKEY_CLASSES_ROOT
#HKEY_CURRENT_CONFIG
#HKEY_USERS
#HKEY_DYN_DATA
#HKEY_PERFORMANCE_DATA

SKey.s ist der Name des Subschlüssels in folgender Form
SKey.s is the name of sub key in this form
(Beispiel/Example)

"JHTestkey\"

Value.s ist der Name des angesprochenen Schlüssels
Value.s is the name of key value

Fehlerrückgabe / Error returns

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English

In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegGetBinary

Funktion JHRegGetBinary
Syntax

result.l = JHRegGetBinary(HKey.l, SKey.s, Value.s)

Beschreibung / Description

Diese Funktion gibt die Adresse mit dem Inhalt des spezifizierten Schlüssels des angegebenen #HKEY und SubKey zurück, wenn es sich um ein Binary handelt.

Wenn Sie die Adresse nicht mehr benötigen, so sollten Sie den mit AllocateMemory() freigehaltenen Speicher mit FreeMemory(Adresse) wieder freigeben.

English

This function gives the address back with the contents of the specified key of the given # HKEY and SubKey, if it is a Binary.

If you don't need the address any more, then you should release the loft kept free with AllocateMemory () with FreeMemory (*Adresse) again.

Rückgabewerte / Returns

- die Adresse des Speicherbereiches, wo der Inhalt abgelegt wurde.
- #False bei Fehler

- where the contents were put down the address of the memory area.
- #False at fault

HKey.l kann folgende Werte annehmen
HKey.l the following can assume results

#HKEY_CURRENT_USER
#HKEY_LOCAL_MACHINE
#HKEY_CLASSES_ROOT
#HKEY_CURRENT_CONFIG
#HKEY_USERS
#HKEY_DYN_DATA
#HKEY_PERFORMANCE_DATA

SKey.s ist der Name des Subschlüssels in folgender Form
SKey.s is the name of sub key in this form

(Beispiel/Example)

"JHTestkey\"

Value.s ist der Name des angesprochenen Schlüssels
Value.s is the name of key value

Beispiel/Example

*MID=JHRegGetBinary(Hkey.l, SKey.s, Value.s)
Dim b(MemorySize(*MID))
If *MID
For I = 0 To MemorySize(*MID)-1
b(I)=PeekB(*MID + I) & $FF ; wegen signierter Variable!
Next
FreeMemory(*MID)
EndIf

In der mit der Speicherbereichsgröße dimensionierten (numerischen) Variable b() liegen byteweise die einzelnen ASCII-Werte. Achtung, AllocateMemory() richtet immer eine Größe von mindestens 12 Byte als Länge ein! Wenn Sie den reservierten Speicher nicht mehr benötigen, so geben Sie ihn wieder frei.

In the variable b() you can find the ASCII-Numbers of your reading key value. Attention, AllocateMemory() made a minimum size of 12 byte for the length of memory. If you are ready and you don´t use the allocated memory, pleas make it free.

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English

In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegGetBinaryDump

Funktion JHRegGetBinaryDump
Syntax

result.l = JHRegGetBinary(HKey.l, SKey.s, Value.s, FontID.l)

Beschreibung / Description

Diese Funktion gibt den Inhalt des spezifizierten Schlüssels des angegebenen #HKEY und SubKey in einem Fenster zurück, wenn es sich um ein Binary handelt.

Diese Funktion öffnet ein Fenster, in der ähnlich der Editierfunktion des Regeditors die Adresse, der Hexwert und das zugehörige Ascii-Zeichen angezeigt werden. Ein editieren ist für eine spätere Version vorgesehen.

English

This function gives the contents of the specified key of the given # HKEY and SubKey back in a window, if it is a Binary.

This function opens a window. The indication is carried out for the editing function the Registry editors there. Address, hex value and the accompanying Ascii sign are shown. A later version is intended for edit one.

Rückgabewerte / Returns

- #True wenn das Fenster angezeigt wurde
- #False bei Fehler

- #True if open window successful
- #False at fault

HKey.l kann folgende Werte annehmen
HKey.l the following can assume results

#HKEY_CURRENT_USER
#HKEY_LOCAL_MACHINE
#HKEY_CLASSES_ROOT
#HKEY_CURRENT_CONFIG
#HKEY_USERS
#HKEY_DYN_DATA
#HKEY_PERFORMANCE_DATA

SKey.s ist der Name des Subschlüssels in folgender Form
SKey.s is the name of sub key in this form

(Beispiel/Example)

"JHTestkey\"

Value.s ist der Name des angesprochenen Schlüssels
Value.s is the name of key value

FontID.l

übergeben Sie hier die ID des Fonts, den Sie verwenden möchten. Schriftart und Größe sind intern bereits festgelegt. Der Parameter dient nur der Kompatibilität, damit sich keine von Ihnen bereits verwendeten FontID überschneiden. Wenn Sie den Font nicht mehr benötigen, so sollten Sie ihn wieder freigeben.

English

FontID.l

submit the ID of the font which you would like to use here. Script and size are already fixed internally. The parameter serves only the compatibility so that no FontID used by you already conflict. If you don't need the Font any more, then you should release him again.

Fehlerrückgabe / Error returns

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English

In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegGetString

Funktion JHRegGetString
Syntax

result.s = JHRegGetString(HKey.l, SKey.s, Value.s)

Beschreibung / Description

Diese Funktion gibt den Inhalt des spezifizierten Schlüssels des angegebenen #HKEY und SubKey zurück, wenn es sich um einen String handelt. Alle Rückgaben erfolgen als String. Wird Value ein Leerstring übergeben, so erfolgt die Rückgabe des Eintrages für <Standard>

English

This function gives the contents of the specified key of the given # HKEY and SubKey back, if it is a string. All returns are carried out as a string. If given for value a empty string, you become return the content of <Standard>

Rückgabewerte / Returns

- den Inhalt des Schlüssels wenn erfolgreich
- einen Leerstring im Fehlerfalle

- the contents of the key if successful
- an empty string in the fault case

HKey.l kann folgende Werte annehmen
HKey.l the following can assume results

#HKEY_CURRENT_USER
#HKEY_LOCAL_MACHINE
#HKEY_CLASSES_ROOT
#HKEY_CURRENT_CONFIG
#HKEY_USERS
#HKEY_DYN_DATA
#HKEY_PERFORMANCE_DATA

SKey.s ist der Name des Subschlüssels in folgender Form
SKey.s is the name of sub key in this form

(Beispiel/Example)

"JHTestkey\"

Value.s ist der Name des angesprochenen Schlüssels
Value.s is the name of key value

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English

In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegGetStringExp

Funktion JHRegGetStringExp
Syntax

result.s = JHRegGetStringExp(HKey.l, SKey.s, Value.s)

Beschreibung / Description

Diese Funktion gibt den Inhalt des spezifizierten Schlüssels des angegebenen #HKEY und SubKey zurück, wenn es sich um einen Expanded_String handelt. Alle Rückgaben erfolgen als String.

English

This function gives the contents of the specified key of the given # HKEY and SubKey back, if it is a expanded string. All returns are carried out as a string.

Rückgabewerte / Returns

- den Inhalt des Schlüssels wenn erfolgreich
- einen Leerstring im Fehlerfalle

- the contents of the key if successful
- an empty string in the fault case

HKey.l kann folgende Werte annehmen
HKey.l the following can assume results

#HKEY_CURRENT_USER
#HKEY_LOCAL_MACHINE
#HKEY_CLASSES_ROOT
#HKEY_CURRENT_CONFIG
#HKEY_USERS
#HKEY_DYN_DATA
#HKEY_PERFORMANCE_DATA

SKey.s ist der Name des Subschlüssels in folgender Form
SKey.s is the name of sub key in this form

(Beispiel/Example)

"JHTestkey\"

Value.s ist der Name des angesprochenen Schlüssels
Value.s is the name of key value

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English

In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegGetMultiSZ

Funktion JHRegGetMultiSZ
Syntax

result.l = JHRegGetMultiSZ(HKey.l, SKey.s, Value.s)

Beschreibung / Description

Diese Funktion gibt den Inhalt des spezifizierten Schlüssels des angegebenen #HKEY und SubKey zurück, wenn es sich um einen Mulit_SZ Eintrag handelt.

English

This function gives the contents of the specified key of the given # HKEY and SubKey back, if it is a Multi_SZ.

Rückgabewerte / Returns

- den Inhalt wenn erfolgreich, die einzelnen Strings sind getrennt durch LfCr
- einen Leerstring bei Fehler

- the contents as string separate with LfCr if successful
- Zero at fault or contents is zero

HKey.l kann folgende Werte annehmen
HKey.l the following can assume results

#HKEY_CURRENT_USER
#HKEY_LOCAL_MACHINE
#HKEY_CLASSES_ROOT
#HKEY_CURRENT_CONFIG
#HKEY_USERS
#HKEY_DYN_DATA
#HKEY_PERFORMANCE_DATA

SKey.s ist der Name des Subschlüssels in folgender Form
SKey.s is the name of sub key in this form

(Beispiel/Example)

"JHTestkey\"

Value.s ist der Name des angesprochenen Schlüssels
Value.s is the name of key value

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English

In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegGetDWord

Funktion JHRegGetDWord
Syntax

result.l = JHRegGetDWord(MKey.l, SKey.s, Value.s)

Beschreibung / Description

Diese Funktion gibt den Inhalt des spezifizierten Schlüssels des angegebenen #HKEY und SubKey zurück, wenn es sich um ein DWord handelt.

English

This function gives the contents of the specified key of the given # HKEY and SubKey back, if it is a DWord.

Rückgabewerte / Returns

- den numerischen Inhalt wenn erfolgreich
- 0 bei Fehler oder Inhalt 0

- the numeric contents if successful
- Zero at fault or contents is zero

HKey.l kann folgende Werte annehmen
HKey.l the following can assume results

#HKEY_CURRENT_USER
#HKEY_LOCAL_MACHINE
#HKEY_CLASSES_ROOT
#HKEY_CURRENT_CONFIG
#HKEY_USERS
#HKEY_DYN_DATA
#HKEY_PERFORMANCE_DATA

SKey.s ist der Name des Subschlüssels in folgender Form
SKey.s is the name of sub key in this form

(Beispiel/Example)

"JHTestkey\"

Value.s ist der Name des angesprochenen Schlüssels
Value.s is the name of key value

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English

In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegGetValue

Funktion JHRegGetValue
Syntax

result.s = JHRegGetValue(HKey.l, SKey.s, Value.s)

Beschreibung / Description

Diese Funktion gibt den Inhalt des spezifizierten Schlüssels des angegebenen #HKEY und SubKey zurück, unabhängig von der Art des Selben. Alle Rückgaben erfolgen als String. Wird Value ein Leerstring übergeben, so erfolgt die Rückgabe des Eintrages für <Standard>

English

This function gives the contents of the specified key of the given # HKEY and SubKey back, independently of the way of the same. All returns are carried out as a string. If given for value a empty string, you become return the content of <Standard>

Rückgabewerte / Returns

- Inhalt des Schlüssels wenn erfolgreich.
- bei Binarys als Hex-String jeweils getrennt durch ein Leerzeichen zwischen den Byte.
- bei Fehler einen Leerstring.

- the contents of the key if successful
- separated the byte by a blank at Binarys as a conjure up string respectively between
- an empty string in the fault case

HKey.l kann folgende Werte annehmen
HKey.l the following can assume results

#HKEY_CURRENT_USER
#HKEY_LOCAL_MACHINE
#HKEY_CLASSES_ROOT
#HKEY_CURRENT_CONFIG
#HKEY_USERS
#HKEY_DYN_DATA
#HKEY_PERFORMANCE_DATA

SKey.s ist der Name des Subschlüssels in folgender Form
SKey.s is the name of sub key in this form

(Beispiel/Example)

"JHTestkey\"

Value.s ist der Name des angesprochenen Schlüssels
Value.s is the name of key value

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English

In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegGetValueType

Funktion JHRegGetValueType
Syntax

result.s = JHRegGetValueType(HKey.l, SKey.s, Value.s)

Beschreibung / Description

Diese Funktion gibt den Typ des spezifizierten Wertes im angegebenen #HKEY und SubKey zurück. Alle Rückgaben erfolgen als String.

English

This function gives the type of the specified keyword of the given # HKEY and SubKey back. All returns are carried out as a string.

Rückgabewerte / Returns

- den Type des Value in Form eines String
- bei Fehler einen Leerstring.

- the type of value as a string if successful
- an empty string in the fault case

HKey.l kann folgende Werte annehmen
HKey.l the following can assume results

#HKEY_CURRENT_USER
#HKEY_LOCAL_MACHINE
#HKEY_CLASSES_ROOT
#HKEY_CURRENT_CONFIG
#HKEY_USERS
#HKEY_DYN_DATA
#HKEY_PERFORMANCE_DATA

SKey.s ist der Name des Subschlüssels in folgender Form
SKey.s is the name of sub key in this form

(Beispiel/Example)

"JHTestkey\"

Value.s ist der Name des angesprochenen Schlüssels
Value.s is the name of key value

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English

In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegListContents

Funktion JHRegListContents
Syntax

result.l = JHRegListContents(HKey.l, SKey.s, FontID.l)

Beschreibung / Description

Diese Funktion erzeugt eine Liste der im angegebenen Subkey enthaltenen Schlüssel und Werte in einem eigenen Fenster. Sie können die Einträge sortiert anzeigen nach:

- Index-Nummer (bezogen auf Eintragszeitpunkt)
- Schlüssel Namen
- Schlüssel Inhalt
- Schlüssel Typ

Außerdem haben Sie die Möglichkeit, ein Filter zu setzen, so daß nur Werte oder nur Schlüssel angezeigt werden.

English

This function produces a list of the keys and value contained in the given Subkey in an own window. You can report the entries sortedly after:

- Index number (obtained) till entry time
- Key names
- Key contents
- Key type

You also have tree options for show the list: only subkey or only value or value and subkey

Rückgaben / Returns (nach dem Schließen des Fensters / after close window)

- #True wenn das Fenter angezeigt wurde
- #False bei Fehler

- #True if open window successful
- #False at fault

HKey.l kann folgende Werte annehmen
HKey.l the following can assume results

#HKEY_CURRENT_USER
#HKEY_LOCAL_MACHINE
#HKEY_CLASSES_ROOT
#HKEY_CURRENT_CONFIG
#HKEY_USERS
#HKEY_DYN_DATA
#HKEY_PERFORMANCE_DATA

SKey.s ist der Name des Subschlüssels in folgender Form
SKey.s is the name of sub key in this form

(Beispiel/Example)

"JHTestkey\"

FontID.l

übergeben Sie hier die ID des Fonts, den Sie verwenden möchten. Schriftart und Größe sind intern bereits festgelegt. Der Parameter dient nur der Kompatibilität, damit sich keine von Ihnen bereits verwendeten FontID überschneiden. Wählen Sie den Font wieder ab, wenn Sie ihn nicht mehr benötigen.

English

FontID.l

submit the ID of the font which you would like to use here. Script and size are already fixed internally. The parameter serves only the compatibility so that no FontID used by you already conflict. If you don't need the Font any more, then you should release him again.

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English

In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegListSubKey

Funktion JHRegListSubKey
Syntax

result.s = JHRegListSubKey(HKey.l, SKey.s, Index.l)

Beschreibung / Description

Diese Funktion gibt den Namen des Subkey innerhalb des angesprochenen Subkey zurück, welcher mit der Indexierung angesprochen wird. Der Index des Subkeys ergibt sich aus der Reihenfolge der Eintragung in die Registry. Eine sortierbare Liste aller Eintragungen innerhalb eines Key können Sie mit der Funktion JHRegListContents erstellen.

English

Which one is asked with the indexation gives the names of the Subkey this function back. The index of the Subkeys arises from the order of the entry into the registry. You can key for entries for a sortable list for everyone make with the function JHRegListContents () within one.

Rückgaben / Returns

- der Name des mit dem Index angesprochenen Schlüssels bei Erfolg
- bei Fehler ein Leerstring

- the name of the key at success mentioned with the index
- an empty string at fault

HKey.l kann folgende Werte annehmen
HKey.l the following can assume results

#HKEY_CURRENT_USER
#HKEY_LOCAL_MACHINE
#HKEY_CLASSES_ROOT
#HKEY_CURRENT_CONFIG
#HKEY_USERS
#HKEY_DYN_DATA
#HKEY_PERFORMANCE_DATA

SKey.s ist der Name des Subschlüssels in folgender Form
SKey.s is the name of sub key in this form

(Beispiel/Example)

"JHTestkey\"

Index.l ist die Nummer des Eintrages bezogen auf die Erstellzeit
Index.l is obtained the number of the entry till the making time

Gültiger Bereich von 0 bis 2147483647, wobei bei fehlerhaften Index eine Meldung erfolgt.
Valid area of 0 to 2147483647, in which a report is carried out at faulty index.

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English

In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegListSubValue

Funktion JHRegListSubValue
Syntax

result.s = JHRegListSubValue(HKey.l, SKey.s, Index.l)

Beschreibung / Description

Diese Funktion gibt den Namen des Value zurück, welcher mit der Indexierung angesprochen wird. Der Index des Value ergibt sich aus der Reihenfolge der Eintragung in die Registry. Eine sortierbare Liste aller Eintragungen innerhalb eines Key können Sie mit der Funktion JHRegListContents erstellen.

English

Which one is asked with the indexation gives the names of the value this function back. The index of the values arises from the order of the entry into the registry. You can key for entries for a sortable list for everyone make with the function JHRegListContents () within one.

Rückgaben / Returns

- der Name des mit dem Index angesprochenen Value bei Erfolg
- bei Fehler ein Leerstring

- the name of the value at success mentioned with the index
- an empty string at fault

HKey.l kann folgende Werte annehmen
HKey.l the following can assume results

#HKEY_CURRENT_USER
#HKEY_LOCAL_MACHINE
#HKEY_CLASSES_ROOT
#HKEY_CURRENT_CONFIG
#HKEY_USERS
#HKEY_DYN_DATA
#HKEY_PERFORMANCE_DATA

SKey.s ist der Name des Subschlüssels in folgender Form
SKey.s is the name of sub key in this form

(Beispiel/Example)

"JHTestkey\"

Index.l ist die Nummer des Eintrages bezogen auf die Erstellzeit
Index.l is obtained the number of the entry till the making time

Gültiger Bereich von 0 bis 2147483647, wobei bei fehlerhaften Index eine Meldung erfolgt.
Valid area of 0 to 2147483647, in which a report is carried out at faulty index.

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English

In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegSetBinary

Funktion JHRegSetBinary
Syntax

result.l = JHRegSetBinary(HKey.l, SKey.s, Value.s, Wert.s, [Flag.b]l)

Beschreibung / Description

Diese Funktion schreibt oder ändert einen binären Wert im spezifizierten Schlüssel des angegebenen #HKEY und SubKey. Flag ist optional und kann entfallen.

ohne optionales Flag oder Flag = 0

Reservieren Sie einen Speicherbereich und tragen Sie die Daten mit PokeB() dort ein. Geben Sie dann die Adresse davon an oder übergeben Sie eine anderweitig bereits vergebene MemoryID an die Procedure. Die Übergabe an die Procedure muß mit Str(MemoryID) erfolgen, da ich keine zusätzliche Variable verwenden wollte. Die Übergabe erfolgt mit dem Parameter Wert.s

mit Flag = 1

Tragen Sie in die Variable <Value.s> einen Hexadezimalstring wie unten angegeben ein, den Rest erledigt die Funktion

English

This function writes or changes a binary value of keys the given # HKEY and SubKey specified in this. Flag is optional and can be dropped.

without flag or flag = 0

Reserve a memory area and type the data in with PokeB() there. Then give the address of this or submit a MemoryID already allocated elsewhere to the procedure. The handing over to the procedure must be carried out with Str(MemoryID) since I didn't want to use any additional variable. The handing over is carried out with the parameter Wert.s

with flag = 1

You write one down, on the variable <Value.s> for hexadecimal string like indicated below for one takes care of the remains the function.

Rückgabewerte ohne optionales Flag oder Flag = 0 oder Flag = 1

- #True wenn der Eintrag erfolgt ist
- #False bei Fehler

- #True if write / change successful
- #False at fault

HKey.l kann folgende Werte annehmen
HKey.l the following can assume results

#HKEY_CURRENT_USER
#HKEY_LOCAL_MACHINE
#HKEY_CLASSES_ROOT
#HKEY_CURRENT_CONFIG
#HKEY_USERS
#HKEY_DYN_DATA
#HKEY_PERFORMANCE_DATA

SKey.s ist der Name des Subschlüssels in folgender Form
SKey.s is the name of sub key in this form

(Beispiel/Example)

"JSTestkey\"

Value.s ist der Name des angesprochenen Schlüssels
Value.s is the name of key value

Wert.s ist der einzutragende Inhalt,
Wert.s is the contents to be typed in

Byteweise getrennt durch je ein Leerzeichen wenn Flag = #True. Es erfolgt eine Prüfung auf gültige Zeichefolge.

Flag = # True byte way separated by each one blank if. An examination is carried out on valid string.

Beispiel mit / Example with Flag = #True

Wert.s = "AA 01 1F FF" oder / or Wert.s = "a1 10 f1 da"
Debug JHRegSetBinary(#HKey, SKey, Value, Wert.s, #True)

Die mit Str(*MID) übergebene gültige Adresse eines zuvor mit AllocateMemory() reservierten Speicherbereiches wenn Flag = #False oder nicht angegeben.

The valid address of a memory area reserved before with AllocateMemory() submitted with Str(*MID) flag = # False or not indicated if.

Beispiel mit / Example with Flag = #False / oder nicht angegeben / or dropped
Length.l = 32
Restore BinaryTest ; Data
*MID = AllocateMemory(Length)
For a=0 To 31
Read b
PokeB(*MID+a,b)
Next a
If *MID
Debug JHRegSetBinary(#HKey, SKey, Value, Str(*MID), #False)
EndIf

; Binary Test
DataSection
BinaryTest:
Data.l 77, 65, 68, 69, 0, 73, 78, 0
Data.l 83, 65, 88, 79, 78, 89, 0, 0
Data.l 67, 72, 69, 77, 78, 73, 84, 90
Data.l 0, 0, 0, 0, 0, 0, 0, 0
EndDataSection

Flag.b kann folgende Werte annehmen oder weggelassen werden
Flag can assume the following results or be dropped

#True
#False

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English

In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegSetString

Funktion JHRegSetString
Syntax

result.l = JHRegSetString(HKey.l, SKey.s, Value.s, Wert.s)

Beschreibung / Description

Diese Funktion schreibt oder ändert einen String im spezifizierten Schlüssel des angegebenen #HKEY und SubKey. Wird Value ein Leerstring übergeben, so erfolgt der Eintrag für das Value <Standard>

English

This function writes or changes a string in the specified key of the given # HKEY and SubKey. If value a empty string, so you write the value of <Standard>.

Rückgabewerte / Returns

- #True wenn der Eintrag erfolgt ist
- #False bei Fehler

- #True if write / change successful
- #False at fault

HKey.l kann folgende Werte annehmen
HKey.l the following can assume results

#HKEY_CURRENT_USER
#HKEY_LOCAL_MACHINE
#HKEY_CLASSES_ROOT
#HKEY_CURRENT_CONFIG
#HKEY_USERS
#HKEY_DYN_DATA
#HKEY_PERFORMANCE_DATA

SKey.s ist der Name des Subschlüssels in folgender Form
SKey.s is the name of sub key in this form

(Beispiel/Example)

"JSTestkey\"

Value.s ist der Name des angesprochenen Schlüssels
Value.s is the name of key value

Wert.s ist der einzutragende Inhalt
Wert.s is the contents to be typed in

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English

In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegSetStringExp

Funktion JHRegSetStringExp
Syntax

result.l = JHRegSetStringExp(HKey.l, SKey.s, Value.s, Wert.s)

Beschreibung / Description

Diese Funktion schreibt oder ändert einen expanded String im spezifizierten Schlüssel des angegebenen #HKEY und SubKey.

English

This function writes or changes a expanded string in the specified key of the given # HKEY and SubKey.

Rückgabewerte / Returns

- #True wenn der Eintrag erfolgt ist
- #False bei Fehler

- #True if write / change successful
- #False at fault

HKey.l kann folgende Werte annehmen
HKey.l the following can assume results

#HKEY_CURRENT_USER
#HKEY_LOCAL_MACHINE
#HKEY_CLASSES_ROOT
#HKEY_CURRENT_CONFIG
#HKEY_USERS
#HKEY_DYN_DATA
#HKEY_PERFORMANCE_DATA

SKey.s ist der Name des Subschlüssels in folgender Form
SKey.s is the name of sub key in this form

(Beispiel/Example)

"JSTestkey\"

Value.s ist der Name des angesprochenen Schlüssels
Value.s is the name of key value

Wert.s ist der einzutragende Inhalt
Wert.s is the contents to be typed in

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English

In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegSetMultiSZ

Funktion JHRegSetMultiSZ
Syntax

result.l = JHRegSetMultiSZ(HKey.l, SKey.s, Value.s, Wert.s)

Beschreibung / Description

Diese Funktion schreibt oder ändert einen Multi_SZ String im spezifizierten Schlüssel des angegebenen #HKEY und SubKey. Als Trennzeichen muß mindestens ein LfCr im Gesamtstring enthalten sein, der String darf jedoch nicht auf LfCr enden oder zweimal LfCr hintereinander enthalten.

English

This function writes or changes a Multi_SZ string in the specified key of the given # HKEY and SubKey. Please note, you need one of break with LfCr, but it´s impossible to use LfCr at the end of string or double write of it.

Rückgabewerte / Returns

- #True wenn der Eintrag erfolgt ist
- #False bei Fehler

- #True if write / change successful
- #False at fault

HKey.l kann folgende Werte annehmen
HKey.l the following can assume results

#HKEY_CURRENT_USER
#HKEY_LOCAL_MACHINE
#HKEY_CLASSES_ROOT
#HKEY_CURRENT_CONFIG
#HKEY_USERS
#HKEY_DYN_DATA
#HKEY_PERFORMANCE_DATA

SKey.s ist der Name des Subschlüssels in folgender Form
SKey.s is the name of sub key in this form

(Beispiel/Example)

"JSTestkey\"

Value.s ist der Name des angesprochenen Schlüssels
Value.s is the name of key value

Wert.s ist der einzutragende Inhalt
Wert.s is the contents to be typed in

zum Beispiel / e.g.: Wert="test 1"+Chr(13)+Chr(10)+"test 2"+Chr(13)+Chr(10)+"test 3"

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English

In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegSetDW

Funktion JHRegSetDW
Syntax

result.l = JHRegSetDW(HKey.l, SKey.s, Value.s, Wert.l)

Beschreibung / Description

Diese Funktion schreibt oder ändert ein DWord im spezifizierten Schlüssel des angegebenen #HKEY und SubKey.

English

This function writes or changes a DWord in the specified key of the given # HKEY and SubKey.

Rückgabewerte / Returns

- #True wenn der Eintrag erfolgt ist
- #False bei Fehler

- #True if write / change successful
- #False at fault

HKey.l kann folgende Werte annehmen
HKey.l the following can assume results

#HKEY_CURRENT_USER
#HKEY_LOCAL_MACHINE
#HKEY_CLASSES_ROOT
#HKEY_CURRENT_CONFIG
#HKEY_USERS
#HKEY_DYN_DATA
#HKEY_PERFORMANCE_DATA

SKey.s ist der Name des Subschlüssels in folgender Form
SKey.s is the name of sub key in this form
(Beispiel/Example)

"JHTestkey\"

Value.s ist der Name des angesprochenen Schlüssels
Value.s is the name of key value

Wert.l ist der einzutragende Inhalt
Wert.s is the contents to be typed in

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English

In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


Setup

Setup-Funktionen
Ein paar Funktionen, die man benötigt um ein Setupprogramm zu gestalten.

Some functions to create a setup program.

JHRegCreateCodeWindow
JHRegCreateGradient
JHRegCreateSetupWindow
JHRegIntroduce
JHRegShowPalette
JHRegCreateGradientImage


JHRegCreateCodeWindow

Funktion JHRegCreateCodeWindow()
 Zurück Startseite Vor
Syntax

result.s = JHRegCreateCodeWindow(InstanceName.s, [WinName.s, [ParentID.l]])

Beschreibung / Description

Es wird ein Fenster geöffnet in dem Sie einen Code eingeben können. Zwei Optionen ermöglichen es zum einen den Namen des Fensters anzugeben und die Zuordnung zu einem übergeordneten Fensters vorzunehmen. Sie können den Code aus der Zwischenablage in das erste Stringfeld einfügen. Beachten Sie dabei jedoch, das der Code ohne Sonderzeichen in die Zwischenablage eingefügt wird. Leerzeichen innerhalb des einzufügenden Strings werden entfernt.

It´s open a window to input a code. As first option you can give the name of window headline and as second option you can give a ParentID from a window.

Rückgabewerte / Returns

bei Fehler oder Abbruch immer ein Leerstring zurückgegeben
im Erfolgsfalle wird die Eingabe zurückgegeben

A empty string if false or error or break
If succesfull the input into string gadgets

Beispiel / Example

Hierzu bitte das dem Paket begefügte Programm setup_window.pb öffnen, da die Erläuterung innerhalb der Hilfe zu weit führen würden. Ich bitte um Verständis. Zu gegebener Zeit wird noch ein Beispiel zur richtigen Anwendung beigefügt.


JHRegCreateGradient

Funktion JHRegCreateGradient
Syntax

result.l=JHRegCreateGradient(color1.l, color2.l, number.l, direction.l, window.l, Image.l)

Beschreibung / Description

Erstellt einen Farbverlauf im durch die PB Nummer angegebenen Fenster. Image ist eine PB-Nummer eines Bildes. Die Richtung des Verlaufs wird mit direction angegeben, wobei die Angabe #Null immer einen waagrechten Verlauf erzeugt und alle anderen einen horizontalen. Farbe1 und Farbe2 geben die Start und die Endfarbe an. Deren Werte können Sie mit der Funktion RGB(r,g,b) ermitteln und übergeben. Sie können die Funktion auch bei laufendem Programm aufrufen. Es wird kein CallBack verwendet. Im Beispiel ist dies dargestellt.

English

Create a gradient in the specified window. Number set the lines, window is the PB-Number of specified window and Image is a PB-Image number. Direction set if it´s horizontal or vertical. If direction #Null it´s allready vertical, else horizontal.

Color1 is the startcolor and color2 is the endcolor. You can find this with the function RGB().

Rückgabewerte / Returns

- #True wenn erfolgreich,
- #False bei Fehler

- #True if successful
- #False at fault

Beispiel / Example

#Window = 0
#Image = 0
#BGadget = 0
#TGadget = 1

OpenWindow(#Window, 0, 0,200,150,"Testfenster Farbverlauf",#PB_Window_Invisible|#PB_Window_SystemMenu|#PB_Window_ScreenCentered)
JHRegCreateGradient(RGB( 0, 0, 0),RGB(255, 0, 0),255, 0, #Window, #Image)
CreateGadgetList(WindowID(#Window))
ButtonGadget(#BGadget, 10, 10,780, 24,"Beenden")
HideWindow(#Window,0)
a=0
Repeat
Select WindowEvent()
Case #PB_Event_CloseWindow
Quit = 1
Case #PB_Event_Gadget
Select EventGadget()
Case #BGadget
CloseWindow(#Window)
Quit=1
EndSelect
Default
Delay(1)
a+1
EndSelect
; Farbe ändern, Richtung ändern
If a=200
JHRegCreateGradient(RGB( 0, 0, 0),RGB( 0,255, 0),255, 0, #Window, #Image)
ElseIf a=400
JHRegCreateGradient(RGB( 0, 0, 0),RGB( 0, 0,255),255, 0, #Window, #Image)
ElseIf a=600
JHRegCreateGradient(RGB(255, 0, 0),RGB( 0, 0,255),255, 0, #Window, #Image)
ElseIf a=800
JHRegCreateGradient(RGB( 0, 0,255),RGB( 0,255, 0),255, 1, #Window, #Image)
a=0
EndIf
Until Quit = 1

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English

In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegCreateSetupWindow

Funktion Funktion JHRegCreateSetupWindow()
 Zurück Startseite Vor
Syntax

result.l = JHRegCreateSetupWindow(PGMName.s, newnum.l, newdate.s, CopyRight.s, WebSite.s, Lizenz.s, InstNum.l, InstDate.s, ColorO.l, ColorU.l, DeleteOff.b, ShortCut.l, Register.l, Sticky.l, SetupSize.l)

Beschreibung / Description

Es wird ein Fullscreenfenster geöffnet mit einem Farbverlauf dessen Farbe mit der Variable GradientColor (Wert 0 - 255) eingestellt werden kann. In diesem Fenster öffnet sich das eigentliche Setup-Abfragefenster.

Übergeben Sie:
- den Namen des Programms
- die Nummer der Version die installiert werden soll, maximal 9 stellig
- das Datum der Version die installiert werden soll als deutschen Datumsstring
- ein Autor-Copyright
- eine Autorenwebseite
- einen Lizenztext
- ggf. die Nummer einer bereits installierten Version (ebenfalls max. 9 stellig)
- ggf. das Datum einer bereits installierten Version (deutscher Datumsstring)
- die Anfangsfarbe des Hauptfenstergradienten (Auswahl aus einer Palette mit 256 Farben)
- die Endfarbe des Hauptfenstergradienten (Auswahl aus einer Palette mit 256 Farben)
- das Optionsbit zum sperren der Deinstallieren Option (#False = ein)
- das Optionsbit zum freischalten der Option Desktop Shortcut (#True = ein)
- das Optionsbit zum registrieren des Dateityps von Datendateien des Programms
- das Optionsbit ob das Fenster "Sticky" sein soll
- ob das Fenster FullSize (-1) oder ab 640 Pixel breit sein soll (Höhe 4:3)

Optional kann im Hauptprogramm ein Bild geladen werden mit der Größe 110*300 Pixel welches später im Setupfenster angezeigt wird. Die PB_Ident muß für dieses Image 1 sein.

Rückgabewerte / Returns

bei Fehler oder Abbruch immer 0
im Erfolgsfalle je nach Auswahl der Optionen

1 bei installieren
2 bei UpDate
3 bei reparieren
4 bei aktualisieren
5 bei deinstallieren (wenn Optionsbit = 0 )
6 bei installieren mit angewählter Option Desktop Shortcut
7 bei installieren mit angewählter Option Dateityp registrieren
8 bei installieren mit beiden Optionen - Shortcut und Dateityp

#False if error or break
If succesfull

1 for install
2 for UpDate
3 for repair
4 for actualize
5 for uninstall ( if optionbit = 0 )
6 for install with option create a desktop shortcut
7 for install with option register filetype
8 for install with option shortcut and filetyp

Beispiel / Example

Hierzu bitte das dem Paket begefügte Programm setup_window.pb öffnen, da die Erläuterung innerhalb der Hilfe zu weit führen würden. Ich bitte um Verständis. Zu gegebener Zeit wird noch ein Beispiel zur richtigen Anwendung beigefügt.


JHRegIntroduce

Funktion JHRegIntroduce()
 Zurück Startseite Vor
Syntax

result.l = JHRegIntroduce(Name.s, BackColor.l, FrontColor.l, BackGround.l, IntroWaitTime.l, IntroMusik.s, Autor.s [NotSprite.l])

Beschreibung / Description

Diese Funktion öfnet ein Fenster für ein Introduce. Geben Sie für <Name> einen Text ein, sowie dessen Vorder- und Hintergrundfarbean. Weiterhin können Sie wählen, ob ein Bild in den Hintergrund gelegt werden soll. Für diese Funktion müssen 2 bzw. 3 Bilder in einem bestimmten Pfad abgelegt sein (siehe Beispiel). Diese Bilder sollten außerdem im eigentlichen Programm includet sein. Vergessen Sie nach Anwendung nicht, die Images wieder freizugeben. Mit <IntroWaittime> geben Sie an, wie lange nach Fertigstellung das Fenster noch angezeigt werden soll. Ist die Zeit kleiner als 0 wird endlos angezeigt. <IntroMusik> gibt den Pfad zu einer *.wav Datei an, die abgespielt werden soll. Ist der Pfad leer, wird nichts abgespielt und <Autor> kann evenfalls leer sein. Ist ein Pfad angegeben, muß auch der Autor angegeben sein. Mit dem optionalen Parameter NotSprite, dessen tatsächlicher Wert frei wählbar ist, können Sie entscheiden, ob die Ausführung mit oder ohne Sprite erfolgen soll.

English

This function open a window for Introduce. You give for <Name> a text and the color for it. You can have a background picture for the screen. If you want this option, you must give a picture by a fixed path. Please include all this two or three images in your program, look example please.

Rückgabewerte / Returns

0 bei Fehler
1 wenn erfolgreich
-1 wenn abgebrochen bei Endlosschleife

0 if Error
1 if OK
-1 if break when used endless

Beispiel

Dieses Beispiel befindet sich auch im Examples-Ordner und ist dort so lauffähig.

; Pfade zu den Bildern für das Introduce (Beispiel), diese Bilder sind mit im Paket
#Pic_0 = "bilder\setpic_001.bmp" ; Bild1 das im Intro angezeigt werden soll (110*300 Pixel)
#Pic_1 = "bilder\setpic_0010.bmp"; Bild2 das im Intro angezeigt werden soll (225*225 Pixel)
#Pic_2 = "bilder\setpic_0011.bmp"; Bild3 das Hintergrundbild im Intro (800*600 Pixel)
; schaltet das Hintergrundbild im Introfenster ein, sonst schwarz
#BackGround = #True
; die includeten Bilder nach Tempfolder kopieren. Pfad und Bildname ist vorgegeben!
tmp.s=GetTemporaryDirectory()
file1.s=tmp+"jhintro\pic_001.bmp"
file2.s=tmp+"jhintro\pic_002.bmp"
file3.s=tmp+"jhintro\pic_003.bmp"
; Ordner erstellen falls nicht vorhanden
If CreateDirectory(tmp+"jhintro"): EndIf
; Bild 1 speichern
If CatchImage(100,?SpritePic_0): SaveImage(100,file1,#PB_ImagePlugin_BMP): EndIf
; Bild 2 speichern
If CatchImage(100,?SpritePic_1): SaveImage(100,file2,#PB_ImagePlugin_BMP): EndIf
; Bild 3 speichern
If CatchImage(100,?SpritePic_2): SaveImage(100,file3,#PB_ImagePlugin_BMP): EndIf
; Image freigeben
FreeImage(100)
; Aufruf der Funktion
JHRegIntroduce("Mein eigenes Programm", RGB(255,0,0),RGB(100,100,100), #BackGround,0,"","")
; Die Introduce Bilder wieder entfernen wenn sie nicht mehr benötigt werden
tmp.s=GetTemporaryDirectory()
DeleteFile(tmp+"jhintro\pic_001.bmp")
DeleteFile(tmp+"jhintro\pic_002.bmp")
DeleteFile(tmp+"jhintro\pic_003.bmp")
; die Bilder includen, können auch eigene Bilder sein, Format ist BMP
DataSection
SpritePic_0:
IncludeBinary #Pic_0
SpritePic_1:
IncludeBinary #Pic_1
SpritePic_2:
IncludeBinary #Pic_2
EndDataSection


JHRegShowPalette

Funktion JHRegShowPalette
Syntax

result.s = JHRegShowPaletteDPI(safe.l)

Beschreibung / Description

Diese Funktion öfnet eine Fensteranordnung in der man sich über die optische Wirkung verschiedener Einstellungen der Gradientenfarbe informieren kann. Die Freigabe des Buttons <Speichern> kann über die Angabe des Wertes für <safe> erfolgen. Ist dieser ungleich 1 wird der Button nicht freigegeben.

English

This function open a window for optical control of gradient color settings. Select the savefunction with #True for <safe>.

Rückgabewerte / Returns

- einen String mit folgendem Inhalt: [Paletten-Nr.: X {R,G,B} / Paletten-Nr.: Y {R,G,B}]

- a string whith follow content: [Paletten-Nr.: X {R,G,B} / Paletten-Nr.: Y {R,G,B}]


JHRegCreateGradientImage

Funktion JHRegCreateGradientImage
Syntax

result.l=JHRegCreateGradientImage(color1.l, color2.l, number.l, direction.l, SizeX.l, SizeY.l, Image.l)

Beschreibung / Description

Erstellt einen Farbverlauf im durch die PB Nummer angegebenen Image und speichert die Datei im temporären Ordner des Rechners unter dem Namen gradient_tmp.bmp. Die Richtung des Verlaufs wird mit direction angegeben, wobei die Angabe #Null immer einen waagrechten Verlauf erzeugt und alle anderen einen horizontalen. Farbe1 und Farbe2 geben die Start und die Endfarbe an. Deren Werte können Sie mit der Funktion RGB(r,g,b) ermitteln und übergeben. Sie können die Funktion auch bei laufendem Programm aufrufen. Es wird kein CallBack verwendet. Im Beispiel ist dies dargestellt.

English

Create a gradient in the specified image and save this under the temporary path on your computer as gradient_tmp.bmp . Number set the lines, Image is the PB-Number of specified image. Direction set if it´s horizontal or vertical. If direction #Null it´s allready vertical, else horizontal.

Color1 is the startcolor and color2 is the endcolor. You can find this with the function RGB().


Shortcut

Shortcut erstellen
Funktionen zum erstellen von Short-Cut (Shell-Links).

Functions to create short-cut.

JHRegCreateShortcutFull
JHRegCreateShortcutSimply


JHRegCreateShortcutFull

Funktion JHRegCreateShortcutFull
Syntax

result.l = JHRegCreateShortcutFull (Zieldatei.s, Link.s, Parameter.s, ToolTip.s, WorkDir.s, WinSize.l, Hotkey.l, Icon.s, IconIdx.l)

Beschreibung / Description

Erstellt einen (Shell-) Link zur angegebenen Datei mit den angegebenen Spezifikationen.
Diese Funktion basiert auf einem Code von Danilo Krahn aus dem PB-Forum. Alle Angaben können selbst gemacht werden.

Wenn Sie nur eine mindest Anzahl von Parametern übergeben möchten oder benötigen können Sie auch die Funktion / If you need not all options you can use the function JHRegCreateShortcutSimply .

English

Create a *.lnk-file to the specified file with the given orders. This function is based by a code from Danilo Krahn. All specification must be write by yourself.

Link.s gibt den Name des zu erstellenden Shell Link an. Der Suffix *.lnk kann bei der Angabe entfallen. Ein falscher Suffix wird entsprechend korrigiert.

Link.s give the name for shortcutfile. The suffix *.lnk must not write into the string. A false suffix will be correctly.

WinSize.l kann folgende Werte annehmen / terms for WinSize:
SW_SHOWNORMAL = Grundeinstellung, normales Fenster
SW_SHOWMAXIMIZED = maximiertes Fenster
SW_SHOWMINIMIZED = minimiertes Fenster

Hotkey.l kann folgende Werte annehmen oder eine Kombination daraus sein:
0 = kein Hotkey
HOTKEYF_ALT= ALT key
HOTKEYF_CONTROL = CTRL key
HOTKEYF_EXT = Extended key
HOTKEYF_SHIFT = SHIFT key

IconIdx bezeichnet den Index des Icon wenn sich mehrere Icon im angegebenen Ziel befinden, z.B. wenn Sie die Systemicon benutzen. Soll das Icon der aufzurufenden Programmdatei benutzt werden, so geben Sie bitte "Null" als Index an.

Beispiel: dies wird den Schaltkreis als Icon anzeigen (WinME)
Icon.s = %SystemRoot%\system32\SHELL32.dll"
IconIdx = 12

Beispiel auf meinem eigenen System / sample from my system:

Zieldatei.s = "D:\Programme\PB400\PureBasic\purebasic.exe"; Zieldatei/-programm
Link.s = "e:\PB.lnk"; Link Ort und Name
PGMPara.s = "testen_wir_mal"; Programmparameter
ToolTip.s = "TestLink zu PB"; Tooltip
WorkDir.s = "D:\Programme\PB400\PureBasic\"; Arbeitsverzeichnis der Zieldatei
WinSize.l = #SW_SHOWMAXIMIZED; Fenstergröße beim Öffnen
Hotkey.l = 0; Hotkeys zum Programmaufruf
Icon.s = "D:\Programme\PB400\PureBasic\purebasic.exe" ; Iconfile
IconIdx.l = 0; Icon Index

Rückgabewerte / Returns

- #True wenn der Shelllink erstellt werden konnte
- #False bei Fehler

- #True if successful create
- #False at fault

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English

In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegCreateShortcutSimply

Funktion JHRegCreateShortcutSimply
Syntax

result.l = JHRegCreateShortcutSimply (Zieldatei.s, Link.s, Parameter.s, ToolTip.s, Icon.s)

Beschreibung / Description

Erstellt einen (Shell-) Link zur angegebenen Datei mit den angegebenen Spezifikationen.
Diese Funktion basiert auf einem Code von Danilo Krahn aus dem PB-Forum. Es werden nur die unbedingt notwendigen Daten übergeben. Alle anderen werden intern gesetzt.

Wenn Sie alle Optionen benötigen, nutzen Sie bitte die Funktion / If you need all options use the function JHRegCreateShortcutFull .

English

Create a *.lnk-file to the specified file with the given orders. This function is based by a code from Danilo Krahn. The important specification must be write by yourself. All other will be setting by the function.

Link.s gibt den Name des zu erstellenden Shell Link an. Der Suffix *.lnk kann bei der Angabe entfallen. Ein falscher Suffix wird entsprechend korrigiert.

Link.s give the name for shortcutfile. The suffix *.lnk must not write into the string. A false suffix will be correctly.

WinSize.l kann folgende Werte annehmen / terms for WinSize:
SW_SHOWNORMAL = Grundeinstellung, normales Fenster
SW_SHOWMAXIMIZED = maximiertes Fenster
SW_SHOWMINIMIZED = minimiertes Fenster

fest gesetzte Parameter die nicht übergeben werden müssen / fix setting parameters

Hotkey = 0 = kein Hotkey
IconIdx = 0 = erstes vorhandenes Icon in der Datei Icon.s
WinSize = #SW_ShowNormal
WorkDir = Programm Verzeichnis

Beispiel auf meinem eigenen System / sample from my system:

Zieldatei.s = "D:\Programme\PB400\PureBasic\purebasic.exe"; Zieldatei/-programm
Link.s = "e:\PB.lnk"; Link Ort und Name
PGMPara.s = "testen_wir_mal"; Programmparameter
ToolTip.s = "TestLink zu PB"; Tooltip
Icon.s = "D:\Programme\PB400\PureBasic\purebasic.exe" ; Iconfile

Rückgabewerte / Returns

- #True wenn der Shelllink erstellt werden konnte
- #False bei Fehler

- #True if successful create
- #False at fault

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English

In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


Change Values

Wandeln von Typen
Einige Funktionen zum umwandeln von Zahlen.

Some function to transform format.

JHRegBinDez
JHRegHexDez
JHRegHex32Dez
JHRegBinHex
JHRegHexBin
JHRegGetLoWord
JHRegGetHiWord


JHRegBinDez

Funktion JHRegBinDez
Syntax

result.q = JHRegBinDez(Bin.s)

Beschreibung / Description

Diese Funktion wandelt einen maxial 32 Zeichen langen String mit einer binären Zeichenfolge in eine Dezimalzahl. Die Rückgabe ist eine Ganzzahl vom Typ Quad. Dies wurde gewählt, damit eine unsignierte positive Zahl zurückgegeben werden kann.

English

This function changes a maxial 32 signs long string with a binary string into a decimal number. The return is an integer of the type Quad. This was, chosen so that one positive number can be given back to unsign.

Rückgabewerte / Returns

- der dezimale Wert der Übergabe
- Null bei Fehler oder Übergabe = 0

- the decimal value of the handing over
- Zero at fault or handing over = 0

Bin.s ist ein String

der nur 0 und 1 enthalten darf und zwischen 1 und 32 Zeichen lang sein kann. Leerzeichen sind gestattet und können zur Trennung von z.B. Nibbles benutzt werden. Das Leerzeichen ersetzt keine Null.

English

Bin.s is a string

containedly may only 0 and 1 and can be between 1 and 32 signs long. Blanks are allowed and can be used to the separation from e.g. Nibbles. The blank doesn't replace any zero.

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English

In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegBinHex

Funktion JHRegBinHex
Syntax

result.s = JHRegBinHex(Bin.s)

Beschreibung / Description

Diese Funktion wandelt einen maxial 64 Zeichen langen String mit einer binären Zeichenfolge in eine Hexadezimalzahl. Die Rückgabe ist ein String. Führende Nullen werden mit angezeigt.

English

This function changes a maxial 64 signs long string with a binary string into a hexadecimal number. The return is a string. High-order zeros are shown.

Rückgabewerte / Returns

- der hexadezimale Wert der Übergabe als String
- ein Leerstring bei Fehler

- the hexadecimal value of the handing over as a string
- an empty string at fault

Bin.s ist ein String,

der nur 0 und 1 enthalten darf und zwischen 1 und 64 Zeichen lang sein kann. Leerzeichen sind ebenfalls erlaubt und werden ausgefiltert. Diese können dazu benutzt werden, um die einzelnen Nibble oder Byte von einander zu trennen, wobei es letztlich auf die Zahl ohne Leerzeichen ankommt.

English

Bin.s is a string

containedly may only 0 and 1 and can be between 1 and 64 signs long. Blanks also are permitted and are from filtered. These can be used to separate the single nibble or byte of each other in which it depends on the number without blanks in the end to this.

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English

In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegHexBin

Funktion JHRegHexBin
Syntax

result.s = JHRegHexBin(Hex.s)

Beschreibung / Description

Diese Funktion wandelt einen maxial 16 Zeichen langen String mit einer hexadezimalen Zeichenfolge in eine Binärzahl. Die Rückgabe ist ein 64Bit Binärstring. Führende Nullen werden mit angezeigt.

English

This function changes a maxial 16 signs long string with a hexadecimal string into a binary number. The return is a string with a 64 bit binary. High-order zeros are shown.

Rückgabewerte / Returns

- der binäre Wert der Übergabe als String
- ein Leerstring bei Fehler

- the binary value of the handing over as a string
- an empty string at fault

Hex.s ist ein String,

der die Hexziffern 0 bis F enthalten darf und zwischen 1 und 16 Zeichen lang sein kann. Kleinschreibung ist erlaubt ebenso Leerzeichen zwischen den Ziffern. Letztere werden ausgefiltert.

English

Hex.s is a string

contain the hexadecimal numbers 0 to F this one may and can be between 1 and 16 signs long. Use of small initial letters is permits just blank between the numbers. The latter are from filtered.

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English

In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegHexDez

Funktion JHRegHexDez
Syntax

result.l = JHRegHexDez(Hex.s)

Beschreibung / Description

Diese Funktion wandelt einen maxial 4 Zeichen langen String mit einer hexadezimalen Zeichenfolge in eine Dezimalzahl (16 Bit). Der Rückgabewert ist vom Typ Long. Für eine 32 Bit Hexzahl verwenden Sie bitte JHRegHex32Dez() .

English

This function changes a maxial 4 signs long string with a hexadecimal string into a decimal number (16 bits). The return value is of the type long. Please, use JHRegHex32Dez () for a 32 bits hexadecimal number.

Rückgabewerte / Returns

- den dezimalen Wert der Zeichenfolge wenn erfolgreich
- 0 bei Fehler oder Übergabe = 0

- the decimal value of the handing over
- Zero at fault or handing over = 0

Hex.s ist ein String,

der nur die Hexadezimalziffern 0 - F enthalten darf und zwischen 1 und 4 Zeichen lang sein kann. Kleinschreibung wird geprüft und ist für die Hexzahlenwerte erlaubt. Leerzeichen sind als Trennzeichen erlaubt und werden gefiltert.

English

Hex.s is a string

this one only the hexadecimal number 0 - F and can be between 1 and 4 signs long. Use of small initial letters is checked and is permitted for the hexadecimal numbers. Blanks are permitted as a hyphen and are filtered.

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English

In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegHex32Dez

Funktion JHRegHex32Dez
Syntax

result.q = JHRegHex32Dez(Hex.s)

Beschreibung / Description

Diese Funktion wandelt einen maxial 8 Zeichen langen String mit einer hexadezimalen Zeichenfolge in eine Dezimalzahl (32 Bit). Für eine 16 Bit Hexzahl können Sie auch JHRegHexDez() verwenden. Der Rückgabewert ist vom Typ Quad. Dies wurde gewählt, damit die Zahlen Vorzeichenlos umgerechnet werden können.

English

This function changes a maxial 8 signs long string with a hexadecimal string into a decimal number (32 bits). Please, use JHRegHexDez () for a 16 bits hexadecimal number. The return value is of the type quad. This was chosen so that the numbers can be converted unsignedly.

Rückgabewerte / Returns

- den dezimalen Wert der Zeichenfolge wenn erfolgreich
- 0 bei Fehler oder Übergabe = 0

- the decimal value of the handing over
- Zero at fault or handing over = 0

Hex.s ist ein String,

der nur die Hexadezimalziffern 0 - F enthalten darf und zwischen 1 und 8 Zeichen lang sein kann. Kleinschreibung wird geprüft und ist für die Hexzahlenwerte erlaubt. Leerzeichen sind als Trennzeichen erlaubt und werden gefiltert.

English

Hex.s is a string

this one only the hexadecimal number 0 - F and can be between 1 and 8 signs long. Use of small initial letters is checked and is permitted for the hexadecimal numbers. Blanks are permitted as a hyphen and are filtered.

Fehlerrückgabe / Error return

Im Falle eines Fehlers wird ein String gesetzt, der mittels der Funktion JHRegLastError() separat abgefragt werden kann. Siehe Funktionsbeschreibung. Die Fehlerauswertung sollten Sie immer dann einsetzen, wenn zum Beispiel durch unbestimmte Übergaben das Ergebnis von der Erwartung abweichen könnte.

English

In the case of a fault a string which can be questioned on by means of the function JHRegLastError() separately is put. See function description. You always then should use the fault evaluation, if for example by uncertain handing over the result of the expectation could differ.


JHRegGetLoWord

Funktion JHRegGetLoWord
Syntax

result.l = JHRegGetLoWord(Zahl)

Beschreibung / Description

Diese Funktion gibt den niederwerten Teil eines Doppelwortes zurück, zum Beispiel 65535 wird 65535 zurück geben, während 65536 zur Rückgabe von 0 führen wird.

English

This function give back the low-word of a given doubleword, e.g. 65535 give back 65535, and 65536 will be 0.

Rückgabewerte / Returns

- Zahl welche die niederwertigen 4 Nibble vorkörpert
- number of low-word as long

Fehlerrückgabe / Error return

keine

English

none


JHRegGetHiWord

Funktion JHRegGetHiWord
 Zurück Startseite
Syntax

result.l = JHRegGetHiWord(Zahl)

Beschreibung / Description

Diese Funktion gibt den niederwerten Teil eines Doppelwortes zurück, zum Beispiel 65536 wird 1 zurück geben.

English

This function give back the low-word of a given doubleword, e.g. 65536 give back 1.

Rückgabewerte / Returns

- Zahl welche die höherwertigen 4 Nibble vorkörpert
- number of high-word as long

Fehlerrückgabe / Error return

keine

English

none


JHRegUniGetAllUserDocumentsPath
Die Unicode-Funktionen unterscheiden sich nur durch die Einfügung von "Uni" in den
Namen, für eine Beschreibung sehen sie bitte bei den ASCII-Funktionen nach, da der Aufwand die Hilfe entsprechend anzupassen für mich in keinem Verhältnis zum Nutzen steht, danke für Ihr Verständis.

JHRegGetAllUserDocumentsPath


JHRegUniGetAplicationPath
Die Unicode-Funktionen unterscheiden sich nur durch die Einfügung von "Uni" in den
Namen, für eine Beschreibung sehen sie bitte bei den ASCII-Funktionen nach, da der Aufwand die Hilfe entsprechend anzupassen für mich in keinem Verhältnis zum Nutzen steht, danke für Ihr Verständis.

JHRegGetAplicationPath


JHRegUniGetAutostartPath
Die Unicode-Funktionen unterscheiden sich nur durch die Einfügung von "Uni" in den
Namen, für eine Beschreibung sehen sie bitte bei den ASCII-Funktionen nach, da der Aufwand die Hilfe entsprechend anzupassen für mich in keinem Verhältnis zum Nutzen steht, danke für Ihr Verständis.

JHRegGetAutostartPath


JHRegUniGetCommonStartmenuPath
Die Unicode-Funktionen unterscheiden sich nur durch die Einfügung von "Uni" in den
Namen, für eine Beschreibung sehen sie bitte bei den ASCII-Funktionen nach, da der Aufwand die Hilfe entsprechend anzupassen für mich in keinem Verhältnis zum Nutzen steht, danke für Ihr Verständis.

JHRegCommonGetStartmenuPath


JHRegUniGetCommonStartmenuProgramsPath
Die Unicode-Funktionen unterscheiden sich nur durch die Einfügung von "Uni" in den
Namen, für eine Beschreibung sehen sie bitte bei den ASCII-Funktionen nach, da der Aufwand die Hilfe entsprechend anzupassen für mich in keinem Verhältnis zum Nutzen steht, danke für Ihr Verständis.

JHRegCommonGetStartmenuProgramsPath


JHRegUniGetDeskPathAllUsers
Die Unicode-Funktionen unterscheiden sich nur durch die Einfügung von "Uni" in den
Namen, für eine Beschreibung sehen sie bitte bei den ASCII-Funktionen nach, da der Aufwand die Hilfe entsprechend anzupassen für mich in keinem Verhältnis zum Nutzen steht, danke für Ihr Verständis.

JHRegGetDeskPathAllUsers


JHRegUniGetDesktopPath
Die Unicode-Funktionen unterscheiden sich nur durch die Einfügung von "Uni" in den
Namen, für eine Beschreibung sehen sie bitte bei den ASCII-Funktionen nach, da der Aufwand die Hilfe entsprechend anzupassen für mich in keinem Verhältnis zum Nutzen steht, danke für Ihr Verständis.

JHRegGetDesktopPath


JHRegUniGetFavoritePath
Die Unicode-Funktionen unterscheiden sich nur durch die Einfügung von "Uni" in den
Namen, für eine Beschreibung sehen sie bitte bei den ASCII-Funktionen nach, da der Aufwand die Hilfe entsprechend anzupassen für mich in keinem Verhältnis zum Nutzen steht, danke für Ihr Verständis.

JHRegGetFavoritePath


JHRegUniGetFontPath
Die Unicode-Funktionen unterscheiden sich nur durch die Einfügung von "Uni" in den
Namen, für eine Beschreibung sehen sie bitte bei den ASCII-Funktionen nach, da der Aufwand die Hilfe entsprechend anzupassen für mich in keinem Verhältnis zum Nutzen steht, danke für Ihr Verständis.

JHRegGetFontPath


JHRegUniGetPBPath
Die Unicode-Funktionen unterscheiden sich nur durch die Einfügung von "Uni" in den
Namen, für eine Beschreibung sehen sie bitte bei den ASCII-Funktionen nach, da der Aufwand die Hilfe entsprechend anzupassen für mich in keinem Verhältnis zum Nutzen steht, danke für Ihr Verständis.

JHRegGetPBPath


JHRegUniGetPBVersion
Die Unicode-Funktionen unterscheiden sich nur durch die Einfügung von "Uni" in den
Namen, für eine Beschreibung sehen sie bitte bei den ASCII-Funktionen nach, da der Aufwand die Hilfe entsprechend anzupassen für mich in keinem Verhältnis zum Nutzen steht, danke für Ihr Verständis.

JHRegGetPBVersion


JHRegUniGetPersonalPath
Die Unicode-Funktionen unterscheiden sich nur durch die Einfügung von "Uni" in den
Namen, für eine Beschreibung sehen sie bitte bei den ASCII-Funktionen nach, da der Aufwand die Hilfe entsprechend anzupassen für mich in keinem Verhältnis zum Nutzen steht, danke für Ihr Verständis.

JHRegGetPersonalPath


JHRegUniGetProgramsPath

JHRegUniGetProgramPath
Die Unicode-Funktionen unterscheiden sich nur durch die Einfügung von "Uni" in den
Namen, für eine Beschreibung sehen sie bitte bei den ASCII-Funktionen nach, da der Aufwand die Hilfe entsprechend anzupassen für mich in keinem Verhältnis zum Nutzen steht, danke für Ihr Verständis.

JHRegGetProgramsPath


JHRegUniGetSelfsetPath
Die Unicode-Funktionen unterscheiden sich nur durch die Einfügung von "Uni" in den
Namen, für eine Beschreibung sehen sie bitte bei den ASCII-Funktionen nach, da der Aufwand die Hilfe entsprechend anzupassen für mich in keinem Verhältnis zum Nutzen steht, danke für Ihr Verständis.

JHRegSelfsetPath


JHRegUniGetStartmenuPath
Die Unicode-Funktionen unterscheiden sich nur durch die Einfügung von "Uni" in den
Namen, für eine Beschreibung sehen sie bitte bei den ASCII-Funktionen nach, da der Aufwand die Hilfe entsprechend anzupassen für mich in keinem Verhältnis zum Nutzen steht, danke für Ihr Verständis.

JHRegGetStartmenuPath


JHRegUniGetStartMenuProgramsPath
Die Unicode-Funktionen unterscheiden sich nur durch die Einfügung von "Uni" in den
Namen, für eine Beschreibung sehen sie bitte bei den ASCII-Funktionen nach, da der Aufwand die Hilfe entsprechend anzupassen für mich in keinem Verhältnis zum Nutzen steht, danke für Ihr Verständis.

JHRegGetStartMenuProgramsPath


JHRegUniGetSystem32Path
Die Unicode-Funktionen unterscheiden sich nur durch die Einfügung von "Uni" in den
Namen, für eine Beschreibung sehen sie bitte bei den ASCII-Funktionen nach, da der Aufwand die Hilfe entsprechend anzupassen für mich in keinem Verhältnis zum Nutzen steht, danke für Ihr Verständis.

JHRegGetSystem32Path


JHRegUniGetSystemPath
Die Unicode-Funktionen unterscheiden sich nur durch die Einfügung von "Uni" in den
Namen, für eine Beschreibung sehen sie bitte bei den ASCII-Funktionen nach, da der Aufwand die Hilfe entsprechend anzupassen für mich in keinem Verhältnis zum Nutzen steht, danke für Ihr Verständis.

JHRegGetSystemPath


JHRegUniGetUserDesktopPath
Die Unicode-Funktionen unterscheiden sich nur durch die Einfügung von "Uni" in den
Namen, für eine Beschreibung sehen sie bitte bei den ASCII-Funktionen nach, da der Aufwand die Hilfe entsprechend anzupassen für mich in keinem Verhältnis zum Nutzen steht, danke für Ihr Verständis.

JHRegGetUserDesktopPath


JHRegUniGetWindowsPath
Die Unicode-Funktionen unterscheiden sich nur durch die Einfügung von "Uni" in den
Namen, für eine Beschreibung sehen sie bitte bei den ASCII-Funktionen nach, da der Aufwand die Hilfe entsprechend anzupassen für mich in keinem Verhältnis zum Nutzen steht, danke für Ihr Verständis.

JHRegGetWindowsPath